Bug 87523 - Table of contents issue with aligning page numbers when more than one tab is used for a TOC entry
Summary: Table of contents issue with aligning page numbers when more than one tab is ...
Status: RESOLVED DUPLICATE of bug 118960
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisectRequest, regression
Depends on:
Blocks:
 
Reported: 2014-12-20 09:17 UTC by Daniel Grigoras
Modified: 2018-07-26 16:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Demo files that illustrates the TOC issue with the alignment of the page numbers (344.43 KB, application/vnd.oasis.opendocument.text)
2014-12-20 09:17 UTC, Daniel Grigoras
Details
screen shot from 440rc1 (60.43 KB, image/png)
2014-12-21 19:25 UTC, Cor Nouws
Details
Well, take a look at how that TOC looks in version 4.3.4.1. How can I upgrade to version 4.4rc1 on Ubuntu? (121.17 KB, image/png)
2014-12-22 08:50 UTC, Daniel Grigoras
Details
Printscreen of how the TOC looks in version 4.4.1.1 of LibreOffice (172.19 KB, image/png)
2015-02-23 10:42 UTC, Daniel Grigoras
Details
Here's the TOC I'm having in mind (6.85 MB, application/vnd.oasis.opendocument.text)
2015-02-23 11:24 UTC, Daniel Grigoras
Details
Here's how the TOC I have in mind looks (178.09 KB, image/png)
2015-02-23 11:25 UTC, Daniel Grigoras
Details
Here's how the TOC should look in the "finised product". I had to use workarounds in LibreOffice and in Adobe Acrobat to have it looking that way. The workarounds did not produce pefect results. (148.15 KB, image/png)
2015-02-23 11:29 UTC, Daniel Grigoras
Details
It's quite simple Cor, LibreOffice doesn't know how to optimize things when it comes to aligning page numbers. See this screenshot. (83.35 KB, image/png)
2015-02-24 17:51 UTC, Daniel Grigoras
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Grigoras 2014-12-20 09:17:43 UTC
Created attachment 111072 [details]
Demo files that illustrates the TOC issue with the alignment of the page numbers

Hi,

LibreOffice has issues with the alignment of the page numbers in a Table of Contents with custom settings. I've added an additional tab between E# (Entry Number) and E (Entry itself). I also added an indentation to the Contents 2 and Contents 3 paragraph styles applied in the TOC to the Level 2 and Level 3 headings.
Please see the Demo file attached.
Comment 1 Adolfo Jayme 2014-12-20 14:51:11 UTC
Comment on attachment 111072 [details]
Demo files that illustrates the TOC issue with the alignment of the page numbers

(Fixing MIME type)
Comment 2 Cor Nouws 2014-12-21 19:25:02 UTC
Created attachment 111127 [details]
screen shot from 440rc1

Hi Darius,

What is the problem? I do not understand in from how it shows in 4.2.8 and 4.4.0.

thanks
Comment 3 Daniel Grigoras 2014-12-22 08:50:49 UTC
Created attachment 111167 [details]
Well, take a look at how that TOC looks in version 4.3.4.1. How can I upgrade to version 4.4rc1 on Ubuntu?
Comment 4 Cor Nouws 2014-12-22 09:34:38 UTC
(In reply to Darius Daniel Grigoras from comment #3)
> Created attachment 111167 [details]
> Well, take a look at how that TOC looks in version 4.3.4.1.

I don't see the problem on 4.3.5 (didn't try 4.3.4.x)

> How can I upgrade to version 4.4rc1 on Ubuntu?

There is a ppa for that.

I expect the problem is related to your Ubuntu version or a corrupt user profile?
  https://wiki.documentfoundation.org/UserProfile#Resolving_corruption_in_the_user_profile
Comment 5 Cor Nouws 2014-12-22 09:37:50 UTC
(In reply to Cor Nouws from comment #4)

> I don't see the problem on 4.3.5 (didn't try 4.3.4.x)

Now I did pick up 4.3.4.1 and indeed it's a problem there. So pls upgrade.

Regards,
Cor
Comment 6 Daniel Grigoras 2014-12-22 09:56:38 UTC
(In reply to Cor Nouws from comment #4)
> (In reply to Darius Daniel Grigoras from comment #3)
>
> > How can I upgrade to version 4.4rc1 on Ubuntu?
> 
> There is a ppa for that.
> 


What's the PPA for upgrading to 4.4? I couldn't find it here: https://launchpad.net/~libreoffice/+archive/ubuntu/ppa
Comment 7 Daniel Grigoras 2014-12-22 11:43:14 UTC
(In reply to Cor Nouws from comment #4)
> 
> I expect the problem is related to your Ubuntu version or a corrupt user
> profile?
>  


I've managed to updgrade to 4.4.0.1 and the TOC page number were still displayed badly, as in the screenshot attached.
The TOC page numbers were correctly aligned only after I removed my old user profile.
Comment 8 Daniel Grigoras 2015-02-23 10:42:45 UTC
Created attachment 113619 [details]
Printscreen of how the TOC looks in version 4.4.1.1 of LibreOffice
Comment 9 Daniel Grigoras 2015-02-23 10:43:57 UTC
I'm having issues again with the TOC, this time in versio 4.4.1.1 of LibreOffice. Why can't this bug be fixed once and for all?
Comment 10 Cor Nouws 2015-02-23 11:07:28 UTC
Hmm, nasty. If I insert a new TOC, it just is fine. So possibly something wrong with the older TOC definition or interpretation of that?

OK in 4.2.x
and not OK in some(?) versions of 4.3.x and 4.4.x
Comment 11 Daniel Grigoras 2015-02-23 11:24:13 UTC
(In reply to Cor Nouws from comment #10)
> Hmm, nasty. If I insert a new TOC, it just is fine. So possibly something
> wrong with the older TOC definition or interpretation of that?
> 
> OK in 4.2.x
> and not OK in some(?) versions of 4.3.x and 4.4.x

Deleting and re-inserting a TOC solves the problem with the alignment of page numbers. However, the narrow-minded people that designed the predefined settings of the default TOC thought that having the title of the heading (Entry or [E]) joined to its chapter number (Chapter Number or [E3]) is not a bad thing, and didn't mind testing someone's try at amending this. Between E# and E there should always be a T (tab), so the TOC lines should always have two tabs (T).
The TOC's problem is with managing these two tabs.
Comment 12 Daniel Grigoras 2015-02-23 11:24:40 UTC
Created attachment 113621 [details]
Here's the TOC I'm having in mind
Comment 13 Daniel Grigoras 2015-02-23 11:25:15 UTC
Created attachment 113622 [details]
Here's how the TOC I have in mind looks
Comment 14 Daniel Grigoras 2015-02-23 11:29:18 UTC
Created attachment 113623 [details]
Here's how the TOC should look in the "finised product". I had to use workarounds in LibreOffice and in Adobe Acrobat to have it looking that way. The workarounds did not produce pefect results.
Comment 15 Cor Nouws 2015-02-24 16:19:57 UTC
Hé Darius,

You're loosing me here :)
May I suggest to close this issue and open a few new issues for all the distinct wishes and problems you have?
Thanks,
Cor
Comment 16 Daniel Grigoras 2015-02-24 17:51:28 UTC
Created attachment 113652 [details]
It's quite simple Cor, LibreOffice doesn't know how to optimize things when it comes to aligning page numbers. See this screenshot.
Comment 17 Buovjaga 2015-10-03 16:47:25 UTC
REOPENED is not the correct status for this.
Comment 18 Cor Nouws 2015-10-03 18:41:10 UTC
Hi Darius,

(In reply to Darius Daniel Grigoras from comment #16)
> Created attachment 113652 [details]
> It's quite simple Cor, LibreOffice doesn't know how to optimize things when
> it comes to aligning page numbers. See this screenshot.

Is that from the same file as you attached initially?

thanks - Cor
Comment 19 Cor Nouws 2015-10-03 18:50:31 UTC
(In reply to Cor Nouws from comment #18)
> 
> Is that from the same file as you attached initially?

Looking at that one: select the whole document and choose Format > Default formatting.
All TOC entries now run over two lines.
Rightclick in TOC on Level 1 entry and choose Edit paragraph style (ToContents 1).
On Tabs, set a left tab on e.g. 1 cm and a right aligned one on 17 cm.
OK.
Do something similar for all the involved styles. :)
So let me set as WorksForMe.

For further questions and discussion pls go to 
 http://www.libreoffice.org/get-help/community-support/

Regards,
Cor
Comment 20 Daniel Grigoras 2015-10-09 10:05:25 UTC
(In reply to Cor Nouws from comment #19)

Now updated the TOC. Is the page number properly aligned to the right? No. At least not for me using LibreOffice 5.0.2.2
Comment 21 Cor Nouws 2015-10-09 10:23:05 UTC
(In reply to Darius Daniel Grigoras from comment #20)

> Now updated the TOC. 

This is not what I did advise you :)
Comment 22 Daniel Grigoras 2015-10-09 10:24:16 UTC
(In reply to Cor Nouws from comment #21)

Yeah, but it proves that LibreOffice is still damn shitty when it comes to TOCs.
Comment 23 Daniel Grigoras 2015-10-09 10:26:01 UTC
(In reply to Cor Nouws from comment #21)

I was suggested as workaround to delete my user profile. I have to delete my user profile each time I want to have the TOC properly laid out.
Comment 24 Cor Nouws 2015-10-09 10:46:21 UTC
(In reply to Darius Daniel Grigoras from comment #22)
> (In reply to Cor Nouws from comment #21)
> 
> Yeah, but it proves that LibreOffice is still damn shitty when it comes to
> TOCs.

Please stop with this nonsense. As I explained you need to set paragraph styles properly. Those are stored in the file, not a user profile.
Comment 25 Daniel Grigoras 2015-10-09 10:55:42 UTC
(In reply to Cor Nouws from comment #24)

Styles. Well I just tried using the tab settings you mentioned for the "Contents 1" style and it did not hep.
What nonsense are you talking about.
The only nonsense here would be having to manually edit the paragraph styles for each and every TOC line. That may not be a problem for an unexciting 3-line TOC, but how about doing this for a 20 or 200 line TOC, each time one needs to updated the TOC.
You should stop talking nonsense.
Comment 26 Cor Nouws 2015-10-09 11:16:08 UTC
please do all steps in comment#19

And feel free to reopen - I 'll ignore you
Comment 27 Daniel Grigoras 2015-10-09 11:54:16 UTC
(In reply to Cor Nouws from comment #26)

You mean the laborious manual workaround steps? That's not feasible with many-line TOCs.
Why do you try to deny this issue by talking about styles, when all that can be done is edit each TOC paragraph individually, which is very laborius and even not feasible if we are to think of large TOCs? I tried editing the "Contents #" styles themselves to no avail, so we cannot talk of styles, but only of individual paragraph settings.
The workaround you proposed could have been an easy thing to do if I could have selected multiple TOC lines/paragraphs and specify the necessary tabs under paragraphs settings, but when I select multiple paragraphs and try go to Paragraph->Tabs, the Tabs tab is missing. Maybe I should make a feature request to make this workaround feasible.
Comment 28 Joel Madero 2015-10-12 14:46:43 UTC
Please stop reopening bugs after they have been closed by experience QA members with a clear explanation. This bug report is quite useless at this point (way too many comments to follow it at all).

Also - next time you go down the road of being disrespectful to our QA members or any other member (using offensive language, calling LibreOffice "shitty", calling advise "nonsense" etc...) you will be banned from our infrastructure. 

If the bug is REOPENED again you will similarly be banned. https://wiki.documentfoundation.org/QA/Bugzilla/Policies_and_Procedures

"Continuously changing bug status despite input from core developers or QA people. If you have an issue with something a core dev or QA member has done - you should email the QA mailing list and wait for additional feedback."
Comment 29 Robinson Tryon (qubit) 2015-12-17 08:42:08 UTC
Migrating Whiteboard tags to Keywords: (bibisectrequest)
[NinjaEdit]
Comment 30 Timur 2018-07-26 15:46:07 UTC
This was and is a valid bug but not report. 
Saw when untangling Bug 32360 and Bug 90667.

*** This bug has been marked as a duplicate of bug 90667 ***
Comment 31 Timur 2018-07-26 16:32:03 UTC

*** This bug has been marked as a duplicate of bug 118960 ***