Download it now!
Bug 87545 - Window title retains '(read-only)' after exiting read-only mode
Summary: Window title retains '(read-only)' after exiting read-only mode
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: Other All
: low normal
Assignee: Stephan Bergmann
URL:
Whiteboard: target:5.0.0 target:4.4.4
Keywords: bibisected, bisected, regression
Depends on:
Blocks:
 
Reported: 2014-12-21 00:46 UTC by Yousuf Philips (jay) (retired)
Modified: 2015-12-17 08:42 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-12-21 00:46:24 UTC
Steps:
1) Open a document as read-only (there is a read-only checkbox in the open dialog)
2) Notice the window title has '(read-only)' next to the document name
3) Click the 'Edit Document' button in the infobar or the 'Edit File' button in the toolbar
4) '(read-only)' is still in the window title

Version: 4.5.0.0.alpha0+
Build ID: e570cd7a293ceee175949dcc9656cdf776ae3c37
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-12-12_18:49:54
Comment 1 A (Andy) 2014-12-21 08:21:02 UTC
Reproducible with LO 4.4.0.0.beta1 and 4.3.4.1 (Win 8.1).
Comment 2 Matthew Francis 2015-04-24 13:37:35 UTC
This isn't actually inherited from OOo - in fact before 3.6 the "(read-only)" went away after typing any text into the document.

This seems to be a secondary issue of the commit which caused bug 65498. I'm leaving this as a separate bug so it gets tested separately when that issue is fixed.

Adding Cc: to sbergman@redhat.com; Could you possibly take a look at this one too? Thanks
(see bug 65498 comment 4)
Comment 3 Commit Notification 2015-04-27 09:48:39 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a199cad8376a5470c50125def2738b44b55ec018

tdf#65498, tdf#87545: Don't confuse logically r/o doc with physically r/o

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2015-04-30 08:34:58 UTC
Stephan Bergmann committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9ad420fba51ee539ecf4a6cedc224e1025632f5f&h=libreoffice-4-4

tdf#65498, tdf#87545: Don't confuse logically r/o doc with physically r/o

It will be available in 4.4.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Robinson Tryon (qubit) 2015-12-17 08:42:11 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]