Download it now!
Bug 87558 - Double clicking function in Sidebar Last Used Functions duplicates it in the list
Summary: Double clicking function in Sidebar Last Used Functions duplicates it in the ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: Other All
: medium normal
Assignee: Julien Nabet
URL:
Whiteboard: target:4.5.0 target:4.3.6 target:4.4...
Keywords:
: 39764 39787 60231 70793 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-12-21 17:03 UTC by tagezi
Modified: 2015-01-07 10:10 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
the screenshot of "Last Used" list (21.08 KB, image/png)
2014-12-21 17:03 UTC, tagezi
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tagezi 2014-12-21 17:03:15 UTC
Created attachment 111117 [details]
the screenshot of  "Last Used" list

OS: Kubuntu 14.04

Problem description: Double click to the formula of the list "Last Used" of Sidebar "Function" tab results in duplicating list formulas in this list.

Steps to reproduce:
1. Open Sidebar and "Function" tab
2. Select "Last Used" in the list of categories
3. Double click to any formula

Current behavior: The formula is copied in a cell. But all names of formulas are duplicated in the last used list. It occurs every time when you double click to any formula.

Expected behavior: I think that this behavior is uncomfortable. I would like this list not to increase in this case.

I reproduced this problem in versions 4.2.7, 4.3.5 and 4.4.0.1.
Also, this problem was reproduced on MacOS and Windows.
http://forumooo.ru/index.php/topic,4638.0.html
Comment 1 raal 2014-12-21 17:34:35 UTC
I can confirm with Version: 4.5.0.0.alpha0+
Build ID: 2116f1cfb31e5fcf829c2f101cd878a32b56c365
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-12-19_05:59:03
Comment 2 Commit Notification 2014-12-21 22:08:52 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=889e20bb1f37b063032e1ab6887a309204c84868

Resolves fdo#87558: Duplication in Last Used Functions sidebar list

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Julien Nabet 2014-12-21 22:13:47 UTC
4.4 branch: https://gerrit.libreoffice.org/13582
4.3 branch: https://gerrit.libreoffice.org/13583
Comment 4 Commit Notification 2014-12-22 00:56:35 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8ef3727ea2cab81605913b866d8eaef341f26b00&h=libreoffice-4-3

Resolves fdo#87558: Duplication in Last Used Functions sidebar list

It will be available in 4.3.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2014-12-22 00:56:40 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a5e169a2f06b8ff159534a8d37e64ecb1a0f4d55&h=libreoffice-4-4

Resolves fdo#87558: Duplication in Last Used Functions sidebar list

It will be available in 4.4.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Kevin Suo 2014-12-22 11:44:26 UTC
*** Bug 39764 has been marked as a duplicate of this bug. ***
Comment 7 Kevin Suo 2014-12-22 11:46:39 UTC
*** Bug 39787 has been marked as a duplicate of this bug. ***
Comment 8 Kevin Suo 2014-12-22 11:48:01 UTC
*** Bug 60231 has been marked as a duplicate of this bug. ***
Comment 9 Kevin Suo 2014-12-22 11:48:40 UTC
*** Bug 70793 has been marked as a duplicate of this bug. ***
Comment 10 Commit Notification 2015-01-06 21:33:01 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=585ab75a9344e140c876cb7565d3525a62fb8a73

Better fix for fdo#87558: Duplication in Last Used Functions sidebar list

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2015-01-06 21:38:46 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=689afb19dc399ff3fcea07a6d264b61d10313a1e&h=libreoffice-4-4

Better fix for fdo#87558: Duplication in Last Used Functions sidebar list

It will be available in 4.4.0.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2015-01-07 10:10:55 UTC
Julien Nabet committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3cc529ccfb91444c13c771d0f8b2c1292452002f&h=libreoffice-4-3

Better fix for fdo#87558: Duplication in Last Used Functions sidebar list

It will be available in 4.3.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.