Bug Hunting Session
Bug 87590 - Table Caption option inexistent in context menu
Summary: Table Caption option inexistent in context menu
Status: RESOLVED WONTFIX
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.1 rc
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 112129 (view as bug list)
Depends on:
Blocks: Context-Menu Writer-Tables-Enhancements Caption
  Show dependency treegraph
 
Reported: 2014-12-22 12:38 UTC by Daniel Grigoras
Modified: 2019-01-21 11:09 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel Grigoras 2014-12-22 12:38:27 UTC
Where has the Add Table Caption feature gone? I can't find it in LibreOffice 4.4.0.1.
Comment 1 Jacques Guilleron 2014-12-22 18:32:34 UTC
Hi Darius Daniel Grigoras,

Insert menu, once you have inserted your table, but perhaps this isn't what you  are searching?

Jacques
Comment 2 Yousuf Philips (jay) (retired) 2014-12-23 00:03:27 UTC
It was recently removed from the right-click context menu, but is still available in the Insert menu.
Comment 3 Daniel Grigoras 2014-12-23 08:08:33 UTC
(In reply to Jay Philips from comment #2)
> It was recently removed from the right-click context menu, but is still
> available in the Insert menu.

Too bad it was removed from the Context Menu. I think that I worked faster right-clicking in a table or on a picture and adding a caption.
Comment 4 Yousuf Philips (jay) (retired) 2014-12-23 09:42:41 UTC
(In reply to Darius Daniel Grigoras from comment #3)
> Too bad it was removed from the Context Menu. I think that I worked faster
> right-clicking in a table or on a picture and adding a caption.

It is only removed from the table context menu. :D
Comment 5 Cor Nouws 2014-12-23 09:56:51 UTC
(In reply to Jay Philips from comment #4)
> (In reply to Darius Daniel Grigoras from comment #3)
> > Too bad it was removed from the Context Menu. I think that I worked faster
> > right-clicking in a table or on a picture and adding a caption.
> 
> It is only removed from the table context menu. :D

Do you try to understand what he writes?
Comment 6 sophie 2014-12-23 13:26:00 UTC
Hi Darius, if you always use captions for tables, you can set them automatically under Tools > Options > Writer > AutoCaption and check tables, pictures, etc. Sophie
Comment 7 Yousuf Philips (jay) (retired) 2014-12-23 19:26:20 UTC
(In reply to Cor Nouws from comment #5)
> Do you try to understand what he writes?

Yes i do try to understand, which is why i stated that his workflow wouldnt be hampered when he tried to add a caption to an image through the context menu.

Darius, i've requested that the caption button be added to the table toolbar to make it easier for you and others to add a table caption. I'm hoping that it will be in the final 4.4 release.
Comment 8 Cor Nouws 2014-12-23 20:15:20 UTC
(In reply to Jay Philips from comment #7)

> Yes i do try to understand, ...

If someone expresses to be not happy, then try to ask why he is not, in stead of offering alternatives that you expect will make him happy again :)
Comment 9 Daniel Grigoras 2014-12-29 08:15:07 UTC
Thank you all!
Yeah, a Caption button on the toolbar, or a checkbox under settings somewhere to enable the Caption option to be displayed in the context menu would help.
Comment 10 Yousuf Philips (jay) (retired) 2017-08-31 11:52:15 UTC
*** Bug 112129 has been marked as a duplicate of this bug. ***
Comment 11 Thomas Lendo 2017-08-31 12:49:35 UTC
Is there a reason for having NOT a context menu entry for tables but for images and drawing objects?

Space can't be the reason as stated in bug 112129.
Comment 12 Yousuf Philips (jay) (retired) 2017-08-31 15:13:34 UTC
(In reply to Thomas Lendo from comment #11)
> Is there a reason for having NOT a context menu entry for tables but for
> images and drawing objects?

Captions on tables isnt as highly used as they are on images.

> Space can't be the reason as stated in bug 112129.

Space is also an issue. :D
Comment 13 Thomas Lendo 2017-08-31 17:34:00 UTC
(In reply to Yousuf Philips (jay) from comment #12)
> (In reply to Thomas Lendo from comment #11)
> > Is there a reason for having NOT a context menu entry for tables but for
> > images and drawing objects?
> Captions on tables isnt as highly used as they are on images.
For me this is nothing else than a rumor. Is an evidence available. I use captions for images and tables, but never used it for drawing objects. There is a reason that there are own indexes for images and tables available because of the high use of captions on both tables and images.
> > Space can't be the reason as stated in bug 112129.
> Space is also an issue. :D
Can't hear this knockout argument anymore.
Comment 14 Cor Nouws 2017-09-01 08:49:32 UTC
There is room enough in the context menu, and it's not consequent - since it's available for e.g. images, and it's odd when you do not find it in the context menu, then look in the menu Table and end up in Insert - how good that may be in 'our logic'. So it's just New & Enhancement.
Comment 15 V Stuart Foote 2017-09-01 13:38:12 UTC
Closing this WF. 

Especially as with implementation of customization for Context menus this is a user's configuration choice--if you want a widget, Insert Caption in this case, add it to the context menu from Tools -> Customize... customization of the Context Menus tab.

Regards the "simplification" of menus from 4.4 onward, not a fan of revisiting these decisions one-at-a-time and not in BZ.
Comment 16 Cor Nouws 2017-09-16 10:38:03 UTC
Hi Stuart,

(In reply to V Stuart Foote from comment #15)

The possibility to add something yourself, is not a reason as such to leave something useful out the default.
It might be that some preparation of changes was nearly perfect and that some improvement comes to sight later.
But .. ;)
Comment 17 Heiko Tietze 2017-09-21 13:10:18 UTC
(In reply to Yousuf Philips (jay) from comment #12)
> Captions on tables isnt as highly used as they are on images.

Captions are demanded for tables as well. 

https://owl.english.purdue.edu/owl/resource/560/19/
"Titles. Like the title of the paper itself, each table must have a clear and concise title. When appropriate, you may use the title to explain an abbreviation parenthetically."

Also, it is repeatedly asked for this enhancement. So the request is valid.
Comment 18 Yousuf Philips (jay) (retired) 2017-09-22 09:42:43 UTC
(In reply to Heiko Tietze from comment #17)
> (In reply to Yousuf Philips (jay) from comment #12)
> > Captions on tables isnt as highly used as they are on images.
> 
> Captions are demanded for tables as well. 

They are not, as tables are commonly used simply for layout. Simple example, the 5.2 Getting Started guide[1] which has 49 tables and only 10 have captions. I've opened documents with tens of tables in them without a single caption[2][3]. Table captions are useful when a user wishes to create a index of tables.

[1] http://documentation.libreoffice.org/assets/Uploads/Documentation/en/GS5.2/GS52-GettingStartedLO.odt
[2] http://download.microsoft.com/documents/UK/Danmark/partner/EMEA_Partner_Workshop_Schedule_Dec.docx
[3] http://www.microsoft.com/investor/reports/ar13/docs/2013_Annual_Report.docx

> Also, it is repeatedly asked for this enhancement. So the request is valid.

Easy access to this function is already provided in the primary UI (the toolbar), so it will not be available in the context menu.
Comment 19 digisus 2017-09-28 16:04:29 UTC
With all due respect, I am using LO in an academic setting since v1.0. The reason I switched from Word were exactly these features. Students and academics NEED to add captions to tables as they do to images and any other object in a document:
https://duckduckgo.com/?q=scientific+writing+table+captions

Citing a few slobby formatted LO manuals (some have captions, some have not...wha??) does not help at all, they are not academic texts.

Please revert the default as it has been for years: Put back by default an "insert caption" to the table context menu. It has been there for over a decade and for good reason. 

As to the "space" argument: How about letting users decide in the preferences whether they want to have simplified menus or fully-featured menus aka basic users and power users? Academics would not mind long menus as long as they can do everything they need on the spot and most basic users hardly use captions at all.

Thanks for listening!
Comment 20 V Stuart Foote 2017-09-28 17:54:58 UTC
(In reply to digisus from comment #19)
> 
> Please revert the default as it has been for years: Put back by default an
> "insert caption" to the table context menu. It has been there for over a
> decade and for good reason. 

And why it was added to the Table Toolbar which is context sensitive and displays by default when a Table object is created or active for editing. What is new is an ability to move from static source based GUI for context menus to xml configurable interface. We no longer needed _all_ the controls as defaults. 

Personally, I use caption/title or not, depending on the document needs, likewise for figures/images. 

But there is plenty of space on Table context menus when active. Otherwise I am neutral on including Caption/Title on context menu for Table objects. Add it back if folks think it is useful enough--or leave it off the context menu, I don't care and the vast majority of users will not.

Meanwhile, it is simple to add it yourself to context menu for Tables in your own persistent user profile...

1. Tools -> Customize -> Context Menus (tab) -> Table (from droplist)
2. position the Menu content entries to where you'd like
3. click the Add Command button
4. from Insert Category, or All Categories scroll and select "Caption"
5. click the Add button

then verify the Insert Caption remains on exit relaunch of LibreOffice, it does.

Note: at 6.0 the Customize dialog is reworked and includes search capability, but similar ability to customize any of the context menus.