Download it now!
Bug 87645 - Find & Replace: no support of special characters
Summary: Find & Replace: no support of special characters
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-23 18:50 UTC by Yan Pas
Modified: 2014-12-31 11:39 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screeenshot (4.45 KB, image/png)
2014-12-24 23:25 UTC, Yan Pas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yan Pas 2014-12-23 18:50:23 UTC
MS Word allows to autoreplace special characters like "New line", "Line Break" and others, and LO Writer no. Add this feature please
Comment 1 Cor Nouws 2014-12-23 20:34:06 UTC
HI Yan,

When you create a text in Writer with for example (shift/Ctrl)Enters, images etc, select that, open Tools > Autocorrect options, fill in a name and click new, you are where you want ?
Comment 2 Yan Pas 2014-12-23 20:36:08 UTC
(In reply to Cor Nouws from comment #1)
> HI Yan,
> 
> When you create a text in Writer with for example (shift/Ctrl)Enters, images
> etc, select that, open Tools > Autocorrect options, fill in a name and click
> new, you are where you want ?

Sorry, I have meant find and replace, not autocorrection
Comment 3 Cor Nouws 2014-12-23 20:46:20 UTC
Hi Yan

Choose Options and then Regular expressions.
Click on Help for examples.

Cheers,
Cor
Comment 4 Yan Pas 2014-12-23 21:22:30 UTC
(In reply to Cor Nouws from comment #3)
> Hi Yan
> 
> Choose Options and then Regular expressions.
> Click on Help for examples.
> 
> Cheers,
> Cor

I don't see there new line symbol, only break (\n). How to remove all newlines? (enter)
Comment 5 Cor Nouws 2014-12-23 21:48:23 UTC
Honestly I don't know without searching myself ;)
Maybe you can ask at ask.libreoffice or one of the other user support possibilities?
  http://www.libreoffice.org/get-help/community-support/
Comment 6 Yan Pas 2014-12-23 23:07:19 UTC
status quo. I'm in process of searching solution. Have written to administrator of russian LO community
Comment 7 Yan Pas 2014-12-24 23:25:09 UTC
Created attachment 111304 [details]
Screeenshot

Hello!
The problem resolved, it was dollar sign. But there are two more questions.
1. It was difficult to find, because of incorrect russian translation (looks like it was translated by Google translate or even something sillier, attached screenshot)
2. The way it is implemented is too complicated. I think this bug should be feature-request anyway. It is easy to code thing, just dropdown menu where, for example, dollar sign named as "New line"
Comment 8 Yan Pas 2014-12-25 00:31:41 UTC
aaaa. Help menu paragraph is not translated fully, only part of it.  Upper part means something other.
Comment 9 Adolfo Jayme 2014-12-25 11:17:11 UTC

*** This bug has been marked as a duplicate of bug 31480 ***
Comment 10 Adolfo Jayme 2014-12-25 11:22:03 UTC
(In reply to Yan Pashkovsky from comment #7)
> 1. It was difficult to find, because of incorrect russian translation

Yan, if you can please help out with localization: https://translations.documentfoundation.org/ru/libo_help
Note that many strings are wrongly translated since the OpenOffice.org era (in various languages), and a lack of volunteers means that there is insufficient manpower to improve these.
Comment 11 Yan Pas 2014-12-25 16:12:13 UTC
I will translate, but how to find that string in the bunch of huge translations?
Comment 13 Cor Nouws 2014-12-31 10:16:56 UTC
(In reply to Yan Pashkovsky from comment #12)
> Suggested translation
> https://translations.documentfoundation.org/ru/libo_help/translate/shared/01.
> po#unit=33550592

Thanks Yan!
Can you pls make contact with the russian l10n team?
They are the best to bring your translation were it belongs.
See here http://www.libreoffice.org/community/nlc/

(more info: https://wiki.documentfoundation.org/Language#Native_Language )

Regards,
Cor
Comment 14 Yan Pas 2014-12-31 11:39:42 UTC
(In reply to Cor Nouws from comment #13)

Hello! I have always had talks with russian team and the translations are moved from suggestions to approved translation by user "bormant" (links below):
https://translations.documentfoundation.org/ru/libo_help/translate/shared/01.po#unit=33550592
https://translations.documentfoundation.org/ru/libo43_help/translate/shared/01.po#unit=78431294

According to what I see on these links - the translation must appear in the next LO release (4.3.6)