Bug Hunting Session
Bug 87647 - Error font rendering with open document with embedded font [Hard to reproduce]
Summary: Error font rendering with open document with embedded font [Hard to reproduce]
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-23 19:17 UTC by Roman Kuznetsov
Modified: 2017-12-23 21:39 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (104.99 KB, image/png)
2014-12-23 19:17 UTC, Roman Kuznetsov
Details
first doc (1.60 MB, application/vnd.oasis.opendocument.text)
2014-12-29 07:12 UTC, Roman Kuznetsov
Details
Text messed up after waiting ~30 mins in 4.3.5 (247.62 KB, image/jpeg)
2015-01-14 08:42 UTC, Buovjaga
Details
font render error in LO 4.4.0.2 (116.04 KB, image/png)
2015-01-17 16:43 UTC, Roman Kuznetsov
Details
font render error in LO 4.5+ (27.74 KB, image/png)
2015-01-17 23:42 UTC, Roman Kuznetsov
Details
font render error in LO 4.5+. font in table is OK! (37.12 KB, image/png)
2015-01-17 23:42 UTC, Roman Kuznetsov
Details
second doc (7.99 MB, application/vnd.oasis.opendocument.text-template)
2015-07-21 19:04 UTC, Gordo
Details
screenshot 4.4.4.3 (148.64 KB, image/png)
2015-07-21 19:31 UTC, Gordo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2014-12-23 19:17:38 UTC
Created attachment 111231 [details]
screenshot

LO 4.3.5.2, id build: 3a87456aaa6a95c63eea1c1b3201acedf0751bd5, OS: Windows 7 x86_64

1. Open in Writer existing text document
2. Open in Writer second document with embedded font
3. See first document ... document view was the terrible (see screenshot)
Comment 1 Roman Kuznetsov 2014-12-23 19:19:09 UTC
Close LibreOffice (all!)
Open first document again. It's OK.
Comment 2 Robinson Tryon (qubit) 2014-12-29 05:34:57 UTC
(In reply to kompilainenn from comment #0)
> 1. Open in Writer existing text document
> 2. Open in Writer second document with embedded font
> 3. See first document ... document view was the terrible (see screenshot)

Hi kompilainenn,

Please upload a sample document (or documents?) we can use to reproduce the problem. Thanks!

Status -> NEEDINFO
Comment 3 Roman Kuznetsov 2014-12-29 07:12:47 UTC
Created attachment 111456 [details]
first doc
Comment 4 Roman Kuznetsov 2014-12-29 07:18:59 UTC
second file is big. download it from http://rghost.ru/60033793

1. open first file
2. open second file
3. no action on the text does not need to produce
4. wait 20-30 minute
5. see first file. font is soured
Comment 5 Robinson Tryon (qubit) 2014-12-29 20:55:16 UTC
Comment on attachment 111456 [details]
first doc

fix mimetype
Comment 6 Buovjaga 2015-01-13 16:18:43 UTC
(In reply to kompilainenn from comment #4)
> second file is big. download it from http://rghost.ru/60033793
> 
> 1. open first file
> 2. open second file
> 3. no action on the text does not need to produce
> 4. wait 20-30 minute
> 5. see first file. font is soured

Could not reproduce on win or linux.

Win 7 64-bit Version: 4.5.0.0.alpha0+
Build ID: b3b4bbaf6cbd2226b659fea7d6ae473ccf84e9dd
TinderBox: Win-x86@39, Branch:master, Time: 2015-01-12_06:13:44

Ubuntu 14.10 64-bit Version: 4.5.0.0.alpha0+
Build ID: 7201fa0dddd7dd0352f69fd2b2b64efcb361ccad
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-01-11_23:28:55
Comment 7 Robinson Tryon (qubit) 2015-01-13 20:14:32 UTC
(In reply to Beluga from comment #6)
> Could not reproduce on win or linux.
> Win 7 64-bit Version: 4.5.0.0.alpha0+

Summary -> (Hard to repro)
Comment 8 Buovjaga 2015-01-14 08:42:06 UTC
Created attachment 112204 [details]
Text messed up after waiting ~30 mins in 4.3.5

The text did mess up after waiting about 30 mins, but not like in the screenshot by the reporter.

Win 7 64-bit, LibO 4.3.5.2
Comment 9 Roman Kuznetsov 2015-01-17 14:29:09 UTC
(In reply to Beluga from comment #8)
> Created attachment 112204 [details]
> Text messed up after waiting ~30 mins in 4.3.5
> 
> The text did mess up after waiting about 30 mins, but not like in the
> screenshot by the reporter.
> 
> Win 7 64-bit, LibO 4.3.5.2

this confirmation bug? or do you think it's not a bug?
Comment 10 Buovjaga 2015-01-17 14:35:19 UTC
(In reply to kompilainenn from comment #9)
> (In reply to Beluga from comment #8)
> > Created attachment 112204 [details]
> > Text messed up after waiting ~30 mins in 4.3.5
> > 
> > The text did mess up after waiting about 30 mins, but not like in the
> > screenshot by the reporter.
> > 
> > Win 7 64-bit, LibO 4.3.5.2
> 
> this confirmation bug? or do you think it's not a bug?

Can you test with 4.4 RC2 and 4.5 alpha?
Comment 11 Roman Kuznetsov 2015-01-17 16:43:22 UTC
Created attachment 112396 [details]
font render error in LO 4.4.0.2

Version: 4.4.0.2
ID build: a3603970151a6ae2596acd62b70112f4d376b990
Locale: ru_RU
OS: Windows 7 Home Basic x86-64

in version 4.4.0.2 bug is reproduced
Comment 12 Buovjaga 2015-01-17 20:49:16 UTC
(In reply to kompilainenn from comment #11)
> Created attachment 112396 [details]
> font render error in LO 4.4.0.2
> 
> Version: 4.4.0.2
> ID build: a3603970151a6ae2596acd62b70112f4d376b990
> Locale: ru_RU
> OS: Windows 7 Home Basic x86-64
> 
> in version 4.4.0.2 bug is reproduced

Thanks for testing. I'd like you to test with 4.5, too: http://dev-builds.libreoffice.org/daily/master/Win-x86@62-TDF/
It installs in parallel.

If you confirm that the error is gone with 4.5, we can do a bibisectRequest and some brave soul can bibisect for some hours to find, which commit fixed it.
Comment 13 Roman Kuznetsov 2015-01-17 23:41:15 UTC
in version 4.5, all became worse. (see screenshot)
I noticed that the text in the table has not changed its appearance.
this is clearly an error text is displayed.
if you try to copy a supposedly empty space in the corrupted document, when you insert it into a new document, insert the letters and should be, that is actually the text on the site.

ps: I repeat: to replicate error you just need to open one file and the second file and nothing (nothing! not even scroll through the text back and forth!) not to do! half an hour just to look at the first document and make here are (O_O) eyes =)
Comment 14 Roman Kuznetsov 2015-01-17 23:42:03 UTC
Created attachment 112408 [details]
font render error in LO 4.5+
Comment 15 Roman Kuznetsov 2015-01-17 23:42:46 UTC
Created attachment 112409 [details]
font render error in LO 4.5+. font in table is OK!
Comment 16 Roman Kuznetsov 2015-01-17 23:44:07 UTC
Version: 4.5.0.0.alpha0+
ID build: 5f6bdce0c0ac687f418821ce328f2987bf340cda
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-17_01:06:46
Locale: ru_RU
OS: Windows 7 Home Basic x86-64
Comment 17 Buovjaga 2015-01-18 09:45:15 UTC
(In reply to kompilainenn from comment #13)
> in version 4.5, all became worse. (see screenshot)

I still can't reproduce with 4.5. It seems you have changed the document after uploading here. If I go through all Внимание, I can't find an instance like in your screenshot.

Unfortunately, I can't reproduce with 4.3.3 on Linux either, so this can't be bibisected!

All my tests had +30 min waiting time.

Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: 5f6bdce0c0ac687f418821ce328f2987bf340cda
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-17_01:06:46

Ubuntu 14.10 64-bit
Version: 4.3.3.2
Build ID: 430m0(Build:2)
Comment 18 Roman Kuznetsov 2015-01-18 09:49:18 UTC
(In reply to Beluga from comment #17)
> (In reply to kompilainenn from comment #13)
> > in version 4.5, all became worse. (see screenshot)
> 
> I still can't reproduce with 4.5. It seems you have changed the document
> after uploading here. If I go through all Внимание, I can't find an instance
> like in your screenshot.
> 
> Unfortunately, I can't reproduce with 4.3.3 on Linux either, so this can't
> be bibisected!
> 
> All my tests had +30 min waiting time.
> 
> Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
> Build ID: 5f6bdce0c0ac687f418821ce328f2987bf340cda
> TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-17_01:06:46
> 
> Ubuntu 14.10 64-bit
> Version: 4.3.3.2
> Build ID: 430m0(Build:2)

Yes, the first document of the other, but it just proves that there is an error and it is not in the file. A Linux on the error not reproduced.
Comment 19 Gordo 2015-07-21 19:04:39 UTC
Created attachment 117368 [details]
second doc

The second document is no longer available from that website.  I did a search and found it on Github and it has the same hash.
Comment 20 Gordo 2015-07-21 19:31:38 UTC
Created attachment 117370 [details]
screenshot 4.4.4.3

I opened the first doc and then the second doc.  I then realised that the second doc is a template and that I had created a new document with it.  I closed that and using File -> Templates -> Manage, I imported the template and then used the Edit function.  After it had loaded, the first doc was immediately all higgledy-pigglety.

I closed everything and opened the first doc and used the template manager to edit the second doc.  It did not happen again.

Windows Vista 64
Version: 4.4.4.3
Build ID: 2c39ebcf046445232b798108aa8a7e7d89552ea8
Comment 21 tommy27 2017-04-30 07:37:14 UTC
 @kompilainenn
is this bug still reproducible using LibO 5.3.2.2?
Comment 22 tommy27 2017-05-20 16:07:19 UTC
no feeback. moving to NEEDINFO.
please retest with latest 5.3.3.2 and tell results.
Comment 23 QA Administrators 2017-12-04 12:44:50 UTC Comment hidden (obsolete)
Comment 24 Roman Kuznetsov 2017-12-23 21:39:25 UTC
don't repro in 6.0.0.1 (x64) on Windows 7 x86-64

Status -> WFM