Bug Hunting Session
Bug 87706 - DIALOG: Dialog title says 'Image Styles' when its not an image
Summary: DIALOG: Dialog title says 'Image Styles' when its not an image
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.3.4.1 release
Hardware: Other All
: medium normal
Assignee: Yousuf Philips (jay) (retired)
URL:
Whiteboard: target:4.5.0
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-25 13:42 UTC by Yousuf Philips (jay) (retired)
Modified: 2015-02-07 21:17 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-12-25 13:42:23 UTC
In LO 3.3, the 'Edit Styles' context menu option opens a dialog titled 'Graphic Styles' and then later on it was changed to 'Image Styles'. In 4.3, the styles & formatting dialog changed the style category to 'Drawing Object Styles' but the dialog title wasnt changed.
Comment 1 Yousuf Philips (jay) (retired) 2014-12-25 19:45:30 UTC
This should be a bug not enhancement.
Comment 2 Stanislav Horacek 2014-12-25 21:30:24 UTC
Confirming, this appeared in 4.3 series (tested in 4.3.4.1).
Comment 3 A (Andy) 2014-12-25 23:25:46 UTC
Reproducible with LO 4.4.0.0.beta1 and 4.3.4.1 (Win 8.1).

Steps to Reproduce:
1. Open IMPRESS
2. Insert an image and select it and make a right mouse click
3. Go to EDIT STYLE in the context menu

-> Title of the dialogue box: "Image Styles: ..."

4. Go STYLES AND FORMATTING in the Sidebar
5. Move the mouse over the left icon under title "Styles and Formatting" in this Sidebar section

-> Name: "Drawing Object Styles"
Comment 4 Yousuf Philips (jay) (retired) 2014-12-26 14:41:40 UTC
As it changed from 'Graphic Styles' to 'Image Styles' and currently 'Drawing Object Styles' is 'Drawing Object Styles' suitable to also cover image styles? I was thinking to change it to Image/Drawing Object Styles.
Comment 5 Adolfo Jayme 2014-12-27 01:40:32 UTC
(In reply to Jay Philips from comment #4)
> As it changed from 'Graphic Styles' to 'Image Styles' and currently 'Drawing
> Object Styles' is 'Drawing Object Styles' suitable to also cover image
> styles? I was thinking to change it to Image/Drawing Object Styles.

No. The initial change was wrong, as it was mass-replaced without care. Please revert it to “Graphic Styles”, which is shorter.
Comment 6 A (Andy) 2014-12-27 11:04:51 UTC
(In reply to Adolfo Jayme (UX) from comment #5)
> (In reply to Jay Philips from comment #4)
> > As it changed from 'Graphic Styles' to 'Image Styles' and currently 'Drawing
> > Object Styles' is 'Drawing Object Styles' suitable to also cover image
> > styles? I was thinking to change it to Image/Drawing Object Styles.
> 
> No. The initial change was wrong, as it was mass-replaced without care.
> Please revert it to “Graphic Styles”, which is shorter.

Do I understand it right, that you mean that the renaming from the term Graphic to Image was wrong?  If yes, why was this wrong?
Comment 7 Adolfo Jayme 2014-12-27 13:45:53 UTC
(In reply to A (Andy) from comment #6)
> If yes, why was this wrong?

Again: because the term was mass-replaced without enough care. This specific instance was a wrong change.
Comment 8 A (Andy) 2014-12-27 14:20:29 UTC
(In reply to Adolfo Jayme (UX) from comment #7)
> (In reply to A (Andy) from comment #6)
> > If yes, why was this wrong?
> 
> Again: because the term was mass-replaced without enough care. This specific
> instance was a wrong change.

Generally, I think it is good to use one notation in order to not irritate users, if there is no specific reason.  But could you maybe help me why in this specific case Graphic is better than Image, because in other dialogues we find now the term Image?  You write it is wrong in this specific instance, but why?  I only want to understand it better.  Thanks a lot in advance for your help.
Comment 9 Yousuf Philips (jay) (retired) 2014-12-27 18:28:33 UTC
Patch is in to change it to 'Graphic Styles' in dialog title and sidebar tooltip.

https://gerrit.libreoffice.org/#/c/13673/

Will postpone pushing it into master in case others have a different opinion. :D
Comment 10 Commit Notification 2015-02-07 21:03:15 UTC
Yousuf Philips committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=cf5a2811bbf5c013da3c6421ecb013137b2cc595

fdo#87706 correct object/image styles dialog title and tooltip

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.