Bug 87731 - Tag appearing in Arabic characters when change size of fonts
Summary: Tag appearing in Arabic characters when change size of fonts
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: ⁨خالد حسني⁩
Whiteboard: target:7.5.0
Depends on: HarfBuzz 104921
Blocks: RTL-Arabic-and-Farsi Kashida-Justification
  Show dependency treegraph
Reported: 2014-12-26 04:37 UTC by yousifjkadom
Modified: 2022-12-06 16:48 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:

Example (4.51 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-12-26 04:37 UTC, yousifjkadom
Artefact (1.34 KB, image/png)
2014-12-26 07:45 UTC, Urmas

Note You need to log in before you can comment on or make changes to this bug.
Description yousifjkadom 2014-12-26 04:37:21 UTC
Created attachment 111351 [details]

Hi. Please open attached file. This created my me using LibreOffice. It contain same statement repeated in 4 Arabic fonts numbered from 1 to 4. Each font included same statement in 2 sizes except 4th which in 3 sizes.
 Issue is old since version 3 when I 1st met LibreOffice & was very sever & led me to not use program. Since version 4.3.0 it became less so I started to use software really. However issue still exists but less sever.
 With Arabic characters, at certain font size - deffer according to type of font - there will appear a tag or dot at end of certain characters.
 In the attached file it appear with terminal character ج in small size line for each font except 4 font where it appear in largest font size in the character و (on character right side). If you take line of issue & change it's size to sizes that do not show issue then the tag will disappear. If you return to previous size then it will reappear.
Comment 1 Urmas 2014-12-26 07:45:33 UTC
Created attachment 111360 [details]

There are indeed pieces of kashidas appearing when font size is about 12 to 14 pt.
Comment 2 Yousuf Philips (jay) (retired) 2014-12-26 10:24:25 UTC
This reminds me somewhat of bug 70775.
Comment 3 yousifjkadom 2015-01-30 18:49:24 UTC
   Hi. I test version I note the bug occuring as following:

1) with "Time new Roman" at font size 10 or bellow.

2) with "Arial" at font size bellow 10.

3) with "Arabic Transperant" at font size bellow 10.

4) with "Simplified Arabic" at font size 10 or bellow.

5) with "Traditional Arabic" at size font = 16, 10, 9.

   Regarding "Arabic typsetting", "Simplified Arabic Fixed", I did not note the bug.

   Please confirm these data.
Comment 4 yousifjkadom 2015-07-20 08:50:23 UTC
   Hi. I test version 5.0.0 RC3 & version 4.4.5 RC1 & bug is still existing without improvement.
Comment 5 yousifjkadom 2015-08-05 17:46:34 UTC
I tested it on version but still not fixed.
Comment 6 yousifjkadom 2015-09-26 16:31:32 UTC
This bug still existing on version 5.0.2
Please fix it.
Comment 7 yousifjkadom 2016-04-30 05:55:13 UTC
Hi. I read that there is havy work on LibreOffice during May 2016:

Please consider fixing this old & long standing bug during your work in May. 

This bug is one of most bad bugs regarding support of Arabic language.
Comment 8 yousifjkadom 2016-06-23 17:37:57 UTC
Hi. Tomorrow 24 / 6 / 2016 a new bug hunting session. Please how can I assist in resolving this bug? Can I help? I live in Iraq & bitcoin not available in my country. I can use CASHU but you have no option to accept donation from UASHU.
Also, I'm not programer. Tomorrow is Frieday & it is holeday & I have time to assist but how?

If no way for me to participate, then please do not forget this bug.
Comment 9 yousifjkadom 2016-06-24 11:02:17 UTC
Hi. Any one can fix this bug?
Comment 10 yousifjkadom 2016-06-24 11:05:15 UTC
Bug still existing in version 5.1.4
Comment 11 Yousuf Philips (jay) (retired) 2016-11-07 20:24:55 UTC
At 160% zoom, i see the dash after the ج on the Simplified Arabic 18pt line.

Build ID: 11cab8aba359c655a75791ddbc0f2ffeae8ce206
CPU Threads: 2; OS Version: Linux 3.19; UI Render: default; VCL: gtk2; Layout Engine: new; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-11-06_23:07:09
Locale: en-US (en_US.UTF-8); Calc: group

With harfbuzz disabled, the dash appears at 90% zoom on the Simplified Arabic 12pt line.

Build ID: 11cab8aba359c655a75791ddbc0f2ffeae8ce206
CPU Threads: 2; OS Version: Linux 3.19; UI Render: default; VCL: gtk2; Layout Engine: old; 
TinderBox: Linux-rpm_deb-x86_64@70-TDF, Branch:master, Time: 2016-11-06_23:07:09
Locale: en-US (en_US.UTF-8); Calc: group
Comment 12 ⁨خالد حسني⁩ 2016-11-07 20:36:56 UTC
I can’t reproduce this, but I’d say it is a new bug either way.
Comment 13 Yousuf Philips (jay) (retired) 2016-11-08 11:39:25 UTC
(In reply to Khaled Hosny from comment #12)
> I can’t reproduce this, but I’d say it is a new bug either way.

Tested LO 3.3 and 4.4 and the same thing happens of it appearing and disappearing at different zoom levels.
Comment 14 yousifjkadom 2018-11-09 04:45:11 UTC
Hi. Please I'm not sure about the following & you should examine issue from your side. In addition I will continue testing & will inform you about any thing new & will find. 

The case as following: I test this issue on version fresh AppImage & it SEEM to be disappeared !! 

Then I test it on my LO on my Fedora Linux 28 X64 Cinnamon edition which came installed by default. It is version. Also, I did not suffer from it.

I did test by downloading attachment & opened it & did not see tag !!

I tried to add new statements & change size to reproduce this error but I did not face it ! 

However, it is 7:40 AM in Baghdad & I'm still waking from sleep .....

I will test it more .....

I can not trust myself that this annoying bug is fixed ! It is long lasting bug & even cause tag to appeared in PDF THOUGH no tag appeared in original office document but I did not report this in independent bug to you ......

I will see after more investigation .....
Comment 15 QA Administrators 2019-11-10 03:48:42 UTC Comment hidden (noise)
Comment 16 yousifjkadom 2019-11-12 09:27:19 UTC
Dear, currently I'm not facing this issue - as I commented before - but I can not be sure if this issue is fixed or not, since developers (Khaled Hosny) thought that he fix it but later on discovered by other developer that it is not fixed !

Please this issue need to be reviewed by more expert person than me.

I used both my Fedora 30 LO version & last available AppImage veersion. I test examples that I uploaded but I did not see the tags ....
Comment 17 yousifjkadom 2020-08-24 13:57:04 UTC
Hi. I can confirm that this bug is still existing BUT TO MUCH LIMITED AREA !

I tested it with version from FlatHub & it is only occur with the 2 character (non Arabic !) which are:

- (long - not shot - I can not add it here)
. (dote)

Specially when typing long - followed by dote like the following:
then a tag appear. 

Also, long - can appeared as fractured long -

Moreover, I noticed that these tags/fractured can overcome by override these characters by themselves !!!

It is much less destructive that before, but still need further fix to make it from the past bugs- it is still existing at lower limit.
Comment 19 Stéphane Guillou (stragu) 2022-12-06 16:48:10 UTC
I could see the artefact appear in LO 7.2 when changing font size of last line in attachment 111351 [details], but verified as fixed in:

Version: (X86_64) / LibreOffice Community
Build ID: c9e961e6803a70587bd4686d05abdd4ac11de434
CPU threads: 8; OS: Linux 5.15; UI render: default; VCL: gtk3
Locale: en-AU (en_AU.UTF-8); UI: en-US
Calc: threaded

Thanks Khaled!