Download it now!
Bug 87783 - Unifying wrap labels
Summary: Unifying wrap labels
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: medium enhancement
Assignee: Gabor Kelemen
URL:
Whiteboard: target:7.1.0
Keywords: difficultyBeginner, easyHack, skillDesign, topicDesign
: 133247 (view as bug list)
Depends on:
Blocks: Anchor-and-Text-Wrap Unify-Across-Apps
  Show dependency treegraph
 
Reported: 2014-12-28 08:41 UTC by Yousuf Philips (jay) (retired)
Modified: 2020-07-07 09:24 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-12-28 08:41:28 UTC
When you look at the labels for the wrap features between the toolbar button, context menu and image properties dialog (or the sidebar), they are not consistent. Here are some examples.

Toolbar: Wrap Off
Context: No Wrap
Dialog: None

Toolbar: Wrap Left
Dialog: Before

Toolbar: Page Wrap
Dialog: Parellel
Comment 1 Yousuf Philips (jay) (retired) 2014-12-28 09:22:43 UTC
Also 'Wrap Through' and 'In Background' should likely be changed to something more meaningful that people can easily understand like 'Above Text' and 'Behind Text'.
Comment 2 Cor Nouws 2014-12-28 20:40:15 UTC
I think this one is perfect to solve when all ideas for wrapping options, and where, have landed ?
Comment 3 Cor Nouws 2015-01-17 16:41:58 UTC
But of course: unifying is good :)
Comment 4 Yousuf Philips (jay) (retired) 2015-08-22 16:48:07 UTC
So changing the wrap labels in the sidebar can be done in sw/uiconfig/swriter/ui/sidebarwrap.ui
Comment 5 Robinson Tryon (qubit) 2016-08-25 05:38:57 UTC Comment hidden (obsolete)
Comment 6 Yousuf Philips (jay) (retired) 2017-11-28 15:01:40 UTC
Adolfo, Stuart, Sophie, Regina, Heiko: any recommendations on what we should use?
Comment 7 Heiko Tietze 2017-11-28 15:20:52 UTC
(In reply to Yousuf Philips (jay) from comment #6)
> Adolfo, Stuart, Sophie, Regina, Heiko: any recommendations on what we should
> use?

We talked about this some time ago but I dont find the minutes. 

Harmonization +1, and I prefer shorter terms with RTL in mind. So my proposal

None
Parallel
Optimal
Trough
Left
Right

That's what we have in the properties dialog, except left/right instead of before/after.
Comment 8 NISZ LibreOffice Team 2020-05-22 07:22:58 UTC
*** Bug 133247 has been marked as a duplicate of this bug. ***
Comment 9 Telesto 2020-05-22 07:33:28 UTC
Actually, is this a easy hack or something.. Would love seeing this making it into 7.0
Comment 10 Heiko Tietze 2020-05-22 08:20:31 UTC
Roman, one for you?
Comment 11 Gabor Kelemen 2020-05-24 17:14:02 UTC
Proposed patch: https://gerrit.libreoffice.org/c/core/+/94762
Comment 12 Commit Notification 2020-07-07 09:24:05 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/859e4dd6b5680e15a454fd0f8c0eae67459fe177

tdf#87783 Unify image wrap option labels wording

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.