Bug Hunting Session
Bug 87804 - PRINTING: Fit to printable page doesn't work any more
Summary: PRINTING: Fit to printable page doesn't work any more
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.3.2.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: high major
Assignee: Clément Lassieur
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-28 19:28 UTC by Robert Großkopf
Modified: 2015-06-22 15:11 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Draw-file, DIN A3, for testing this bug (10.75 KB, application/vnd.oasis.opendocument.graphics)
2014-12-28 19:28 UTC, Robert Großkopf
Details
plan of a parcel whith constructions and dimensions. A2 (13.52 KB, application/vnd.oasis.opendocument.graphics)
2015-03-26 12:09 UTC, bernadette.adam
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Robert Großkopf 2014-12-28 19:28:37 UTC
Created attachment 111435 [details]
Draw-file, DIN A3, for testing this bug

Open the attached document or open Draw.
Create a page larger than the printer could print.
Put some content on this page (left, right, up, down).
Start  File → Print → LibreOffice Draw → Size → Fit to printable page.
Up to LO 4.3.1.2 there is shown the content of the whole page in the print-preview.
Since LO 4.3.2.2 the print-preview doesn't show the whole page. And it also doesn't print the whole page. You could test this by printing to a file.

Remark:
Much of the printing-dialog is destroyed at the same time:
Distribute on multiple sheets of paper doesn't work.
Existing paperformat of the printer isn't recognized - is set to the maximum the printer could print.
Don't know if there is some more buggy behavior ...
Comment 1 Jim Franck 2014-12-29 01:24:37 UTC
When attempting to print Draw doc in legal, landscape format page content shown in print preview larger than actual page. Attempted to select "Fit to printable page" but nothing happened in the preview window. 

When I printed the doc content overflowed page. Fonts were much larger than specified in actual doc. I reverted from LibreOffice v. 4.2.8.2 back to v.4.2.6.8 (the version the doc was created in) and "Fit to printable page" worked OK again.

I took the original file created in v.4.2.6.8 and selected a text block from it. It measured 4.85" x 0.13". I pasted it onto a new blank draw doc created in v.4.2.8.2 and the text box now measured 6.81" x 1.28".

Had to trash v. 4.2.8.2 in order to be able to print.
Comment 2 vohe 2014-12-29 12:20:19 UTC
This happens to me, select any other page size than DIN A4 (german installation of Libre under Xubuntu (DE))
My Laserjet print out nothing, it seems like the pageformat "legal" is sent to him an as i insert DIN A4 paper the printer told me to change that?
Scaled output of a Document with draw on other printers fails like described before.
Comment 3 tmacalp 2015-01-02 15:09:12 UTC
This appears to be the same bug caused by the fix from bug 63905.  The same problem commit also broke Draw's ability to "Distribute on multiple sheets of paper," which was reported in bug 84051.  The commit causing this issue was implemented in 4.4.0, 4.3.2, and 4.2.7, so all branches are affected.
Comment 4 bernadette.adam 2015-03-26 12:09:15 UTC
Created attachment 114373 [details]
plan of a parcel whith constructions and dimensions. A2

Available also for 87804