Bug 87862 - SIDEBAR: Rearranging the lower half of the slide transition tab
Summary: SIDEBAR: Rearranging the lower half of the slide transition tab
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: Other All
: medium enhancement
Assignee: Katarina Behrens (CIB)
QA Contact:
URL:
Whiteboard: target:5.0.0 target:5.1.0 target:5.0...
Keywords:
Depends on:
Blocks: Sidebar-Slide-Transition
  Show dependency treegraph
 
Reported: 2014-12-30 11:41 UTC by Yousuf Philips (jay)
Modified: 2016-10-24 12:17 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
before and after (33.56 KB, image/png)
2014-12-30 11:41 UTC, Yousuf Philips (jay)
Details
Impress LO vs AOO (107.28 KB, image/png)
2014-12-30 23:57 UTC, Yousuf Philips (jay)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) 2014-12-30 11:41:48 UTC
Created attachment 111510 [details]
before and after

Looking at the bottom section of the slide transition tab, i felt it could be better organized. Mockup attached.
Comment 1 V Stuart Foote 2014-12-30 16:56:04 UTC
Yup, that would be cleaner UI...

Looks to be a simple Glade adjustment to GtkBox of:
http://opengrok.libreoffice.org/xref/core/sd/uiconfig/simpress/ui/slidetransitionspanel.ui

From lines #279 to #346, think we'd need a new GtkFrame, and a GtkLabel--"Preview", to hold the GtkButtonBox at #294, and rearrange the GtkButton objects packing/positions in that box within the new frame.
Comment 2 A (Andy) 2014-12-30 21:54:11 UTC
I like it, it looks more aligned and tidier.

On my PC (Win 8.1) LO 4.4.0.0.beta1 the Speed drop-down list box seems to be a little more left (-> a little bit wider) than the Sound drop-down list box.  From my point of view they should be aligned, that they have the same width, if possible.
Comment 3 Yousuf Philips (jay) 2014-12-30 23:57:40 UTC
Created attachment 111545 [details]
Impress LO vs AOO

I had felt that the dimmed checkbox underneath sound should have been aligned with the drop down list and after peaking at AOO, i can see that this is how it was supposed to be.

I personally find openoffice's layout much better/cleaner and here are some reasons why.

1) element padding on the left and right is not glued to the sides of the sidebar
2) separators separation sections
3) larger list of transitions shown in the list because there isnt a huge amount of space between elements

I believe that we could save space by turning the advance slide section into an entry underneath 'Modify Transition', simply by having it with the heading 'Advance:', followed by a drop down list containing 'on mouse click' and 'automatically after' and then the seconds field.
Comment 4 V Stuart Foote 2014-12-31 00:18:43 UTC
AOO uses different Windowing widgets and are way behind on conversion. In other words, this is what LO looked like when we first brought in the Sidebar. Conversion to .UI remains a work in progress, and margins and spacing can be tweaked.

Have to be careful about any effort to "save" space in the UI. l10n and i18n string translations make this a losing effort--what looks good and seems to fit in en-US gets out of whack in a hurry when translated.
Comment 5 Yousuf Philips (jay) 2015-01-01 00:19:32 UTC
(In reply to V Stuart Foote from comment #4)
> AOO uses different Windowing widgets and are way behind on conversion. In
> other words, this is what LO looked like when we first brought in the
> Sidebar. Conversion to .UI remains a work in progress, and margins and
> spacing can be tweaked.

I assumed that must have been the reason. :D I thought all the conversions were complete, or was that only for the dialogs?

> Have to be careful about any effort to "save" space in the UI. l10n and i18n
> string translations make this a losing effort--what looks good and seems to
> fit in en-US gets out of whack in a hurry when translated.

Luckily we have a resizable sidebar. :D
Comment 6 Adolfo Jayme 2015-01-11 18:36:54 UTC
(In reply to V Stuart Foote from comment #4)
> AOO uses different Windowing widgets and are way behind on conversion.

Correction: AOO has not started any “conversion”. GtkBuilder-based dialogs is a exclusive feature of LibreOffice.
Comment 7 Katarina Behrens (CIB) 2015-04-14 10:20:34 UTC
Bugzilla bot is lazy again: 

http://cgit.freedesktop.org/libreoffice/core/commit/?id=98c9887e8dfe7ea8babd6d77fc81349e1739c0d5 
and
 http://cgit.freedesktop.org/libreoffice/core/commit/?id=b12c44133549e0694e5e10bd98e9677209b89c6a

I've rearranged the frames 'n widgets as in Jay's mockup. I'm no UI designer though, feel free to improve further
Comment 8 Commit Notification 2015-04-14 11:08:07 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=b12c44133549e0694e5e10bd98e9677209b89c6a

Related tdf#87862: some HIG tweaks to slide transition panel

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Yousuf Philips (jay) 2015-04-14 21:44:56 UTC
Thanks Katarina for the fixes, but unfortunately i still have to wait for tomorrow to get a new build. I hope you were able to fix the few alignment issues shown in attachment 111545 [details], primarily the alignment of the 'loop until next sound' checkbox.
Comment 10 Yousuf Philips (jay) 2015-05-05 13:52:18 UTC
So i checked today's master build and additional tweaking needs to be done and a regression seems to have crept in, with the spacing between the speed and sound drop downs being reduced.
Comment 11 Yousuf Philips (jay) 2015-05-05 13:53:28 UTC
removing ux-advise.
Comment 12 Commit Notification 2015-05-07 10:39:01 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2a08be751d7f30d97bb8b5a6f8dfa713231acc04

tdf#87862: Row spacing sneaked out, put it back

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2015-05-31 10:46:57 UTC
Rishabh Kumar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a7b926243b300daf195467111e10a7bd481828a0

tdf#87862: Rearranging the lower half of slide transition tab

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2015-06-02 19:19:12 UTC
Rishabh Kumar committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=31407dc23c41fb7f07ed62e049a35b0da7ec9564&h=libreoffice-5-0

tdf#87862: Rearranging the lower half of slide transition tab

It will be available in 5.0.0.0.beta2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.