Bug 87871 - UI: Font drop-down is cluttered (UX)
Summary: UI: Font drop-down is cluttered (UX)
Status: RESOLVED DUPLICATE of bug 66792
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-12-30 18:37 UTC by Geoffrey
Modified: 2015-03-20 11:53 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Mockup (88.98 KB, image/png)
2014-12-31 10:04 UTC, Geoffrey
Details
How the Fonts are displayed right now (73.67 KB, image/png)
2014-12-31 10:05 UTC, Geoffrey
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Geoffrey 2014-12-30 18:37:51 UTC
There are many fonts and font variants available in LibreOffice. That is the good news.

The bad news is:
1) I can barely navigate between the fonts because I have so many
2) All font variants are listed (they are called very similar)
3) Many fonts that I never use clutter up the menu

To resolve this and create a better user experience, I suggest:

1) Put the most used fonts first
2) Group font variants under the general font name, and provide another way to select the variant (for example with an arrow with an extra menu)
3) Grouping fonts into categories (like Arabic) and let the user hide categories (I will likely never use Arabic fonts)

UX team, this is really something for you! :)
Comment 1 Joel Madero 2014-12-30 19:03:41 UTC
As this is UX according to the new procedures, moving this straight to NEW, UX can advise and close (or move it forward) as they see fit.
Comment 2 V Stuart Foote 2014-12-30 23:50:23 UTC
A review of source http://opengrok.libreoffice.org/xref/core/external/more_fonts/ shows just the following font families are built and may be deployed with LibreOffice. These fonts coupled with bundled FreeType, Graphite and HarfBuzz provide LibreOffice typography support for Latin, CJK and CTL.

We *only* bundle ;-)
Caladea
Carlito
DejaVu Sans
DejaVu Sans Mono
DejaVu Serif
Gentium Basic
Gentium Book Basic
Liberation Mono
Liberation Sans
Liberation Serif
Linux Biolinum G
Linux Libertine Display G Regular
Linux Libertine G
Open Sans
PT Serif
Source Code Pro
Source Sans Pro

The clutter most folks experience comes from the crud that builds up as programs are installed adding to whatever the OS provides. For example, my home Windows box currently has 551 font families present.

Unfortunately, for the most part we turn management of the fonts over to the OS--so you will have to use OS utilities to suppress fonts.

The Tools -> Options -> Fonts panel lets you specify substitution fonts for fonts not-present (or present) on the system. As well as to specify font to use for HTML, Basic or SQL.  But beyond those limited capabilities, we don't provide too much.

Guess there would be room to be more aggressive about reducing the clutter of too many fonts available from the system--perhaps restricting to just the LibreOffice core. But that would require some work to implement across the supported OS and various DE.  But many users would find that unacceptable UI.

Thoughts?
Comment 3 Heiko Tietze 2014-12-31 08:44:19 UTC
I think we should not mess with the list of fonts in terms of unusual sorting or the like. For example grouping by Sans, Serif, and Mono would spread DejaVu, Libertine, or Nimbus over those groups.
The question is rather why someone has 500+ font installed. It's not a big deal to remove the unused with any OS. And the first idea, to put the most used fonts first, is implemented right now (last used fonts are added at the beginning).
Comment 4 Geoffrey 2014-12-31 10:04:12 UTC
Let me clarify things further.

For example, I have the Ansana Matjax font family installed on my system.

This contains the following fonts:
Asana MathJax Alphabets
Asana MathJax Arrows
Asana MathJax DoubleStruck
Asana MathJax Fraktur
Asana MathJax Latin
Asana MathJax Main
Asana MathJax Marks
Asana MathJax Misc
Asana MathJax Monospace
Asana MathJax NonUnicode
Asana MathJax NOrmal
Asana MathJax Operators
Asana MathJax SansSerif
Asana MathJax Script
Asana MathJax Shapes
Asana MathJax Size1
Asana MathJax Size2
Asana MathJax Size3
Asana MathJax Size4
Asana MathJax Size5
Asana MathJax Size6
Asana MathJax Symbols
Asana MathJax Variants

What I suggest, is that you list Asana MathJax and let the user choose between the variants in another way, for example with a floating menu.

See the mockup.
Comment 5 Geoffrey 2014-12-31 10:04:35 UTC
Created attachment 111564 [details]
Mockup
Comment 6 Geoffrey 2014-12-31 10:05:03 UTC
Created attachment 111565 [details]
How the Fonts are displayed right now
Comment 7 Yousuf Philips (jay) 2014-12-31 11:33:17 UTC
Yes font weights arent grouped in LO correctly. Bug 66792 is an enhancement attempting to move some of the font variants under a submenu, similar to Geoffrey's mockup.
Comment 8 Yousuf Philips (jay) 2015-03-20 11:53:38 UTC
Setting this as a duplicate as Geoffrey's mockup is the same as the mockup presented in the duplicate bug (attachment 83035 [details]).

*** This bug has been marked as a duplicate of bug 66792 ***