Download it now!
Bug 87957 - FILEOPEN: hyperlinks not wrapping correctly in .xlsx file
Summary: FILEOPEN: hyperlinks not wrapping correctly in .xlsx file
Status: RESOLVED DUPLICATE of bug 39910
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-02 05:32 UTC by vkmr2012
Modified: 2015-10-16 19:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Excel 2007 file with internal hyperlinks (19.62 KB, application/xls)
2015-01-02 05:33 UTC, vkmr2012
Details
Excel 2007 file opened in excel - screen shot (47.69 KB, image/png)
2015-01-02 05:34 UTC, vkmr2012
Details
Excel 2007 file opened in LO Calc - screen shot (131.71 KB, image/png)
2015-01-02 05:34 UTC, vkmr2012
Details
Excel 2007 file opened in LO Calc Version: 4.3.5.2 - screen shot (127.31 KB, image/png)
2015-01-03 04:47 UTC, vkmr2012
Details

Note You need to log in before you can comment on or make changes to this bug.
Description vkmr2012 2015-01-02 05:32:26 UTC
I am submitting excel 2007 file with internal hyperlinks to sheets. when this file is opened in LO Calc, then cell contents are incorrectly rendered and hyperlinks point to incorrect sheets.
Comment 1 vkmr2012 2015-01-02 05:33:18 UTC
Created attachment 111633 [details]
Excel 2007 file with internal hyperlinks
Comment 2 vkmr2012 2015-01-02 05:34:03 UTC
Created attachment 111634 [details]
Excel 2007 file opened in excel - screen shot
Comment 3 vkmr2012 2015-01-02 05:34:46 UTC
Created attachment 111635 [details]
Excel 2007 file opened in LO Calc - screen shot
Comment 4 Rostislav 'R.Yu.' Okulov 2015-01-02 08:37:08 UTC
LO 4.3.5 works just fine, but without linebraks.

WORKSFORME?
Comment 5 Cor Nouws 2015-01-02 17:20:38 UTC
Hi vkmr,

Do you see the problem in 4.2.0.4 - which is a rather old version, or also in later versions and did you check that 4.2.0.4 is the first with the problem?
thanks,
Cor
Comment 6 vkmr2012 2015-01-03 04:45:54 UTC
With LO Version: 4.3.5.2
Cell contents are rendering correctly.
Internal Hyperlinks are preserved.
But I am still facing the following issues -
(1) Existing cell contents are not wrapping as per the cell boundary.
(2) I am not able to edit existing contents, neither by pressing F2 Key, nor in the formula bar.
(3) If I force overwrite existing content by typing something new, then hyperlinks are lost.
Comment 7 vkmr2012 2015-01-03 04:47:51 UTC
Created attachment 111679 [details]
Excel 2007 file opened in LO Calc Version: 4.3.5.2 - screen shot
Comment 8 Buovjaga 2015-02-22 17:01:23 UTC
Hey, could you edit the title of this bug to correspond to one of the remaining issues? You should create new reports for every other issue.

Set to UNCONFIRMED after editing.
Comment 9 vkmr2012 2015-02-23 03:08:11 UTC
See also closely related Bug 89424 .
It is generic behavior of the LO Calc, which to wrong and must change.
Comment 10 vkmr2012 2015-02-23 03:09:37 UTC
> It is generic behavior of the LO Calc, which to wrong and must change.
It is generic behavior of the LO Calc, which ^is^ wrong and must change.
Comment 11 Buovjaga 2015-02-23 06:29:14 UTC
Changed the title to be about the incorrect wrapping as your Bug 89424 covers the hyperlink editing.

For now, you can edit the hyperlinks like this:
1) Be in a cell with a hyperlink (don't press F2 or edit it)
2) Insert - Hyperlink
3) Edit the link text and press OK

Confirmed incorrect wrapping using:
Win 7 Pro 64-bit, LibO Version: 4.4.0.3
Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7
Locale: fi_FI
Comment 12 Buovjaga 2015-10-16 19:25:19 UTC
Actually this can be closed as dupe, as hyperlink wrapping is broken everywhere.

*** This bug has been marked as a duplicate of bug 39910 ***