Bug Hunting Session
Bug 88058 - Text formatted with only styles and manually is not visually different
Summary: Text formatted with only styles and manually is not visually different
Status: RESOLVED DUPLICATE of bug 106556
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Styles
  Show dependency treegraph
 
Reported: 2015-01-05 15:16 UTC by belomir
Modified: 2019-01-03 13:14 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
highlight direct formatting concept (63.24 KB, application/vnd.oasis.opendocument.text)
2015-01-17 13:38 UTC, belomir
Details

Note You need to log in before you can comment on or make changes to this bug.
Description belomir 2015-01-05 15:16:19 UTC
Problem description: 

When I want to format text with only styles, formatting panels is definitely evil.
When I get complete text that was formatted with both mixed styles and manual, I can use cancel formatting feature (ctrl+m) to clear all manual formatting and get only styles.
But text is not different when it have only style properties or some formatting functions was added after style by manipuating with panels.

The same trouble in visual line is in styles with inherited or changed options.

Steps to reproduce (paragraph exaxmple):
1. apply style to par
2. change par properties to some unequal to style and get them back manually

Current behavior:
both paragraphs: manually changed and styled are looking the same


Expected behavior:

There must be some instrument to visualize the difference in manually formatting and styles only formatting pieces (paragraphs and chars).
Comment 1 Robinson Tryon (qubit) 2015-01-15 08:40:59 UTC
Jay: Perhaps you can provide some insight here?
Thanks!
Comment 2 Yousuf Philips (jay) (retired) 2015-01-16 22:22:18 UTC
Though i see very little use cases to this, maybe text which has direct formatting applied to it can appear in a different color than text which only uses styles, but this setting would not be enabled by default.

I know MSO has a style inspector (attachment 102031 [details]) which shows the paragraph and character level styles and direct formatting applied to text.
Comment 3 belomir 2015-01-17 13:38:49 UTC
Created attachment 112391 [details]
highlight direct formatting concept

I wrote a little macro for demonstration.
I don't know how to make such the instrument and how to use it: should it have ability to select all of direct formatted objects, should it count them etc.
Comment 4 Robinson Tryon (qubit) 2015-01-17 20:19:54 UTC
This is in UX-advise for triage, so:
Status -> NEW
Comment 5 Robinson Tryon (qubit) 2016-08-25 04:21:36 UTC Comment hidden (obsolete)
Comment 6 David 2017-06-19 01:39:46 UTC
Might this issue be solved if a solution for bug 34002 was developed?
Comment 7 Yousuf Philips (jay) (retired) 2017-06-20 19:01:09 UTC
(In reply to David from comment #6)
> Might this issue be solved if a solution for bug 34002 was developed?

No dont think reveal codes is a suitable solution for this issue.
Comment 8 Timur 2019-01-03 09:15:29 UTC
Seems like solution for Bug 106556 would solve the need.
I'll mark as a duplicate but let CC'ed UX gives a comment here.

*** This bug has been marked as a duplicate of bug 106556 ***
Comment 9 Heiko Tietze 2019-01-03 11:26:40 UTC
(In reply to Timur from comment #8)
> Seems like solution for Bug 106556 would solve the need.

Yes, and there is another aspect discussed at bug 115311 with a mockup how it could be solved.