Download it now!
Bug 88066 - UI status line insert/overwrite mode display broken
Summary: UI status line insert/overwrite mode display broken
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.6.0.4 release
Hardware: x86-64 (AMD64) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: target:7.1.0
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-05 19:44 UTC by Peter Eisentraut
Modified: 2020-06-08 16:31 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot (7.88 KB, image/png)
2015-01-05 19:44 UTC, Peter Eisentraut
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Eisentraut 2015-01-05 19:44:22 UTC
Created attachment 111781 [details]
screenshot

In the status bar, the field to the right of the language field should display "INSRT" or "OVER", according to <https://help.libreoffice.org/Common/Switching_Between_Insert_Mode_and_Overwrite_Mode>. For me, it's empty; see attached screenshot.  Hovering over the area produces a tooltip "Insert mode."  Wild clicking on the empty space (sometimes double, sometimes single) changes the displayed text to "Overwrite" (and actually activates overwrite mode).  More wild clicking changes back to insert mode and makes the status bar field blank again.

Obviously, this is highly weird.  Also, since there is no "Insert" key on OS X, enabling overwrite mode is a bit difficult.

This is also discussed in this thread: <http://en.libreofficeforum.org/node/5946>.
Comment 1 Cor Nouws 2015-01-05 20:37:05 UTC
Confirmed.
Comment 2 QA Administrators 2016-09-20 09:38:17 UTC Comment hidden (obsolete)
Comment 3 Peter Eisentraut 2016-09-27 01:20:18 UTC
The bug is still present in 5.2.1.2 on Mac OS X.
Comment 4 Xisco Faulí 2017-09-29 08:53:52 UTC Comment hidden (obsolete)
Comment 5 Peter Eisentraut 2018-01-21 00:17:44 UTC
The bug is still present in 5.4.4.2 on macOS.
Comment 6 QA Administrators 2019-01-22 03:41:17 UTC Comment hidden (obsolete)
Comment 7 Cor Nouws 2019-01-22 15:03:31 UTC
still a problem in Version: 6.3.0.0.alpha0+
Build ID: b8e450a54936560cdac00ab4c70ef80c20cfaf99
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
TinderBox: Linux-rpm_deb-x86_64@86-TDF, Branch:master, Time: 2019-01-18_06:04:42
Locale: nl-NL (nl_NL.UTF-8); UI-Language: en-US
Calc: threaded

That's (again) on Linux > OS = All
OK in 3304 - not OK in 4062 > regression
Comment 8 Buovjaga 2020-06-05 13:21:04 UTC
Bibisected with 43all Linux repo to range https://git.libreoffice.org/core/+log/67ff63988f3b8eef2cc2b5bdf917918b93c3f070..877c96a601e6e50d0c7a8f704d57baec22f089c5
This certainly jumps out:
https://git.libreoffice.org/core/+/b30e202861e9bdba4d86e76ba8a6f059da8efc31%5E%21/

> status bar: INSRT/OVER -> 'Overwrite' shown only when in overwrite mode.
> 
> Idea by Mirek M. - thank you!  Additionally introduced a tooltip showing more
verbose text when in overwrite mode.

So this is not a bug, but a feature. Nobody updated the documentation to match the change.

Due to this problem the topic might be discussed by the UX team again after these 8 years:
(In reply to Peter Eisentraut from comment #0)
> Obviously, this is highly weird.  Also, since there is no "Insert" key on OS
> X, enabling overwrite mode is a bit difficult.
Comment 9 Heiko Tietze 2020-06-08 09:59:13 UTC
Isn't it a duplicate of bug 107918?
Comment 10 Buovjaga 2020-06-08 10:04:39 UTC
(In reply to Heiko Tietze from comment #9)
> Isn't it a duplicate of bug 107918?

You are right that the macOS concern is addressed in that.

I guess I will close and fix the help later.
Comment 11 Peter Eisentraut 2020-06-08 11:45:16 UTC
Confirmed that it works now in 6.4.1.2.
Comment 12 Commit Notification 2020-06-08 16:31:22 UTC
Ilmari Lauhakangas committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/help/commit/33f5cf993af2d3a08eb2b12abef53d5393a00bfc

tdf#88066 Update help on switching between insert and overwrite mode