Download it now!
Bug 88078 - Color-selector drop-downs inaccessible from non-visible toolbar icons (in the >> menu)
Summary: Color-selector drop-downs inaccessible from non-visible toolbar icons (in the...
Status: RESOLVED DUPLICATE of bug 42029
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: framework (show other bugs)
Version:
(earliest affected)
4.4.0.0.beta2
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-06 00:13 UTC by Jim Avera
Modified: 2015-01-07 09:02 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Avera 2015-01-06 00:13:19 UTC
If there is not enough space for all icons in a toolbar, they appear in a menu which can be displayed by clicking the ">>" symbol at the right edge.  However, if any of these are themselves a color-selctor drop-down (e.g. font color or background color), then clicking them does not drop-down the sub-menu, but arbitrarily uses whatever color was selected when the sub-menu was previously used.

This occurs in Writer and Calc (haven't tried other apps).

STEPS TO REPRODUCE:

1. Open a new writer doc (run 'swriter')
2. If necessary, enable the Background Color icon in View->Toolbars->Customize->Formatting
3. Make the app window wide enough to see the "Background Color" icon
4. Enter two paragraphs (e.g. foo<ENTER>bar<ENTER>)
   Select text in the first paragraph and set background to, say, PINK
5. Make the window narrow enough that the "Background Color" icon won't fit
6. Select text in the second paragraph (the one with white background)
7. Click the ">>" at the right edge of the formatting toolbar.  
8. Click the "Background Color" icon

ACTUAL RESULTS:  The background is immediately set to PINK (whatever was last used).

EXPECTED RESULTS: The color-select drop-down should appear so the user can select the desired color.
Comment 1 Adolfo Jayme 2015-01-07 09:02:24 UTC
Thanks for your bug report. This is a known problem and is already reported as bug 42029, so Iā€™m marking this one as a duplicate.

*** This bug has been marked as a duplicate of bug 42029 ***