Bug Hunting Session
Bug 88101 - kde file dialog is not modal, so can close parent window while still open -> SIGSEGV
Summary: kde file dialog is not modal, so can close parent window while still open -> ...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Dialog
  Show dependency treegraph
 
Reported: 2015-01-06 10:34 UTC by Caolán McNamara
Modified: 2019-01-28 20:07 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Caolán McNamara 2015-01-06 10:34:09 UTC
file->open, leave the kde file dialog open and try and close the parent application window.

The window can be closed, leaving the child dialog running. The dialog should be modal and not allow that.

causes crash of https://bugzilla.redhat.com/show_bug.cgi?id=1174265
Comment 1 Caolán McNamara 2015-06-04 10:09:44 UTC
hmph, _dialog->setModal( true );, _dialog->setWindowModality(Qt::ApplicationModal); have no effect on this and KWindowSystem::setMainWindow is called with the xid of the toplevel frame window. Dunno why that doesn't work, *throw hat at it*
Comment 2 Katarina Behrens (CIB) 2015-07-06 08:24:20 UTC
@Jürgen: you might be interested in this bug, it's still present in 5.0 

(not sure about SIGSEGV part of it, but for sure file picker dialogs ain't modal)
Comment 3 QA Administrators 2016-09-20 10:14:11 UTC Comment hidden (obsolete)
Comment 4 Michael Weghorn 2019-01-28 20:07:23 UTC
The kde4 VCL plugin has recently been removed from master and I can't reproduce with either kde5 or gtk3_kde5; file dialogs are modal there.

Closing as WORKSFORME.