Bug 88229 - Crash Calc when you try to create a bar chart GL3D
Summary: Crash Calc when you try to create a bar chart GL3D
Status: RESOLVED DUPLICATE of bug 82693
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.0.1 rc
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard: target:4.5.0 target:4.4.1
Keywords:
: 90817 (view as bug list)
Depends on:
Blocks: Impress-OpenGL
  Show dependency treegraph
 
Reported: 2015-01-09 09:56 UTC by Roman Kuznetsov
Modified: 2015-11-29 17:58 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
OpenGL bar in LO 4.4.2.1 (46.00 KB, image/png)
2015-03-17 19:37 UTC, Roman Kuznetsov
Details
console logs (2.21 KB, text/plain)
2015-11-09 20:17 UTC, Julien Nabet
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2015-01-09 09:56:56 UTC
Version: 4.4.0.2
ID build: a3603970151a6ae2596acd62b70112f4d376b990
Locale: ru_RU
OS: Windows 7 x86-64

1. Create new Calc spreadsheet
2. Insert-Chart
3. Select type chart "bar GL3D"
4. LO is crashed
Comment 1 MM 2015-01-09 13:06:35 UTC
Confirmed with Version: 4.4.0.1 Build ID: 1ba9640ddd424f1f535c75bf2b86703770b8cf6f on mint 17.1 x64.
Comment 2 Commit Notification 2015-01-23 15:13:01 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=05e7b1db351ee964d155e49c55de7db3c917083f

Resolves: fdo#88229 Crash when you try to create a bar chart GL3D

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Commit Notification 2015-01-25 10:22:06 UTC
Caolán McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8eef38d87d5a876b9628355289ab6ddf9915db89&h=libreoffice-4-4

Resolves: fdo#88229 Crash when you try to create a bar chart GL3D

It will be available in 4.4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 MM 2015-02-15 02:15:39 UTC
Still crashing with *all* LO components.

Mint 17.1 x64 Version: 4.4.1.1
Build ID: b5ac74bf8683a92078a2bc8aff97d4b436af63cb

Tried it with a clean profile, still crashing while selecting GL3D bar.
Comment 5 Caolán McNamara 2015-02-15 20:31:29 UTC
And not for me, though the crash I could experience is gone. so un-assigning from me.
Comment 6 m.a.riosv 2015-02-26 22:08:48 UTC
I can reproduce also.
Win7x64
Version: 4.4.1.1 Build ID: b5ac74bf8683a92078a2bc8aff97d4b436af63cb

Graphics data:
Versión del paquete de controladores	8.672.3-091111a-092448C-Acer	
Versión de Catalyst	11.7	
Proveedor	ATI Technologies Inc.	
Versión de controlador 2D	8.01.01.973	
Ruta de archivo de controlador 2D	/REGISTRY/MACHINE/SYSTEM/ControlSet001/Control/CLASS/{4D36E968-E325-11CE-BFC1-08002BE10318}/0000	
Versión de Direct3D	8.14.10.0708	
Versión de OpenGL	6.14.10.9117	
Versión de Catalyst Control Center	2011.0707.2346.40825
Comment 7 Roman Kuznetsov 2015-03-17 19:37:37 UTC
Created attachment 114156 [details]
OpenGL bar in LO 4.4.2.1

in version 4.4.2.1 fow Windows this bug not reproduced. but the chart looks abnormal (see attach)
Comment 8 raal 2015-04-23 17:15:39 UTC
*** Bug 90817 has been marked as a duplicate of this bug. ***
Comment 9 MM 2015-05-14 22:17:53 UTC
Well I don't have the crash under ubuntu 14.04 / 15.04 or win 7, but only on mint 17.1 x64. I completely removed LO 4.4 and then reinstalled it (and clean profile). But the crash is still there.
Comment 10 MM 2015-05-24 00:16:33 UTC
Somehow it now also crashes on ubuntu 14.04 x64 with v4.4.3.2 and v5.0.0.0 b1.
Comment 11 baffclan 2015-11-03 10:13:34 UTC
dup/related to 82693?
Comment 12 MM 2015-11-07 23:24:13 UTC
(In reply to baffclan from comment #11)
> dup/related to 82693?

Normally a segfault is linux only ?! This one is also confirmed on windows.
And with this one there's no 'Runtime Error/Pure virtual function' error.
Comment 13 baffclan 2015-11-09 02:52:40 UTC
(In reply to MM from comment #12)
> (In reply to baffclan from comment #11)
> > dup/related to 82693?
> 
> Normally a segfault is linux only ?! This one is also confirmed on windows.
> And with this one there's no 'Runtime Error/Pure virtual function' error.

Bug 82693 is not only linux.
see bug 85753.
Comment 14 Julien Nabet 2015-11-09 20:17:56 UTC
Created attachment 120426 [details]
console logs

On pc Debian x86-64 with master sources updated today, I got the console logs attached with SAL_USE_VCLPLUGIN=gen or SAL_USE_VCLPLUGIN=gtk
Comment 15 Julien Nabet 2015-11-09 20:22:51 UTC
And same bt as https://bugs.documentfoundation.org/show_bug.cgi?id=82693#c8 with SAL_USE_VCLPLUGIN= (so by default value, in my case gtk3)
Comment 16 Julien Nabet 2015-11-09 20:23:33 UTC
I suppose it's a dup then.

*** This bug has been marked as a duplicate of bug 82693 ***