Download it now!
Bug 88267 - Page orientation doesn't export to .doc/.docx correctly
Summary: Page orientation doesn't export to .doc/.docx correctly
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.3.3.1 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc, filter:docx
Depends on:
Blocks:
 
Reported: 2015-01-10 14:08 UTC by Matthew Francis
Modified: 2016-07-24 17:51 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Sample file with mixed portrait / landscape pages (8.23 KB, application/vnd.oasis.opendocument.text)
2015-01-10 14:09 UTC, Matthew Francis
Details
Source file in odt (15.40 KB, application/vnd.oasis.opendocument.text)
2015-02-12 14:17 UTC, ksb
Details
Destination file in docx (10.40 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2015-02-12 14:19 UTC, ksb
Details
Sample file - page break dialog (29.30 KB, image/jpeg)
2015-06-16 15:19 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Francis 2015-01-10 14:08:23 UTC
Saving a file with mixed portrait/landscape page orientation to .doc/docx doesn't preserve the orientation correctly

Steps to reproduce:
1. Load the attached .ods, which has one portrait and one landscape page
2. Save as .doc/.docx
3. Reopen the saved file

Expected results:
- Page orientation is preserved

Actual results:
- All pages have portrait orientation (current master)
- All pages have landscape orientation (3.3.0)



(Not sure whether or not two bugs would be more helpful for this. For .docx the issue started in 3.3.0 where support was implemented, while for .doc this is inherited from OOo)
Comment 1 Matthew Francis 2015-01-10 14:09:00 UTC
Created attachment 112057 [details]
Sample file with mixed portrait / landscape pages
Comment 2 Robinson Tryon (qubit) 2015-01-11 22:12:12 UTC
TESTING on Ubuntu 14.04 + LO 4.4.0.2 rc

(In reply to Matthew Francis from comment #0)
> Steps to reproduce:
> 1. Load the attached .ods, which has one portrait and one landscape page
> 2. Save as .doc/.docx
> 3. Reopen the saved file
> 
> Expected results:
> - Page orientation is preserved
> 
> Actual results:
> - All pages have portrait orientation (current master)
> - All pages have landscape orientation (3.3.0)

CONFIRMED: Both pages have portrait orientation (with both DOC and DOCX format).

I've filed a separate bug 88303 - FILESAVE: File -> Save a Copy does not warn user about potential data loss when using non-ODF format

> (Not sure whether or not two bugs would be more helpful for this. For .docx
> the issue started in 3.3.0 where support was implemented, while for .doc
> this is inherited from OOo)

Good question. Either way the bug is there, so:
Status -> NEW

IF this turns out to be a limitation of the DOC/DOCX file format, please add 'doc-limitations' and 'docx-limitations' (as appropriate) to the 'Blocks' field.
Comment 3 Timur 2015-01-20 12:11:57 UTC
(In reply to Matthew Francis from comment #1)
> Created attachment 112057 [details]
> Sample file with mixed portrait / landscape pages

Reproducible with the attached .odt, but NOT reproducible from scratch creating simple document with Insert- Page break - Landscape. Please specify how this example was created and in which version.
Comment 4 ksb 2015-02-09 10:44:03 UTC
Similar to 75431, maybe duplicate?
Comment 5 ksb 2015-02-10 11:01:16 UTC
OK, 75431 is closed now. I have also one .odt, saving to .docx makes all pages portrait. Are You interested in it?
Comment 6 Timur 2015-02-10 12:03:24 UTC
Please attach it, and in the comment write exact steps how it was created, if you know, at least with which LO version and which OS. Also, try to reproduce with the current LO 4.3.6 and 4.4.0. In Windows, you may use "Separate Install GUI".
Comment 7 ksb 2015-02-12 14:17:30 UTC
Created attachment 113343 [details]
Source file in odt

Originally made with MS Office 2011 for Mac OS X (docx). Then LO 4.3 involved (Windows) and saved as odt (problem appears already here if saving to docx).
Last step - cleaned up and prepared for reporting in LO 4.4 (Mac OS X).
Comment 8 ksb 2015-02-12 14:19:22 UTC
Created attachment 113344 [details]
Destination file in docx

Saved from odt to docx in LO 4.4 on Mac OS X (same on 4.3 (Win)).
Comment 9 Timur 2015-02-12 16:59:18 UTC
This bug is about saving ODT to DOC/DOCX. 
Problem seems to be "page break". That should be found in the document source. And that problem for both DOC and DOCX looks like started from 4.3.3.1 (not inherited, so I change that). Otherwise, bug is not easily reproducible. 

Your problem might be a new bug. 
Anyway, please attach there the "original DOCX made with MS Office 2011 for Mac OS X" in the 1st step. If I understand well, what you call "Source file in ODT" is not source, but it's ODT converted from DOCX in 2nd step. And destination is 3rd step. You may also rename and re-upload all 3 files and replace those 2, for the sake of clarity. They still may be used in another bug.
Comment 10 Timur 2015-06-16 15:19:19 UTC
Created attachment 116587 [details]
Sample file - page break dialog

(In reply to Timur from comment #3)
> (In reply to Matthew Francis from comment #1)
> > Created attachment 112057 [details]
> > Sample file with mixed portrait / landscape pages
> 
> Reproducible with the attached .odt, but NOT reproducible from scratch
> creating simple document with Insert- Page break - Landscape. Please specify
> how this example was created and in which version.

Page break dialog from sample file attachment 112057 [details] has "insert break" but it doesn't have "with page style Landscape", like a normal document created from scratch. So, when saved as doc/docx, it also doesn't have page style Landscape.
Comment 11 Timur 2015-06-16 15:20:31 UTC
We need to know how this sample file was created and in which version, or this should be closed as NotABug.
Comment 12 Robinson Tryon (qubit) 2015-12-14 06:01:43 UTC
Migrating Whiteboard tags to Keywords: (filter:doc filter:docx)
[NinjaEdit]