Bug 88276 - Please add UI for new LO 4.4. feature "Text Background Color in Draw"
Summary: Please add UI for new LO 4.4. feature "Text Background Color in Draw"
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.4.0.1 rc
Hardware: Other All
: high major
Assignee: Katarina Behrens (CIB)
QA Contact:
URL:
Whiteboard: target:5.1.0 target:5.0.0.0.beta2
Keywords:
: 95050 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-01-10 18:04 UTC by Gerry
Modified: 2016-10-25 19:17 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Gerry 2015-01-10 18:04:49 UTC
LibreOffice 4.4 release notes announce the great new feature "Text Background Color in Draw" (https://wiki.documentfoundation.org/ReleaseNotes/4.4#Text_background_color). However, the feature does not exist in LO 4.4RC1.

Matteo's blog (https://matteocam.github.io/output/category/gsoc-draw-text-background-color.html) shows that the feature apparently is there in LibreOffice, but "this feature still has to be intgrated with the UI of DRAW". Hence, the UI for this feature is still missing.

Please add the UI so that the users can actually access the new feature.
Comment 1 Cor Nouws 2015-01-10 20:08:15 UTC
Thanks for noticing and reporting Gerry.
Comment 2 Cor Nouws 2015-01-12 09:20:18 UTC
for now, I think best is to change the feature info on the wiki..
Comment 3 Gerry 2015-01-12 16:45:42 UTC
I changed the wording here and gave more explanation: https://wiki.documentfoundation.org/ReleaseNotes/4.4#Text_background_color

However, I think that it should be entirely removed from the release notes 4.4., because it is not accessible for end users?!?
Comment 4 Cor Nouws 2015-01-13 09:21:13 UTC
Indeed.
For easy reuse, I paste the wiki text here

 = = = =
=== Text background color ===

The Draw backend supports background color for text in frames and captions. However, the feature is not yet accessible from the LibreOffice user interface. [https://matteocam.github.io/output/category/gsoc-draw-text-background-color.html blog entry] (Matteo Campanelli, <abbr title="Google Summer of Code">GSoC</abbr> 2014). See bug {{fdo|88276}} on the missing user interface part.
[[File:Text background color.png|thumb|center|600px|Text in boxes and captions can have colored backgrounds.]]

 = = = =
Comment 5 Robinson Tryon (qubit) 2015-03-05 20:06:57 UTC
Setting priority to highest as this is a 4.4 MAB. This is part of an effort to
make the importance of MAB reflected in priority too.
Comment 6 Yousuf Philips (jay) 2015-05-06 10:48:50 UTC
So what is needed is to incorporate various features available in Writer.

1) Toolbar button - A 'Highlighting' (aka character background) button should be added to the 'Text Formatting' toolbar next to the 'Font Color' button.

2) Sidebar button - The 'Highlighting' button should also be added to the character section of the properties tab

3) Character dialog - A 'background' tab should be added to the dialog.
Comment 7 Cor Nouws 2015-05-06 14:52:46 UTC
(In reply to Yousuf (Jay) Philips from comment #6)
> So what is needed is to incorporate various features available in Writer.

thanks for the overiew Jay, useful :) !
Comment 8 Commit Notification 2015-06-01 17:13:24 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c1b9d61bacaf676d69a0f49a79fb086535f79a48

tdf#88276: Add slot and handlers for toolbar|sidebar buttons

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2015-06-01 17:14:46 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0e2ef262bea4cbc7cb04cfcd1d47f2a9d6092398

tdf#88276: Add background colour toolbar and sidebar buttons

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Cor Nouws 2015-06-01 19:28:23 UTC
(In reply to Commit Notification from comment #9)
> Katarina Behrens committed a patch related to this issue.

Mille gracias :)
Comment 11 Katarina Behrens (CIB) 2015-06-02 10:16:16 UTC
I'd like to have this cherry-picked to 5.0 so if any1 of you people in Cc: can review the code (or motivate other people to do so ;-) ) - there:
https://gerrit.libreoffice.org/#/c/16030/
Comment 12 Commit Notification 2015-06-03 17:26:36 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c0e07bc592b7fe270514ae392eacb6ebde3df879&h=libreoffice-5-0

tdf#88276: toolbar|sidebar button for text background colour

It will be available in 5.0.0.0.beta2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Katarina Behrens (CIB) 2015-06-03 22:07:09 UTC
I'm leaving this bug open as I still need to implement support for text background in character formatting dialog (for now, only toolbar and sidebar buttons have been added). That'll be something for 5.1, though, UI freeze is in a week.

I'm also not backporting this to 4.4.X, because of UI change, string change and possible documentation and help update required.

I suggest decreasing the importance of this bug a bit, since now at least *some* UI is there.
Comment 14 Adolfo Jayme 2015-06-07 04:57:16 UTC
Decreasing importance.
Comment 15 Stephan Bergmann 2015-08-04 16:52:03 UTC
Please verify that this feature is still working after the fix from bug 93041 comment 6, esp. if and when that fix should be backported to libreoffice-5-0 and libreoffice-5-0-0.
Comment 16 Robinson Tryon (qubit) 2015-10-07 22:40:34 UTC
(In reply to Adolfo Jayme from comment #14)
> Decreasing importance.

As a result -> Removing from mab4.4
Comment 17 Commit Notification 2015-11-02 12:37:07 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ecc7308efa973fd1f1985ff9a0a0f01414b73f2b

tdf#88276: New text background tab in char formatting dialog

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 18 Katarina Behrens (CIB) 2015-11-02 12:39:11 UTC
Background tab in char formatting dialog is now there as well => let's set this to fixed
Comment 19 Michael Stahl 2016-02-19 20:28:11 UTC
*** Bug 95050 has been marked as a duplicate of this bug. ***