Bug Hunting Session
Bug 88287 - UI: Rename "Lines" toolbar and removing "Arrows" toolbar from View > Toolbars
Summary: UI: Rename "Lines" toolbar and removing "Arrows" toolbar from View > Toolbars
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Roman Kuznetsov
URL:
Whiteboard: target:6.4.0
Keywords: difficultyBeginner, easyHack, skillDesign, topicUI
: 89021 (view as bug list)
Depends on:
Blocks: Toolbars
  Show dependency treegraph
 
Reported: 2015-01-11 10:39 UTC by Cor Nouws
Modified: 2019-06-15 04:46 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2015-01-11 10:39:23 UTC
In Draw:

The arrow "Curves" (GZMEE) on the tool bar "Drawing" opens a toolbar with the title "Lines" (uJMtU).
You cannot turn this on and off with the menu "View" > "Lines"

Proposal:
 - change tool bar title to Curves 
 - add this tool bar to the menu View

( the arrow  "Lines and Arrows" (gVhz6) on the tool bar "Drawing" opens a tool bar with the title "Arrows" (ABoyL). That can be turned on and off via the "View" > "Arrows" )

NB (strings between parenthesis are KeyID's for searching in Pootle)
Comment 1 Cor Nouws 2015-01-11 10:39:50 UTC
Jay, one for you pls?
Cheers,
Cor
Comment 2 Yousuf Philips (jay) (retired) 2015-01-11 17:08:50 UTC
Hey Cor,

There are a number of toolbars which are not visible in View > Toolbars that are only accessible through clicking the drop down arrow buttons in the Drawing toolbar (e.g. Connector, Basic Shapes, Symbol Shapes, etc.). The ability to rip them off and dock them if needed is available to those wishing to do so, but as the drawing toolbar is always on, there isnt much of a need to do so.

All the items in the drop down are lines (freeform line, polygon, curved line), so i think we could change the button's tooltip to something like 'Lines and Polygons' and the toolbar could be titled the same.

Just incase you hadnt heard, we decided to always set ux-advise enhancements to NEW so that it doesnt affect UNCONFIRMED numbers for the QA team. :D
Comment 3 Cor Nouws 2015-01-11 17:23:23 UTC
(In reply to Jay Philips from comment #2)

> There are a number of toolbars which are not visible in View > Toolbars that
> are only accessible through clicking the drop down arrow buttons in the
> Drawing toolbar (e.g. Connector, Basic Shapes, Symbol Shapes, etc.). The
> ability to rip them off and dock them if needed is available to those
> wishing to do so, but as the drawing toolbar is always on, there isnt much
> of a need to do so.

I know. The example Arrows I gave, was the one I accidentally looked at ;)
But it looks as the only exception: others are only accessible from the Drawing tool bar. So remove Arrows from the menu? There's enough to choose from :\

> All the items in the drop down are lines (freeform line, polygon, curved
> line), so i think we could change the button's tooltip to something like
> 'Lines and Polygons' and the toolbar could be titled the same.

Fine for me.

> Just incase you hadnt heard, we decided to always set ux-advise enhancements
> to NEW so that it doesnt affect UNCONFIRMED numbers for the QA team. :D

OK, try to act accordingly. thanks,
Cor
Comment 4 Yousuf Philips (jay) (retired) 2015-01-16 22:09:02 UTC
(In reply to Cor Nouws from comment #3)
> (In reply to Jay Philips from comment #2)
> I know. The example Arrows I gave, was the one I accidentally looked at ;)
> But it looks as the only exception: others are only accessible from the
> Drawing tool bar. So remove Arrows from the menu? There's enough to choose
> from :\

Yes i guess it can be removed from the View > Toolbars menu.

So the fixes needed are:

1) The tooltip for .uno:LineToolbox needs to be changed to 'Lines and Polygons'
2) The toolbar title of linesbar.xml needs to be changed to 'Lines and Polygons'
3) The Arrows toolbar (arrowsbar.xml) needs to be removed from View > Toolbars
Comment 5 Cor Nouws 2015-01-17 09:04:32 UTC
(In reply to Jay Philips from comment #4)
> 1) The tooltip for .uno:LineToolbox needs to be changed to 'Lines and
> Polygons'
> 2) The toolbar title of linesbar.xml needs to be changed to 'Lines and
> Polygons'

Polygons better fits what is offered. But maybe Curves is more understandable for average users?
Comment 6 Yousuf Philips (jay) (retired) 2015-01-17 12:00:03 UTC
To me, 'Curves' has no meaning to what is provided in the drop down. Maybe we can just use 'Polyline'.
Comment 7 Cor Nouws 2015-01-17 13:24:58 UTC
(In reply to Jay Philips from comment #6)
> To me, 'Curves' has no meaning to what is provided in the drop down. Maybe
> we can just use 'Polyline'.

I've no strong preference. And in the end people make the translation that fits them best ;)
So if no one else comes up: pls go ahead.
Comment 8 Cor Nouws 2015-02-01 22:48:07 UTC
*** Bug 89021 has been marked as a duplicate of this bug. ***
Comment 9 Heiko Tietze 2019-06-10 06:17:21 UTC
Some code pointers:

> 1) The tooltip for .uno:LineToolbox needs to be changed to 'Lines and
> Polygons'
The LineToolbox is here
https://opengrok.libreoffice.org/xref/core/officecfg/registry/data/org/openoffice/Office/UI/GenericCommands.xcu?r=82bba7e4#4761
The ArrowsToolbox (labeled "Lines") at
https://opengrok.libreoffice.org/xref/core/officecfg/registry/data/org/openoffice/Office/UI/GenericCommands.xcu?r=82bba7e4#1998
(not sure at what of the two we should do the changes)

> 2) The toolbar title of linesbar.xml needs to be changed to 'Lines and
> Polygons'
https://opengrok.libreoffice.org/xref/core/officecfg/registry/data/org/openoffice/Office/UI/CalcWindowState.xcu?r=00f96e88#127
https://opengrok.libreoffice.org/xref/core/officecfg/registry/data/org/openoffice/Office/UI/WriterWindowState.xcu?r=00f96e88#196
https://opengrok.libreoffice.org/xref/core/officecfg/registry/data/org/openoffice/Office/UI/DrawWindowState.xcu?r=00f96e88#578
https://opengrok.libreoffice.org/xref/core/officecfg/registry/data/org/openoffice/Office/UI/ImpressWindowState.xcu?r=00f96e88#515

> 3) The Arrows toolbar (arrowsbar.xml) needs to be removed from View >
> Toolbars

Maybe per 

  <prop oor:name="HideFromToolbarMenu" oor:type="xs:boolean">
      <value>true</value>
  </prop>

at 

https://opengrok.libreoffice.org/xref/core/officecfg/registry/data/org/openoffice/Office/UI/CalcWindowState.xcu#711
https://opengrok.libreoffice.org/xref/core/officecfg/registry/data/org/openoffice/Office/UI/WriterWindowState.xcu#210
https://opengrok.libreoffice.org/xref/core/officecfg/registry/data/org/openoffice/Office/UI/DrawWindowState.xcu#315
https://opengrok.libreoffice.org/xref/core/officecfg/registry/data/org/openoffice/Office/UI/ImpressWindowState.xcu#226
Comment 10 Maxim Monastirsky 2019-06-11 16:47:07 UTC
(In reply to Yousuf Philips (jay) (retired) from comment #4)
> So the fixes needed are:
> 
> 1) The tooltip for .uno:LineToolbox needs to be changed to 'Lines and
> Polygons'
> 2) The toolbar title of linesbar.xml needs to be changed to 'Lines and
> Polygons'
Not sure about it. Next to the .uno:LineToolbox button, we have .uno:ArrowsToolbox whose tooltip is "Lines and Arrows". IMHO it's confusing to have the word "Lines" in both. Personally, I would just stick with the original proposal of keeping the "Curves" tooltip, and only adapt the linesbar.xml toolbar title.
Comment 11 Roman Kuznetsov 2019-06-12 14:42:15 UTC
(In reply to Maxim Monastirsky from comment #10)
> (In reply to Yousuf Philips (jay) (retired) from comment #4)
> > So the fixes needed are:
> > 
> > 1) The tooltip for .uno:LineToolbox needs to be changed to 'Lines and
> > Polygons'
> > 2) The toolbar title of linesbar.xml needs to be changed to 'Lines and
> > Polygons'
> Not sure about it. Next to the .uno:LineToolbox button, we have
> .uno:ArrowsToolbox whose tooltip is "Lines and Arrows". IMHO it's confusing
> to have the word "Lines" in both. Personally, I would just stick with the
> original proposal of keeping the "Curves" tooltip, and only adapt the
> linesbar.xml toolbar title.

We can use "Curves and Polygons" for example.
The toolbar has "Curve", "Freeform Line" and "Polygon" tools.
Maxim, Heiko, what do you think?
Comment 12 Heiko Tietze 2019-06-13 12:36:02 UTC
(In reply to Maxim Monastirsky from comment #10)
> Personally, I would just stick with the
> original proposal of keeping the "Curves" tooltip, and only adapt the
> linesbar.xml toolbar title.

We have "Lines and Arrows" (tooltip) opening "Arrows" (caption) and "Curve" for "Lines". This is one issue and the detached toolbars should be removed from View > Toolbars (or we just do not allow the floating menu to become a toolbar).

(In reply to Roman Kuznetsov from comment #11)
> We can use "Curves and Polygons" for example.

Sounds better. I would make tooltip and caption the same. How about "Lines and Arrows" (.uno:ArrowsToolbox) and "Curves and Polygons" (uno:LineToolbox)?
Comment 13 Maxim Monastirsky 2019-06-13 14:09:31 UTC
(In reply to Heiko Tietze from comment #12)
> the detached toolbars should be removed from View > Toolbars
Yes, we agree on that.

> I would make tooltip and caption the same. How about "Lines
> and Arrows" (.uno:ArrowsToolbox) and "Curves and Polygons" (uno:LineToolbox)?
Sounds good to me.
Comment 14 Commit Notification 2019-06-14 21:03:50 UTC
Roman Kuznetsov committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/1dac2184c5e904887fe56c632fcd048fb0b698e9%5E%21

tdf#88287 Change toolbars attributes in Draw

It will be available in 6.4.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.