Bug 88360 - Crash closing help viewer while Navigator is set to "Active Window"
Summary: Crash closing help viewer while Navigator is set to "Active Window"
Status: CLOSED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.2 rc
Hardware: Other All
: medium normal
Assignee: Michael Stahl
QA Contact:
URL:
Whiteboard: target:4.5.0 target:4.4.3
Keywords: bibisected, bisected, regression
: 90236 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-01-13 09:01 UTC by Harald Koester
Modified: 2015-12-17 08:44 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
osx 10.10.1 LO 4.4.0.2 crashlog (67.27 KB, text/plain)
2015-01-16 16:11 UTC, retired
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Harald Koester 2015-01-13 09:01:47 UTC
I tried to check if bug 43020 still exists in version 4.4.0.2. During this test LO crashes. 

Steps in order to reproduce the bug:
[1] Start LO and open a new text document.
[2] Display the Navigator (F5). 
[3] Start local help (F1). A help page is displayed.
[4] Change back to document (Alt+Tab).
[5] Choose "Active Window" at the bottom of the Navigator window. 
[6] Change back to Help [Alt+Tab].
[7] Close Help. LO crashes. Expected: No crash.

Tested with German UI.

Tested also with version 4.3.5 and US-English UI. No crash with this version. Hence regression.
Comment 1 Robinson Tryon (qubit) 2015-01-14 18:06:28 UTC
TESTING with Ubuntu 14.04 + LO 4.4.0.2

(In reply to Harald Koester from comment #0)
> I tried to check if bug 43020 still exists in version 4.4.0.2. During this
> test LO crashes. 
> 
> Steps in order to reproduce the bug:
> [1] Start LO and open a new text document.
> [2] Display the Navigator (F5). 
> [3] Start local help (F1). A help page is displayed.

I don't have local help installed here; I just discovered that there's no Help page in the Online wikihelp:
Bug 88414 - WIKIHELP: swriter/SW_HID_NAVIGATOR_TREELIST page does not exist
Comment 2 retired 2015-01-16 16:10:57 UTC
OSX 10.10.1
LO 4.4.0.2 confirmed
LO 4.5 2015-01-15 confirmed
crashlog attached
NEW
Comment 3 retired 2015-01-16 16:11:16 UTC
Created attachment 112353 [details]
osx 10.10.1 LO 4.4.0.2 crashlog
Comment 4 Caolán McNamara 2015-01-23 14:57:11 UTC

*** This bug has been marked as a duplicate of bug 87845 ***
Comment 5 Harald Koester 2015-01-26 12:20:16 UTC
Checked again with version 4.4.0.3. LO still crashes. Hence bug 87845 has been fixed in version 4.4.0.3, this bug can't be a dupe of bug 87845. 

I tried to set back the status to NEW but I did not succeed. I don't know if this is intended and what would be the correct state in this case. Hence set back to UNCONFIRMED.
Comment 6 Harald Koester 2015-01-26 12:23:13 UTC
After the state has been set back to UNCONFIRMED it's now possible to set the status to NEW.
Comment 7 Matthew Francis 2015-03-31 07:21:50 UTC
Adjusting metadata; already confirmed to occur on OSX, and it's a regression.
The bibisect trees don't contain the help browser, so not bibisectable - I'm attempting to reproduce in a local build, but without success as yet.

-> Adjusted Summary
-> Platform: All
-> Keywords: regression
-> Whiteboard: notBibisectable
Comment 8 Matthew Francis 2015-03-31 08:12:57 UTC
This seems to have begun at the below commit.
Adding Cc: to mstahl@redhat.com; Could you possibly take a look at this? thanks

commit 329742e6c9da7cd7848d92a6846e3d1249d8d9b4
Author: Michael Stahl <mstahl@redhat.com>
Date:   Fri Nov 21 15:16:20 2014 +0100

    fdo#85886 don't redraw the Navigator content tree if nothing changed
    
    This fixes the flickering of the scrollbar on re-draw once a second.
    Perhaps it helps for the performance issue too.
    
    Change-Id: I2ec8f0a8a241b128113bfa3d47fb09ba472b4a7e
Comment 9 Matthew Francis 2015-03-31 08:14:32 UTC
*** Bug 90236 has been marked as a duplicate of this bug. ***
Comment 10 Michael Stahl 2015-04-01 13:55:20 UTC
fixed on master
Comment 11 Commit Notification 2015-04-01 13:55:37 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7ddd6c008142a6b88878ffc96f5e339a0fddd7d9

tdf#88360: sw: fix crash on closing help in Navigator window

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2015-04-03 07:27:17 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=530c8def8a11c98d6e2afab1e4954f5914741b0b&h=libreoffice-4-4

tdf#88360: sw: fix crash on closing help in Navigator window

It will be available in 4.4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Harald Koester 2015-06-29 16:06:52 UTC
Checked with with versions 4.4.2. and 4.4.3. Bug still exists in version 4.4.2 but not in 4.4.3. Hence bug is fixed in version 4.4.3. Bug closed.
Comment 14 Robinson Tryon (qubit) 2015-12-17 08:44:07 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]