Bug 88389 - android document browser: there is no way to access external storage
Summary: android document browser: there is no way to access external storage
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Android Viewer (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: target:5.2.0
Keywords:
: 90692 98718 (view as bug list)
Depends on:
Blocks: mabAndroid
  Show dependency treegraph
 
Reported: 2015-01-14 08:11 UTC by Miklos Vajna
Modified: 2017-09-01 14:24 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Miklos Vajna 2015-01-14 08:11:49 UTC
It seems there is no way to access external storage (i.e., an SD Card) in the document browser. Only folders / files of the internal (emulated) sdcard are shown.
Comment 1 Cor Nouws 2015-01-14 12:00:29 UTC
I confirm this.
Had to copy documents from SD to internal memory.
Comment 2 raal 2015-04-18 10:40:29 UTC
*** Bug 90692 has been marked as a duplicate of this bug. ***
Comment 3 Commit Notification 2016-02-02 19:29:29 UTC
AlexF committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1dfb68debb01dcc0aa5902f41bc17c7a97e47b26

tdf#88389 - android document browser: external storage access

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 4 raal 2016-03-17 08:16:48 UTC
*** Bug 98718 has been marked as a duplicate of this bug. ***
Comment 5 rag 2016-03-25 14:33:15 UTC
Just checked with version 5.2.0.0.alpha0+ Build ID f6a74ce, running on an LG4 with Android 6.0. Selecting "External SD" as the document source results in a disappointing "Invalid root file. Check your configuration." message on a mauve background flashing up.

I suspect that the issue is with Android 6.0
Comment 6 alexfonggX 2016-03-25 15:54:29 UTC
@rag Have you navigated to the settings menu and set the root directory of your external SD card? 

The sources of error could either be that, or as you have mentioned, Android 6.0
Comment 7 alexfonggX 2016-03-25 16:44:46 UTC
I am unable to help for this as I am still unable to get the Android 6.0 emulator working with LO Android. Do hope that someone else can step in to lend a hand. :)
Comment 8 Ximeng Zu 2017-03-29 21:22:08 UTC
I think this mab is solved already.

My version is 5.4.0.0.alpha0+.
Comment 9 Xisco Faulí 2017-06-09 10:02:45 UTC
Hello,
Is this bug fixed?
If so, could you please close it as RESOLVED FIXED?
Comment 10 Christian Lohmaier 2017-09-01 14:24:05 UTC
is resolved - Viewer now even has (experimental) support for OTG devices