Bug Hunting Session
Bug 88509 - upper case i in non english text
Summary: upper case i in non english text
Status: RESOLVED DUPLICATE of bug 76964
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.6.3 release
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-16 20:05 UTC by Puggan SE
Modified: 2015-01-18 18:12 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Puggan SE 2015-01-16 20:05:27 UTC
Libreoffice have a feuture that always converts lowercase "i" to upper case "I" in english text.

But when I try to write a swedish dockument, and using the swedish word "i", i want it to stay lower case.

If I use the Menu->Tools->Language->All Text->Swedish, I don't want the English autoconversions.

I have my system language set to english, and installed the english version of Libbreoffice, and added the swedish spellcheck.
(got the feling that computer installed in swedish, don't have this bug)
Comment 1 Robinson Tryon (qubit) 2015-01-17 00:46:35 UTC
(In reply to Puggan SE from comment #0)
> I have my system language set to english, and installed the english version
> of Libbreoffice, and added the swedish spellcheck.
> (got the feling that computer installed in swedish, don't have this bug)

Hi Puggan,

Looks like we have Swedish help- and lang-packs:
http://comments.gmane.org/gmane.comp.documentfoundation.libreoffice.qa/6237

What happens when you install those and enable them? Do you still have the same auto-correct problem?

Status -> NEEDINFO

(Please change status back to UNCONFIRMED after you reply. thanks!)
Comment 2 Puggan SE 2015-01-18 16:02:07 UTC
In gentoo there is a packaged called "app-office/libreoffice-l10n", where you can select what languages you want to support, my installation is configured to install for: "en en_GB sv"

The link you gave me, refers to the file:
LibreOffice_4.2.0.2_Linux_x86-64_deb_helppack_sv.tar.gz

The ebuild instruction referens to:
LibreOffice_${MY_PV}_Linux_x86_rpm_helppack_${lang2/_/-}.tar.gz
and
LibreOffice_${MY_PV}_Linux_x86_rpm_langpack_${lang/_/-}.tar.gz

but it only installs the helppack if you switch on the setting named "offlinehelp", with the description "Install help files locally instead of using the LibreOffice Wiki".

Switching on "offlinehelp" solved it.

So I see 3 options here:
1. This is a gentoo bug, and it should install the parts needed for swedish dokuments, even when the "offlinehelp" is off.
2. The parts needed should be in langpack, insted of being in helppack.
3. LO should never make upercase I on unknown languages.

I belive in number 3, but i guess its up to the developers to decide, if you say it's number 1, I make a bug report at gentoo too.
Comment 3 tommy27 2015-01-18 18:12:05 UTC
already known issue

*** This bug has been marked as a duplicate of bug 76964 ***