Bug 88577 - EDITING: Can't place cursor after comment anchor at end of line using the mouse
Summary: EDITING: Can't place cursor after comment anchor at end of line using the mouse
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Text-Cursor
  Show dependency treegraph
 
Reported: 2015-01-19 10:16 UTC by Matthew Francis
Modified: 2021-01-26 09:19 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Francis 2015-01-19 10:16:06 UTC
There is currently no way to place the cursor after a comment anchor at the end of a line using the mouse. This has always been the case back to 3.3.0

Steps to reproduce:

1. Insert a comment (containing some random text so it doesn't auto-delete) into a blank Writer document, such that it is the last thing on a line of text
2. Click to the right of the comment anchor (and/or below the anchor if its line is the last in the document)
3. Type some text

Expected result:
- The text in (3) is typed after the comment anchor

Actual result:
- The text in (3) is typed before the comment anchor
Comment 1 Buovjaga 2015-01-29 18:02:59 UTC
Reproduced.

Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: 784d069cc1d9f1d6e6a4e543a278376ab483d1eb
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-25_23:07:36
Comment 2 Gordo 2015-02-27 16:09:49 UTC
Here is some comment anchor behaviour that I have noticed:

If a comment is added at the beginning of a line and you click before the word, then you have selected the comment anchor.  Hitting space or typing will delete the comment.   If you want to add letters to that word and keep the comment at the beginning of the word then you need to right arrow.  If you left arrow and add letters to the word, then the comment will stay where it was originally.   If the cursor is placed anywhere in the line after the comment then just hit home and you can add letters to the word, then the comment will stay where it was originally.

If a comment is added before a word in a sentence and you click before the word, then you have selected the comment anchor.  Hitting space or typing will delete the comment.  If you want to add letters to that word and keep the comment at the beginning of the word then you need to right arrow (you could always place the cursor after the first letter and left arrow).  If you left arrow then right arrow and add letters to the word, then the comment will stay where it was originally.

If a comment is added after a word in a sentence and you click after the word, then you have selected the comment anchor.  Hitting space or typing will delete the comment.  If you want to add letters to that word and keep the comment at the end of the word then you need to left arrow then right arrow to get to the end of the word.  (or ctrl+right if the cursor is in that word)  If you hit the right arrow to get to the end of the word and add letters to the word, then the comment will stay where it was originally.

a.)  If a comment is added at the end of a line and you click directly after the last word (before placing the cursor the dashed comment line becomes solid), then you have selected the comment anchor.  Hitting space or typing will delete the comment.  If you want to add letters to that word and keep the comment at the end of the word then you need to left arrow then right arrow to get to the end of the word.
b.)  If the cursor was placed after the last word with the mouse being more than slightly away from the last word then the comment anchor has not been selected.  If you want to add letters to that word and keep the comment at the end of the word then just type.  If you want to add another word/sentence then right arrow (the solid comment line becomes dashed).
c.)  If the cursor is placed anywhere in the line before the comment then just hit end to add another word/sentence.

Whenever the mouse and the keyboard have an argument, the keyboard always wants to have the last word.
Comment 3 tommy27 2016-04-16 07:26:29 UTC Comment hidden (obsolete)
Comment 4 Philipp Kewisch [:Fallen] 2016-10-20 11:05:27 UTC
I can confirm this is still an issue with LibreOffice 5.2.2.2. This is certainly not a major error since if you know it you can work around, but it has caused me to carry along the period at the end of the sentence a few times.

This is also an issue with the latest OpenOffice version so I assume the "inherited from OOo" version is still accurate.
Comment 5 QA Administrators 2017-10-23 14:12:38 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2020-12-28 03:44:22 UTC Comment hidden (obsolete)
Comment 7 Telesto 2021-01-22 18:52:36 UTC
I think it's working properly
Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 6ee7a3b2c0565c2871d32d704cb2899445b9f88d
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: Skia/Raster; VCL: win
Locale: nl-NL (nl_NL); UI: en-US
Calc: CL
Comment 8 Buovjaga 2021-01-26 09:19:38 UTC
Yep, it's gone

Version: 7.2.0.0.alpha0+ (x64) / LibreOffice Community
Build ID: 01ac21d99fb9945f9d3ab2fe3ed04e3c86fa5583
CPU threads: 2; OS: Windows 10.0 Build 19042; UI render: Skia/Raster; VCL: win
Locale: fi-FI (fi_FI); UI: en-US
Calc: threaded

Arch Linux 64-bit
Version: 7.2.0.0.alpha0+ / LibreOffice Community
Build ID: bc684505f634643305f98611d5f39394c3a49044
CPU threads: 8; OS: Linux 5.10; UI render: default; VCL: kf5
Locale: fi-FI (fi_FI.UTF-8); UI: en-US
Calc: threaded
Built on 26 January 2021