Bug 88743 - type of border lines of cells changes when saved in .xls format
Summary: type of border lines of cells changes when saved in .xls format
Status: RESOLVED DUPLICATE of bug 79787
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-23 11:13 UTC by Roman Kuznetsov
Modified: 2016-07-18 18:02 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
MS Excell cell border is point (81.17 KB, image/png)
2015-01-23 11:13 UTC, Roman Kuznetsov
Details
LO Calc - borde cells is line (71.29 KB, image/png)
2015-01-23 11:13 UTC, Roman Kuznetsov
Details
test file (6.00 KB, application/vnd.ms-excel)
2015-01-23 12:54 UTC, raal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Kuznetsov 2015-01-23 11:13:02 UTC
Created attachment 112713 [details]
MS Excell cell border is point

Version: 4.4.0.3
ID build: de093506bcdc5fafd9023ee680b8c60e3e0645d7
Locale: ru_RU
OS: Windows 7 x86

1) create a very simple border lines of cells in Calc.
2) Save file in format .xls. 
3) Open the xls file in Excel 2010. 
4) Line border replaced by a point
5) Reopen this file xls in Calc - border is OK
Comment 1 Roman Kuznetsov 2015-01-23 11:13:59 UTC
Created attachment 112714 [details]
LO Calc - borde cells is line
Comment 2 Roman Kuznetsov 2015-01-23 11:17:27 UTC
similar to bug 75130, which is marked as fixed
Comment 3 raal 2015-01-23 12:54:50 UTC
Created attachment 112718 [details]
test file

I can confirm with LO 4.3.5, win7. I'll test later with dev builds.
Comment 4 raal 2015-01-23 19:45:19 UTC
I can confirm with Version: 4.5.0.0.alpha0+
Build ID: 60143f4f7bc50054dcef923218b8c7c3bc154933
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-01-21_04:58:34
Comment 5 QA Administrators 2016-02-21 08:38:15 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice 
   (5.0.5 or 5.1.0)  https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and 
   your operating system, and any changes you see in the bug behavior
 
   If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave 
   a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
   appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-02-21
Comment 6 Roman Kuznetsov 2016-02-22 13:58:39 UTC
Версия: 5.1.1.1
ID сборки: c43cb650e9c145b181321ea547d38296db70f36e
CPU Threads: 4; OS Version: Windows 6.1; UI Render: GL; 
Локаль: ru-RU (ru_RU)

bug is reproduceed
Comment 7 Roeland 2016-06-27 18:32:27 UTC
Isn't this a duplicate of Bug 79787?
Comment 8 Roman Kuznetsov 2016-06-27 18:57:00 UTC
(In reply to Roeland from comment #7)
> Isn't this a duplicate of Bug 79787?

i don't known. may be. if bug 79787 will fixed and this bug also fixed automated, then yes, duplicate =)
Comment 9 Roeland 2016-06-27 19:11:10 UTC
Ok, I added this bug at the "see also" part. However if I read the description of the other bug it really reads as a duplicate of this one:

bug 79787 Steps to reproduce:
1. New spreadsheet, apply borders from the toolbar icon to some cells.
2. Save as xlsx or xls format.
3. Reopen with MSO 2010.
4. Borders are showing dashed/dotted when reopen with MSO 2010.

This bug:
1) create a very simple border lines of cells in Calc.
2) Save file in format .xls. 
3) Open the xls file in Excel 2010. 
4) Line border replaced by a point
Comment 10 Roeland 2016-07-18 18:02:49 UTC

*** This bug has been marked as a duplicate of bug 79787 ***