Bug 88760 - Accessibility: Calc crashes when Orca speaks some cells
Summary: Accessibility: Calc crashes when Orca speaks some cells
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.3.2 release
Hardware: Other Linux (All)
: medium major
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: have-backtrace
Keywords:
Depends on:
Blocks: a11y-Linux
  Show dependency treegraph
 
Reported: 2015-01-23 19:35 UTC by Jean-Philippe MENGUAL
Modified: 2016-05-04 12:41 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Crash backtrace (19.38 KB, text/plain)
2015-01-23 19:35 UTC, Jean-Philippe MENGUAL
Details
Test file (122.73 KB, application/vnd.oasis.opendocument.spreadsheet-template)
2015-01-23 19:44 UTC, Jean-Philippe MENGUAL
Details
A trace of what I experience on 4.4.0 (12.46 KB, text/plain)
2015-02-22 22:58 UTC, Jean-Philippe MENGUAL
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Philippe MENGUAL 2015-01-23 19:35:48 UTC
Created attachment 112738 [details]
Crash backtrace

Hi,

From LO 4.3.3, Orca 3.14, steps to reproduce:
1. Open the attach file with Orca enabled.
2. ctrl-home
3. Down arrow key, until A11

When the speech synthetiser is enabled, on A11, LO crashes. Without speech, it's not systematic.

I attach the traceback too.

Regards,
Comment 1 Jean-Philippe MENGUAL 2015-01-23 19:44:42 UTC
Created attachment 112741 [details]
Test file
Comment 2 raal 2015-01-23 22:05:26 UTC
I can not confirm with Version: 4.5.0.0.alpha0+
Build ID: 60143f4f7bc50054dcef923218b8c7c3bc154933
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-01-21_04:58:34
Locale: cs_CZ
Comment 3 Jean-Philippe MENGUAL 2015-02-03 19:22:59 UTC
Hi,

I tried with master built today. I reproduce again. Same behavior. I use DEBS packages.

Regards,

(In reply to raal from comment #2)
> I can not confirm with Version: 4.5.0.0.alpha0+
> Build ID: 60143f4f7bc50054dcef923218b8c7c3bc154933
> TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time:
> 2015-01-21_04:58:34
> Locale: cs_CZ
Comment 4 Jean-Philippe MENGUAL 2015-02-22 22:58:28 UTC
Created attachment 113612 [details]
A trace of what I experience on 4.4.0
Comment 5 Jean-Philippe MENGUAL 2015-02-22 23:00:31 UTC
Hi,

I'm experiencing the same problem with LO 4.4.0, here's the backtrace. The bug nearly makes Calc unusable in many situations. Fixing this bug would fix other a11y issues as we saw with Orca team.

Regards,
Comment 6 Matthew Francis 2015-04-21 23:14:58 UTC
I don't experience a crash following the instructions in comment 0, but I do see the following when the cursor hits cell A11, which seems relevant:

(soffice:26343): GLib-GObject-WARNING **: g_object_weak_unref: couldn't find weak ref 0x7f2954d4bc30(0x2775590)
Comment 7 Joel Madero 2015-10-17 17:35:13 UTC
Ubuntu 15.04
LibreOffice 5.0.2.2

No crash.

Marking as NEEDINFO:

Please do the following:
1. Reset your profile: https://wiki.documentfoundation.org/UserProfile
2. Install 5.0.2.2 or later


Rerun your test and see what you get. If you get a crash still, mark the bug as UNCONFIRMED and I will try to find a developer to look at your crash log.


Thanks!
Comment 8 Alex ARNAUD 2016-05-02 13:18:46 UTC
(In reply to Jean-Philippe MENGUAL from comment #0)
> From LO 4.3.3, Orca 3.14, steps to reproduce:
> 1. Open the attach file with Orca enabled.
> 2. ctrl-home
> 3. Down arrow key, until A11

With the steps describe and LibreOffice 5.1.2 and Orca 3.18 I cannot reproduce the bug.
Could you confirm or not your bug ?
Comment 9 Alex ARNAUD 2016-05-04 12:36:08 UTC
Dear all,
after a discussion with the bug reporter it seems that the bug no longer appears in the latest 5.1 version.

Best regards.