Download it now!
Bug 88790 - Conditional Formatting is lost when the document is saved then reopened
Summary: Conditional Formatting is lost when the document is saved then reopened
Status: RESOLVED DUPLICATE of bug 100393
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.0.1 rc
Hardware: All All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
: 88789 (view as bug list)
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2015-01-25 18:44 UTC by Curtis J Blank
Modified: 2016-09-22 19:03 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
Example of Conditional Formatting loss (34.20 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-01-25 18:44 UTC, Curtis J Blank
Details
Test for Conditional Formatting (20.95 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-08-20 04:32 UTC, Robert Gonzalez MX
Details
Nieuw test file with issue (11.94 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-08-20 14:59 UTC, vlb
Details
Screenshoot of conditional formatting manage window (46.08 KB, application/vnd.oasis.opendocument.text)
2015-08-21 19:59 UTC, Robert Gonzalez MX
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Curtis J Blank 2015-01-25 18:44:59 UTC
Created attachment 112789 [details]
Example of Conditional Formatting loss

FILEOPEN FILESAVE FORMATTING

See attached file ConditionalFormattingBroken.ods

Every cell in column A rows 1 thru 120 should have conditional formatting.

Conditional formatting is copied to every cell in column A rows 1 thru 120.

The document is then saved in ods format.

The document is then opened and the majority of the cells in column A that had formatting when the document was saved do not have the conditional formatting when the document is opened.

This is 100% repeatable.

This occurs with LibreOffice version 4.3.5.2 Build ID: 3a87456aaa6a95c63eea1c1b3201acedf0751bd5 on OS X Yosemite and openSuSE 13.2 LibreOffice version 4.3.5.2.0+ Build ID: 430m0(Build:2)
Comment 1 Joel Madero 2015-01-25 19:16:12 UTC
I suspect that the other bug that you reported is just this one and there was a mistake. Setting the other one to a duplicate of this one.
Comment 2 Joel Madero 2015-01-25 19:16:51 UTC
*** Bug 88789 has been marked as a duplicate of this bug. ***
Comment 3 Joel Madero 2015-01-25 19:21:13 UTC
Confirmed:

Steps to reproduce:
1. Download file and open file;

Observed:
Conditional formatting is not on every cell in column A

2. Copy cell A1
3. Highlight Cells A1:A120)
3. Paste special (ctrl + shift + v)
4. Select ONLY "formats" (uncheck everything else)
5. Paste 

Observed:
Conditional formatting applies to everything correctly

6. Save and close file
7. Open file

Observed: Conditional formatting is largely lost
Expected: Conditional formatting is still present.


LibreOffice 4.4.0.2 rc
Ubuntu 14.04 x64
Comment 4 Joel Madero 2015-01-25 19:27:20 UTC
@markus - any thoughts on this one?
Comment 5 Curtis J Blank 2015-01-25 19:29:57 UTC
Yeah sorry about the duplicate, when I hit submit I got some weird error message that lead me to believe it didn't get submitted. And from the looks of it it didn't because everything that is in this report was in the other report and it's all missing there.
Comment 6 Curtis J Blank 2015-02-25 00:50:00 UTC
Is this going to be addressed anytime soon? The fact that it doesn't work makes the use conditional formatting to flag anything totally useless.
Comment 7 Joel Madero 2015-02-25 15:15:14 UTC
@Curtis: http://joelmadero.wordpress.com/2014/10/11/user-expectations-and-the-reality-of-our-community/

In short - we never give ETA's and the options are:
1) Submit a patch;
2) Find a family/friend/colleague to submit a patch;
3) Pay for a fix;
4) Wait until a volunteer decides to tackle it.
Comment 8 vlb 2015-06-22 19:39:15 UTC
In LO 4.2.8 did.t issue present.
In LO 4.3.0.1 is the issue present.
In LO 5.0.0 beta 3 is the issue to present.

I can confirm the issue in windows 7 pro 64 bit.
Comment 9 Robert Gonzalez MX 2015-07-14 20:39:39 UTC
Hi.

I can confirm this problem in Windows XP SP3 with LO 5.0 RC 3

If a individual cell is copied one by one to other cells, the conditional formatting is saved and preserved.
Comment 10 Matthew Francis 2015-08-20 03:00:07 UTC
Confused by comments 8 and 9; I can reproduce this issue perfectly, but it's already fixed in commit 1e4fc94c7feff11f28654dcf70cccf77db216143 which is long before 5.0.0 beta3 - and would make this a duplicate of bug 86253

It seems unlikely there could be a Windows specific issue there, but could one of the reproducers please re-confirm? Thanks
Comment 11 Robert Gonzalez MX 2015-08-20 04:30:55 UTC
Hi. 

Just tested with Version: 5.0.0.5
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: es-MX (es_MX)on Windows 10

Still is present. Following the steps in coment 3 is reproducible, and as i said in coment 9, if you copy in the same manner, just one cell, the conditional formatting is preserved.
Comment 12 Robert Gonzalez MX 2015-08-20 04:32:14 UTC
Created attachment 118031 [details]
Test for Conditional Formatting
Comment 13 Buovjaga 2015-08-20 07:52:48 UTC
No repro with steps from comment 3.

Win 7 Pro 64-bit, Version: 5.0.0.5 (32-bit)
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: fi-FI (fi_FI)
Comment 14 vlb 2015-08-20 14:59:28 UTC
Created attachment 118045 [details]
Nieuw test file with issue

I have test the steps from comment 3 in windows 10 pro 64 bit:
In LO 4.3.0.1 is the issue present.
In LO 4.4.5.2 did.t issue present.
In LO 5.0.0 I can't yet parallel installation in Wi 10 with command “msiexec /a LibreOffice-xx.msi” in Dos prompt

I have a new attachment where the conditional format didn't work in LO 4.4.5.2.

Reproduce steps:
1) download file and open
2) copy cell J1
3) Paste special to cells k1..w1
4) Select ONLY "formats" (uncheck everything else)
5) paste and cells are correct

6) close file and reopen and see the cells didn't correct

Observed: Conditional formatting is largely lost
Expected: Conditional formatting is still present.
Comment 15 vlb 2015-08-20 15:01:13 UTC
(In reply to vlb from comment #14)
> Created attachment 118045 [details]
> Nieuw test file with issue
> 
This is done with the orginal test file!
> I have test the steps from comment 3 in windows 10 pro 64 bit:
> In LO 4.3.0.1 is the issue present.
> In LO 4.4.5.2 did.t issue present.
> In LO 5.0.0 I can't yet parallel installation in Wi 10 with command “msiexec
> /a LibreOffice-xx.msi” in Dos prompt
> 

This is done with the new test file!
> I have a new attachment where the conditional format didn't work in LO
> 4.4.5.2.
> 
> Reproduce steps:
> 1) download file and open
> 2) copy cell J1
> 3) Paste special to cells k1..w1
> 4) Select ONLY "formats" (uncheck everything else)
> 5) paste and cells are correct
> 
> 6) close file and reopen and see the cells didn't correct
> 
> Observed: Conditional formatting is largely lost
> Expected: Conditional formatting is still present.
Comment 16 Robert Gonzalez MX 2015-08-20 21:15:04 UTC
I like to add this steps to reproduce this with the second attachment file:

Select O2
Ctrl- C to copy
select range P2:W2
right click- paste special
select formats only
at this point everything look fine, the formatting is copied
save the file and close LO
Open it again
the conditional formatting is lost or not saved.


On the contrary
if the same process is made, but one by one
the conditional formatting is saved

Select O2
Ctrl-C to copy
select P2
right click- paste special
select formats only
the formatting is copied
save the file and close LO
Open it again
the conditional formatting is preserved or saved.

Tested with Version: 5.0.0.5
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: es-MX (es_MX) on Win 10
Comment 17 Buovjaga 2015-08-21 06:41:42 UTC
(In reply to vlb from comment #14)
> Created attachment 118045 [details]
> Reproduce steps:
> 1) download file and open
> 2) copy cell J1
> 3) Paste special to cells k1..w1
> 4) Select ONLY "formats" (uncheck everything else)
> 5) paste and cells are correct
> 
> 6) close file and reopen and see the cells didn't correct
> 
> Observed: Conditional formatting is largely lost
> Expected: Conditional formatting is still present.

Could repro. Of the paste targets, only K1 and L1 remain green after reload.

Win 7 Pro 64-bit, Version: 5.0.0.5 (32-bit)
Build ID: 1b1a90865e348b492231e1c451437d7a15bb262b
Locale: fi-FI (fi_FI)
Comment 18 Robert Gonzalez MX 2015-08-21 19:57:37 UTC
Testing with Version: 5.0.1.1
Build ID: 13f702ca819ea5b9f8605782c852d5bb513b3891
Locale: es-MX (es_MX)
On WinXP SP3 and Windows 10

Is reproducible

Using the second attachment file
After pasting the conditional formatting to the range Q2:W2
and inspecting the conditional formatting manage window
I see that it's not added 


I'am adding a file with 
Screenshoot after pasting formats only
Comment 19 Robert Gonzalez MX 2015-08-21 19:59:55 UTC
Created attachment 118078 [details]
Screenshoot of conditional formatting manage window
Comment 20 Matthew Francis 2015-08-22 11:52:02 UTC
Following the instructions from comment 14, I get the following.

From (1), formatting is immediately broken by the paste special
From (2), pasting the format crashes immediately
From (3), the crash and initial format paste are fixed but conditional formatting is lost on save (as is still the case up to the present)

(1)
commit 80ea2822c368e6655d216c32904268fc335ef6a4
Author: Kohei Yoshida <kohei.yoshida@collabora.com>
Date:   Fri Jan 24 11:38:47 2014 -0500

    Optimize copy-n-pasting of single cell replicated over a range.
    
    This is a very common operation. Let's speed it up a bit.
    
    TODO : Handle cell comments.
    
    Change-Id: I5442bf19008475a9427b889c1eb641cacd8ff161

(2)
commit c0deb50f8f7feecb7adb049e8253c9566232abde
Author: Kohei Yoshida <kohei.yoshida@collabora.com>
Date:   Mon Jan 27 14:26:23 2014 -0500

    Handle note instances during copy-n-pasting of single cell.
    
    Change-Id: Ib258556414fd94b5156b65777478a8fd37abfd9e

(3)
commit 3b2a30ca8cbb46a137bfd0819d3a6b84757bbcee
Author: Kohei Yoshida <kohei.yoshida@collabora.com>
Date:   Thu Jan 30 12:41:59 2014 -0500

    Prevent crash.
    
    Change-Id: Id30e6dfa14c08ecad5c15df6a79d20a5cdc50a59
Comment 21 Robinson Tryon (qubit) 2015-12-13 11:12:20 UTC Comment hidden (obsolete)
Comment 22 Markus Mohrhard 2016-09-19 21:51:51 UTC
Should be fixed as part of Bug 100393

Please retest with a daily build or hopefully 5.2.3
Comment 23 vlb 2016-09-22 18:37:23 UTC
> Please retest with a daily build or hopefully 5.2.3

I have the steps from comment 14 test in 5.3.0.0 and there is it oke and works fine, thanks!

Is the issue solved for LO 5.2.2?
Comment 24 Buovjaga 2016-09-22 19:03:13 UTC
(In reply to vlb from comment #23)
> Is the issue solved for LO 5.2.2?

In comment 7 of bug 100393 (automatic commit message), it is said that the fix will be in 5.2.2.

*** This bug has been marked as a duplicate of bug 100393 ***