Download it now!
Bug 88817 - record changes: change in heading incorrectly presented in table of contents
Summary: record changes: change in heading incorrectly presented in table of contents
Status: RESOLVED DUPLICATE of bug 61154
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.8.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Track-Changes TableofContents-Indexes
  Show dependency treegraph
 
Reported: 2015-01-27 07:37 UTC by Ulrich Windl
Modified: 2020-08-02 08:33 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Sample ODT document (two versions) showing the problem (27.39 KB, application/vnd.oasis.opendocument.text)
2015-01-30 08:01 UTC, Ulrich Windl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ulrich Windl 2015-01-27 07:37:37 UTC
When you change a heading with "record changes" active, and then refresh the table of contents, the changed area has no markups, but just concatenated old and new text. This may be related to bug 61832 (IMHO).
Comment 1 Buovjaga 2015-01-29 20:22:25 UTC
Could not reproduce lack of strikethrough when removing characters from heading and updating TOC.

Updating the TOC doesn't actually update the heading entry in it, though.

Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: 784d069cc1d9f1d6e6a4e543a278376ab483d1eb
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-25_23:07:36
Comment 2 Ulrich Windl 2015-01-30 08:01:38 UTC
Created attachment 112942 [details]
Sample ODT document (two versions) showing the problem

I can reproduce the problem in 4.2.8 (Windows 7 64-bit).
Comment 3 Buovjaga 2015-01-30 16:15:02 UTC
Oh you mean "concatenated old and new text" *in the TOC*. That, I can confirm.

Let's set this to NEW.
Comment 4 QA Administrators 2016-02-21 08:36:22 UTC Comment hidden (obsolete)
Comment 5 QA Administrators 2017-03-06 15:28:44 UTC Comment hidden (obsolete)
Comment 6 Timur 2020-08-02 08:33:57 UTC
looks duplicate

*** This bug has been marked as a duplicate of bug 61154 ***