Bug 88831 - When OpenGL is enabled, drop-down arrows, check marks, scrollbars etc. are upside down
Summary: When OpenGL is enabled, drop-down arrows, check marks, scrollbars etc. are up...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard: target:5.1.0 target:5.0.0.3 target:4...
Keywords:
: 89074 89414 90266 90827 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-01-27 19:09 UTC by morvan
Modified: 2016-10-25 19:24 UTC (History)
10 users (show)

See Also:
Crash report or crash signature:


Attachments
Image shows selection arrow from Combobox. Only happens when set OpenGL (29.48 KB, image/png)
2015-01-27 19:09 UTC, morvan
Details
Verifying marks, when active OpenGL rendering, are inverted. (62.52 KB, image/png)
2015-01-27 19:10 UTC, morvan
Details
Image shows selection arrow from Combobox. These are shown, even inverted. (78.59 KB, image/png)
2015-02-04 11:53 UTC, morvan
Details
Screenshot on Arch Linux (114.77 KB, image/png)
2015-03-21 06:15 UTC, Michael Heyns
Details

Note You need to log in before you can comment on or make changes to this bug.
Description morvan 2015-01-27 19:09:34 UTC
Created attachment 112836 [details]
Image shows selection arrow from Combobox. Only happens when set OpenGL

When I set OpenGL, ComboBoxes hide select arrows and Verifying marks are inverted. Is this a bug, is this specific from my video card (both, work and home, I have Intel hardware in video cards - home: Fedora 21 X_64; work: Kubuntu 1404 X_64) or is this by design? I really do not know.
Follow to files (png) with affect. 
Thanks in advance.
Comment 1 morvan 2015-01-27 19:10:53 UTC
Created attachment 112837 [details]
Verifying marks, when active OpenGL rendering, are inverted.
Comment 2 morvan 2015-01-27 19:20:07 UTC
When I speak to files, please read it "two files". Thanks.
Comment 3 Adolfo Jayme 2015-02-03 12:09:34 UTC
*** Bug 89074 has been marked as a duplicate of this bug. ***
Comment 4 Adolfo Jayme 2015-02-03 12:45:19 UTC
CCing Markus as he could shed some light on this issue :-)
Comment 5 Liam Smit 2015-02-03 14:32:42 UTC
I logged bug 89074 (duplicate of this bug)

I run Ubuntu 14.04 LTS 64bit

I've seen this on Intel graphics and I'm pretty sure I saw it on AMD graphics as well (not on the AMD machine right now).
Comment 6 Markus Mohrhard 2015-02-03 16:55:46 UTC
Does this only happen with the KDE backend?
Comment 7 morvan 2015-02-03 17:15:09 UTC
(In reply to Markus Mohrhard from comment #6)
> Does this only happen with the KDE backend?

Hi. I, by my turn, only can reply to this question when at home, cause I am just now at work and here I am running KUbuntu. There, I can try it on Fedora (Gnome and KDE).
I must test even on another graphical driver, to help to insulate driver problem. I must put a NVidia Card and test it with its driver.

Best regards,
Morvan
Comment 8 Liam Smit 2015-02-03 17:28:27 UTC
It also occurs with Unity and Flashback (Metacity) as I've experienced it on both those DEs.
Comment 9 morvan 2015-02-04 11:42:40 UTC
(In reply to Liam Smit from comment #8)
> It also occurs with Unity and Flashback (Metacity) as I've experienced it on
> both those DEs.

Good morning.
Thanks, Liam. I have tested it on Gnome and it keeps with inverted arrows.
Comment 10 morvan 2015-02-04 11:51:46 UTC
Good morning. As I said to Liam, I tested it on Gnome (Fedora 21) Keep inverting arrows, but, differently from before, arrows from Comboboxes appear, even inverted too. I had two tests (inconclusive) with Nvidia Card installed: without xorg.conf (only by EvDev) screen is completely dark, impossible to see arrows and checkmarks. With xorg.conf (minimal, no acceleration information, just loading driver) OpenGL does not function, anyway. I need more tests, thus. I put another image showing tests on Gnome.
Any question, please report.
Comment 11 morvan 2015-02-04 11:53:08 UTC
Created attachment 113118 [details]
Image shows selection arrow from Combobox. These are shown, even inverted.
Comment 12 Adolfo Jayme 2015-02-17 02:45:31 UTC
*** Bug 89414 has been marked as a duplicate of this bug. ***
Comment 13 tmp-libo-3333d9d3e4 2015-03-07 09:52:00 UTC
Confirming inverted check marks, but no problems with arrows, scrollsbars et cetera.

Tested on:
 - ArchLinux 64b
 - 3.18.6 kernel
 - nVidia's GeForce 9500GT on Nouveau
 - LibO 4.4.1.2
 - Xfce (GTK-based) as desktop environment
Comment 14 Michael Heyns 2015-03-21 06:15:42 UTC
Created attachment 114224 [details]
Screenshot on Arch Linux

I can confirm.

Many UI elements are upside down or inverted. Including selection boxes and buttons. Please see attached screenshot.
Comment 15 Adolfo Jayme 2015-03-29 13:01:35 UTC
*** Bug 90266 has been marked as a duplicate of this bug. ***
Comment 16 Rpnpif 2015-04-02 16:37:12 UTC

*** This bug has been marked as a duplicate of bug 88747 ***
Comment 17 Adolfo Jayme 2015-04-25 01:16:49 UTC
Damn…
Comment 18 Adolfo Jayme 2015-04-25 01:17:09 UTC
*** Bug 90827 has been marked as a duplicate of this bug. ***
Comment 19 Commit Notification 2015-07-03 05:54:52 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f7f0486376adbabf3ea66bfd8a7b692c335ec3c8

tdf#88831 fix inverted textures when OpenGL is enabled

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 20 Commit Notification 2015-07-08 15:38:53 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5de8f1559afafe4a5430142c305549223d467606&h=libreoffice-5-0

tdf#88831 fix inverted textures when OpenGL is enabled

It will be available in 5.0.0.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2015-08-18 09:51:40 UTC
Tomaž Vajngerl committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=dfac25d2300b56ee4594346a4b5ce8b083a5c782&h=libreoffice-4-4

tdf#88831 fix inverted textures when OpenGL is enabled

It will be available in 4.4.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.