Bug 88833 - UI: Checkbox misaligned on high DPI screen (search&replace bar at the bottom)
Summary: UI: Checkbox misaligned on high DPI screen (search&replace bar at the bottom)
Status: RESOLVED DUPLICATE of bug 92249
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
5.0.2.2 release
Hardware: x86-64 (AMD64) Windows (All)
: lowest trivial
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-27 19:57 UTC by cycore
Modified: 2015-10-25 10:30 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot showing the misaligned checkbox at the bottom. (72.48 KB, image/png)
2015-01-27 19:57 UTC, cycore
Details
confirm bug in 5.0.2.2 (82.47 KB, image/png)
2015-10-19 17:19 UTC, cycore
Details
after deleting user profile. small checkboxes still exist (128.08 KB, image/png)
2015-10-20 18:40 UTC, cycore
Details

Note You need to log in before you can comment on or make changes to this bug.
Description cycore 2015-01-27 19:57:24 UTC
Created attachment 112838 [details]
Screenshot showing the misaligned checkbox at the bottom.

The checkbox at the bottom saying "Groß/Kleinschreibung" (case sensitive search) is misaligned at the top of the search&replace bar. It should be aligned with "Alle suchen" (search all) in the middle.
Comment 1 Dennis Roczek 2015-10-17 21:02:22 UTC
cannot confirm with 

Version: 5.0.2.2 (x64)
Build-ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Gebietsschema: de-DE (de_DE)
with Win 10


What means with high dpi screen?
Comment 2 Dennis Roczek 2015-10-17 21:04:56 UTC
cannot confirm with the same version under OS X 10.10 / macbook pro with retina display (13", Mid 2014)
Comment 3 Joel Madero 2015-10-17 21:08:13 UTC
@cycore

Can you please test with 5.0.2.2 as we've changed a lot since 4.3 that might have fixed this issue. It's hard to find people with these high DPI screens so if it's fixed I don't want to waste a ton of time tracking someone down. Apologies for the long delay.

Marking as NEEDINFO - please test with 5.0.2.2 and if it's still an issue mark it back to UNCONFIRMED and I'll try to track someone down with one of these rare high DPI screens.


Thanks
Comment 4 cycore 2015-10-19 17:19:11 UTC
Created attachment 119767 [details]
confirm bug in 5.0.2.2
Comment 5 cycore 2015-10-19 17:23:52 UTC
Hi Joel,
unfortunately it still exists in the latest release version. I've attached a new screenshot.
Setting issue to UNCONFIRMED as you requested.
Thanks for looking into it!
Comment 6 David Lynch 2015-10-20 17:30:29 UTC
OK for me, no misalignment:

Version: 5.0.2.2
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: en-GB (en_GB)

Windows 10 with 1920x1080 monitor
Comment 7 Dennis Roczek 2015-10-20 17:59:37 UTC
cycore can you reset (=rename) your userprofil and try again please? (see https://wiki.documentfoundation.org/UserProfile/de )
Comment 8 cycore 2015-10-20 18:39:54 UTC
I just tried. No luck. Still looks the same.

The checkboxes all over the application look pretty small to me (see new screenshot).

On regular screens, maybe you can reproduce the error by increasing the windows dpi scaling factor to 200%.
Comment 9 cycore 2015-10-20 18:40:51 UTC
Created attachment 119799 [details]
after deleting user profile. small checkboxes still exist
Comment 10 David Lynch 2015-10-20 19:13:22 UTC
Have you tried unchecking

 Options -> LibreOffice -> View -> Use OpenGL for all rendering

That helped with bug 94917
Comment 11 cycore 2015-10-20 19:26:25 UTC
doesn't change anything. checkboxes are still too small
Comment 12 Dennis Roczek 2015-10-20 22:09:22 UTC
ahhh, I CAN confirm it, but not really reproducable


Tools --> Preferences --> LibreOffice --> View --> change from tango to sifr + zoom of gui to 150% in one step and confirm.

setting it back resolves the problem. but somehow it is not really stable (doing it again might not result in the same error)
Comment 13 Joel Madero 2015-10-20 22:20:53 UTC
Looks confirmed - even if sporadic. Marking it as such.

New
Trivial - placement of text only, no impact at all on professional quality work;
Lowest - seems appropriate as it's a trivial issue on high DPI screen, and not 100% repro.
Comment 14 cycore 2015-10-21 05:28:16 UTC
For me, it is 100% percent reproducable and looks like LibreOffice does not apply the Windows system GUI scaling factor (e.g. 200% in my case) to check boxes. 

The way Dennis described it uses the LibreOffice scaling factor and not the Windows system scaling factor. That may lead to a sporadic appearance.
Comment 15 Tomaz Vajngerl 2015-10-25 10:30:00 UTC

*** This bug has been marked as a duplicate of bug 92249 ***