Download it now!
Bug 88836 - UI: in-form navigation bar icons gone since 4.4
Summary: UI: in-form navigation bar icons gone since 4.4
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.5.0 target:4.4.1
Keywords: bibisected, bisected, regression
: 88972 (view as bug list)
Depends on:
Blocks:
 
Reported: 2015-01-27 23:44 UTC by Olav Seyfarth
Modified: 2015-12-17 08:45 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
sub-form navigation: without icons (47.65 KB, image/png)
2015-01-27 23:44 UTC, Olav Seyfarth
Details
hovering over icons makes them visible - a little (3.48 KB, image/png)
2015-01-27 23:45 UTC, Olav Seyfarth
Details
sample database file as requested (61.87 KB, application/vnd.sun.xml.base)
2015-01-28 16:29 UTC, Olav Seyfarth
Details
screenshot "showing" the missing icons within the sample database (37.95 KB, image/png)
2015-01-28 16:30 UTC, Olav Seyfarth
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Olav Seyfarth 2015-01-27 23:44:38 UTC
Created attachment 112841 [details]
sub-form navigation: without icons

I built my own address book using base and forms, saved as read-only .odt to access contact details easily. Up to 4.3.5, this setup (a main form for the customer and a sub-form for this customer's emloyees I deal with) worked like a charm. After upgrading to 4.4.0.3 I noticed that my in-form(!) navigation bars lack their symbols (First, Prev, Next, Last, New, Delete). Currently I use them blindly (LO shows hint when hovering over button), see screenshots.
Comment 1 Olav Seyfarth 2015-01-27 23:45:29 UTC
Created attachment 112842 [details]
hovering over icons makes them visible - a little
Comment 2 raal 2015-01-28 13:27:51 UTC
Hello Olav,

Thank you for reporting the bug. Please attach a sample document, as this makes it easier for us to verify the bug. 
I have set the bug's status to 'NEEDINFO'. Please change it back to 'UNCONFIRMED' once the requested document is provided.
(Please note that the attachment will be public, remove any sensitive information before attaching it. 
See https://wiki.documentfoundation.org/QA/FAQ#How_can_I_eliminate_confidential_data_from_a_sample_document.3F for help on how to do so.)
Comment 3 Olav Seyfarth 2015-01-28 16:29:31 UTC
Created attachment 112894 [details]
sample database file as requested
Comment 4 Olav Seyfarth 2015-01-28 16:30:28 UTC
Created attachment 112895 [details]
screenshot "showing" the missing icons within the sample database
Comment 5 raal 2015-01-28 17:41:52 UTC
I can confirm with Version: 4.5.0.0.alpha0+
Build ID: 60143f4f7bc50054dcef923218b8c7c3bc154933
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-01-21_04:58:34

No problem in version 4.3.3 -> regression
Comment 6 Matthew Francis 2015-01-29 12:17:50 UTC
Bibisect results from 44:

This seems to have regressed in two stages. First, the last of the original 4 icons becomes invisible at

# first bad commit: [95d4432551fd58a604029ea886134d0126ec0289] source-hash-1964870db4ad1e4334e8fc5050795469dc1fb05e

Then, all the 4 icons become invisible at

# first bad commit: [44b035cbec37614034a66b5617313d237faa83f7] source-hash-b2503f187341f9a37737f34c7fc6a02d03c2e84e
Comment 7 Matthew Francis 2015-01-29 14:48:39 UTC
The first change mentioned above (the disappearance of one of the four icons) appears to have occurred at commit 1964870db4ad1e4334e8fc5050795469dc1fb05e, and the second at commit 6419c745e5e9802da264250d5e131fb9a3b6e4de. It's not particularly obvious why in either case.

Adding Cc: to giuseppe.bilotta@gmail.com and zolnaitamas2000@gmail.com. Any chance you could figure out what's going on here? Thanks


commit 1964870db4ad1e4334e8fc5050795469dc1fb05e
Author: Giuseppe Bilotta <giuseppe.bilotta@gmail.com>
Date:   Tue Sep 9 21:34:45 2014 +0200

    Fallback DPI detection on X11
    
    When the Xft.dpi setting is not found, and if only one screen is
    available, fall back to detecting the screen DPI from the reported
    resolution and monitor size.
    
    Change-Id: I1481d94b5dc4072c1f8da4659a221dfc7971080b
    Reviewed-on: https://gerrit.libreoffice.org/11377
    Reviewed-by: Chris Sherlock <chris.sherlock79@gmail.com>
    Tested-by: Chris Sherlock <chris.sherlock79@gmail.com>


commit 6419c745e5e9802da264250d5e131fb9a3b6e4de
Author: Zolnai Tamás <tamas.zolnai@collabora.com>
Date:   Fri Oct 17 10:06:10 2014 +0200

    Do not check a reference
    
    Change-Id: I5baac12f97ea7fa36293844331ca548b7bc2cdfd
Comment 8 Julien Nabet 2015-02-04 22:01:18 UTC
*** Bug 88972 has been marked as a duplicate of this bug. ***
Comment 9 Commit Notification 2015-02-07 10:27:00 UTC
Zolnai Tamás committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=905d4db48a0b98f540c8abc3e12fb80be4826029

tdf#88836: UI: in-form navigation bar icons gone

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2015-02-09 10:52:36 UTC
Zolnai Tamás committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3c1c50281acce8a7471ba456d514e2584e6d22d1&h=libreoffice-4-4

tdf#88836: UI: in-form navigation bar icons gone

It will be available in 4.4.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 tim 2015-02-24 16:26:54 UTC
Working for me in Version: 4.4.1.2 Build ID: 40m0(Build:2) (Ubuntu 14.04)

Thanks very much.
Comment 12 Robinson Tryon (qubit) 2015-12-17 08:45:32 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]