Bug Hunting Session
Bug 88900 - EDITING: Table between two numbered headings completely deleted when deleting lower heading
Summary: EDITING: Table between two numbered headings completely deleted when deleting...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Writer-Tables
  Show dependency treegraph
 
Reported: 2015-01-29 12:07 UTC by Amir Adar
Modified: 2018-10-15 19:07 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Amir Adar 2015-01-29 12:07:46 UTC
When using numbered headings (of any level) in a writer document, and trying to delete a numbered heading paragraph located below a table, which is located below another numbered heading paragraph, the whole table is deleted. When pressing Ctrl+Z, the table is restored.

To reproduce:
1. Create a numbered heading
2. Create a table underneath the heading
3. Create another numbered heading underneath the table
4. Press “backspace” until the heading paragraph is completely deleted

Expected result:
The heading paragraph should be empty. The cursor should move to the last cell in the table, without deleting anything.

Actual result:
The whole table is deleted.

I'm using Linux Mint 17.1 Cinnamon edition, 32-bit. I managed to reproduce on both the "master" and "fresh" versions of LO.
Comment 1 A (Andy) 2015-01-31 10:27:04 UTC
Reproducible with LO 4.4.0.3, Win 8.1.


Note to step 4: To reproduce this bug you need to put the cursor at the end of the heading underneath the table and then to press the Backspace key.
Comment 2 QA Administrators 2016-02-21 08:36:08 UTC Comment hidden (obsolete)
Comment 3 QA Administrators 2017-03-06 15:25:35 UTC Comment hidden (obsolete)
Comment 4 Thomas Lendo 2018-10-15 08:59:13 UTC
Can't reproduce with

Version: 6.2.0.0.alpha0+ (x64)
Build ID: 425af6845ebe066c950b0b63f50563e067485f3e
CPU threads: 8; OS: Windows 10.0; UI render: GL; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-10-09_23:30:22
Locale: de-AT (de_AT); Calc: CL

nor with

Version: 6.0.6.2 (x64)
Build-ID: 0c292870b25a325b5ed35f6b45599d2ea4458e77
CPU-Threads: 8; BS: Windows 10.0; UI-Render: Standard; 
Gebietsschema: de-AT (de_AT); Calc: group
Comment 5 Buovjaga 2018-10-15 19:07:14 UTC
In 4.3.0 and 4.4.7 on Win the backspacing gets me inside the table.
In 6.2 I do not move inside the table, but do not delete the table either.

Version: 6.2.0.0.alpha0+ (x64)
Build ID: d9ad59da50c1172fe98f94370221c9c1b688200a
CPU threads: 4; OS: Windows 10.0; UI render: default; VCL: win; 
TinderBox: Win-x86_64@42, Branch:master, Time: 2018-10-09_01:03:44
Locale: fi-FI (fi_FI); Calc: threaded