Bug 88961 - Table line styles are not visible
Summary: Table line styles are not visible
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium minor
Assignee: Nickson Thanda
URL:
Whiteboard: target:6.1.0 target:6.2.0
Keywords: difficultyBeginner, easyHack, skillDesign
: 91822 100045 (view as bug list)
Depends on:
Blocks: Table-Borders
  Show dependency treegraph
 
Reported: 2015-01-30 22:54 UTC by A (Andy)
Modified: 2018-07-19 13:06 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description A (Andy) 2015-01-30 22:54:51 UTC
Table line styles are not visible / not selectable.

Steps to Reproduce:
1. Open DRAW
2. Go to INSERT -> TABLE and select OK
3. Put the cursor in any cell of the table and make a right mouse click
4. Go to TABLE -> tab BORDERS
5. In the section Line Style select the arrow to open the Line Style drop-down list box

Result: An empty box opens (only "None" and a single line is visible).  If you move the mouse cursor up and down inside the drop-down list box you see that there are supposed to be more line styles.

Reproducible with LO 4.4.0.3, Win 8.1.
Comment 1 Buovjaga 2015-01-31 14:10:00 UTC
Reproduced with all versions tested .. 3.3.0 at least shows the pt values :)
The styles ARE selectible, though, so adjusting title.

Win 7 Pro 64-bit, LibO Version: 4.4.0.3
Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7

Version: 4.5.0.0.alpha0+
Build ID: 309574394bd4ae3e9e10e5ff0d64bdd7bbbc8b83
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-29_23:44:46

Ubuntu 14.10 64-bit Version: 4.5.0.0.alpha0+
Build ID: 8fd9c25ac66dd238d4c68be3974241a18cb21705
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-01-27_22:43:15

Version: 4.3.3.2
Build ID: 430m0(Build:2)

LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 2 Julien Nabet 2015-02-02 22:18:06 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.

Weird thing is loading line styles from an table on Writer is ok whereas both, Draw and Writer, use SvxBorderTabPage::FillLineListBox_Impl
See http://opengrok.libreoffice.org/xref/core/cui/source/tabpages/border.cxx#1029
Comment 3 Katarina Behrens (CIB) 2015-06-08 12:46:39 UTC
*** Bug 91822 has been marked as a duplicate of this bug. ***
Comment 4 Katarina Behrens (CIB) 2015-06-08 12:47:30 UTC
Changing the component to UI, affects also Impress
Comment 5 Katarina Behrens (CIB) 2016-06-10 20:38:43 UTC
*** Bug 100045 has been marked as a duplicate of this bug. ***
Comment 6 Telesto 2017-12-20 18:11:33 UTC
For the record, still reproducible
Version: 6.1.0.0.alpha0+
Build ID: aad9c6da5154a89c6ef02214d1122d4b444eea23
CPU threads: 4; OS: Windows 6.3; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-12-15_22:56:44
Locale: nl-NL (nl_NL); Calc: CL
Comment 7 Heiko Tietze 2018-02-20 10:50:35 UTC
Looks to me as the line color is just white and you don't see the alternatives. Should be fixed anyway.
Comment 8 Tamás Zolnai 2018-02-27 05:27:27 UTC
(In reply to Heiko Tietze from comment #7)
> Looks to me as the line color is just white and you don't see the
> alternatives. Should be fixed anyway.

Yeap, I see the same. The default border color is white in Impress / Draw (while in Writer it is balck). If you change the color the lines are rendered. However it still wierd that we don't see anything in that popup. Might be good to have an UX opinion here.
I see the same issue for Writer tables, if I change the border color to white.
Comment 9 Heiko Tietze 2018-02-27 08:22:24 UTC
(In reply to Tamás Zolnai from comment #8)
> However it still wierd that we don't see anything in that popup.

What popup do you mean?

(Btw, Draw/Impress uses the old table designs with white borders and access in the sidebar)
Comment 10 Tamás Zolnai 2018-02-27 13:44:02 UTC
(In reply to Heiko Tietze from comment #9)
> (In reply to Tamás Zolnai from comment #8)
> > However it still wierd that we don't see anything in that popup.
> 
> What popup do you mean?
> 
> (Btw, Draw/Impress uses the old table designs with white borders and access
> in the sidebar)

Sorry, I mean the dropdown listbox (as written in the first comment), not popop.
Comment 11 Nickson Thanda 2018-04-03 01:28:59 UTC
Working on this
Comment 12 Commit Notification 2018-04-04 20:30:32 UTC
Nickson Thanda committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=e0a641f863be91c5407dac5fc58edc33b5703116

tdf#88961 table line style color visible when color is white

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 13 Heiko Tietze 2018-04-06 10:57:12 UTC
(In reply to Commit Notification from comment #12)
> Affected users are encouraged to test the fix and report feedback.

Works nicely for White but not the other bright colors. In fact, Light Gray 5 is now completely hidden on my theme. 

There is a solution for the style dropdown in Writer but not working in all situations (white on white or black on black). See also bug 115507.
Comment 14 Heiko Tietze 2018-04-10 09:41:58 UTC
(In reply to Heiko Tietze from comment #13)

Take a look at the solution for styles in the toolbar dropdown in bug 58161
Comment 15 Xisco Faulí 2018-05-11 02:30:34 UTC Comment hidden (obsolete)
Comment 16 Nickson Thanda 2018-05-12 14:14:39 UTC
(In reply to Xisco Faulí from comment #15)
> A polite ping, still working on this bug?

Hi Xisco, I am still working on this bug.
Comment 17 Heiko Tietze 2018-06-06 19:34:44 UTC
Design team discussed the current status:

 * Table line styles are not visible (Muhammet)
   + https://bugs.documentfoundation.org/show_bug.cgi?id=88961
   + The first patch merged turns white lines to black, which makes them very hard to see on dark theme, and almost invisible on high-contrast theme
   + The second patch involves some trickery, and brings some improvements, but still not satisfied with the result (try different themes with different colors to see what I mean)
   + Why do we bother changing the color of the lines in the box?
      + What if we stop doing these tricky things, and make the style box just show the style and the color box just the color? (Just like the "Border Color" and the "Border Style" elements do in the Table toolbar)
        + It will be consistent with the rest of the UI
        + It will be always perfectly visible
        + We can also open an enhancement request to add a preview to the Borders tab of Table Properties dialog, like the one in the "Insert Table" dialog in Writer.
      + would require a preview that in fact we have under user-defined (line arrangement)
      + alternatively, show the line on a dedicated self-drawn rectangle similar to color dropdowns

    => go with the simple black line ignoring width and color
Comment 18 Commit Notification 2018-06-07 12:07:30 UTC
Nickson Thanda committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=11d13f46a825811067997272f485e45eeb1bba7b

tdf#88961 change table line style color to make it more visible

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.