Bug Hunting Session
Bug 88974 - [RTL] Outline numbering not shown correctly
Summary: [RTL] Outline numbering not shown correctly
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 98104 (view as bug list)
Depends on:
Blocks: RTL-CTL
  Show dependency treegraph
 
Reported: 2015-01-31 11:17 UTC by Oribasht
Modified: 2018-03-06 03:43 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
An .odt file plus a .jpg showing more details (279.38 KB, application/zip)
2015-01-31 11:17 UTC, Oribasht
Details
An image showing what is expected. (199.62 KB, image/png)
2015-02-03 09:14 UTC, Oribasht
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oribasht 2015-01-31 11:17:33 UTC
Created attachment 112987 [details]
An .odt file plus a .jpg showing more details

[Attach]
The outline numbering has problems with RTL languages in Writer. The numbers are swapped (as if they were LTR, instead of RTL).

I've attached an .odt file and a .jpg showing the bug more clearly.
Comment 1 Buovjaga 2015-02-02 11:09:34 UTC
Confirmed already in 3.3.0.

Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: 4b9a9ce8a0e5e0716dad9a9ec87d16237e534dc2
TinderBox: Win-x86@39, Branch:master, Time: 2015-01-31_09:49:44

Ubuntu 14.10 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4
Comment 2 Yousuf Philips (jay) (retired) 2015-02-02 18:50:43 UTC
Arabic and english numbers are written LTR so this is NOTABUG.
Comment 3 Oribasht 2015-02-02 19:51:31 UTC
Mathematically speaking, numbering should always be LTR.

But the problem is when you use numbers to indicate titles and subtitles. In english, it is LTR indeed. 
But in RTL languages, numbering SHOULD BE RTL, or it will lead to confusion (2nd title and 1st subtitle, or 1st title and 2nd subtitle?).

I totally agree that in mathematics, numbers and operations are always LTR. But I am talking about subtitling, which is completely a different aspect.

Thank you for your understanding.
Comment 4 Yousuf Philips (jay) (retired) 2015-02-02 21:33:34 UTC
Please show an example from another source that arabic numbering is shown in the way that you describe.
Comment 5 Yousuf Philips (jay) (retired) 2015-02-02 22:48:37 UTC
I just tested word 2013 and it acts the same way. I checked with my arab friend he said that arabs normally use '1.a, 1.b, 1.c' (of course a, b and c are in the arabic alphabet) instead of '1.1, 1.2, 1.3' to work around this issue.
Comment 6 Oribasht 2015-02-03 09:14:34 UTC
Created attachment 113077 [details]
An image showing what is expected.

OK, I have added another image (More.png) showing what is expected.
Comment 7 Yousuf Philips (jay) (retired) 2015-02-03 17:41:03 UTC
Oribasht, I am aware of what you have been saying is expected, I was asking of an external example showing that what is expected is the correct way to display it. Like an example from a publish arabic book, etc.
Comment 8 Oribasht 2015-02-03 20:21:05 UTC
I am sorry but I have no examples.
I don't see where the difficulty lies. It is exactly the same logic as english, except that it should be read from right to left.
Comment 9 Oribasht 2015-02-07 10:59:38 UTC
Please, can any person help fixing this bug? I need the outline to work correctly.
Comment 10 Amir Adar 2015-02-07 12:07:51 UTC
(In reply to Oribasht from comment #3)
> But in RTL languages, numbering SHOULD BE RTL, or it will lead to confusion.

Are you sure of that? In Hebrew, numbering and numbers are ALWAYS LTR. It is widely agreed-upon and understood, and therefore no confusion is caused: you simply read the numbers ltr, and the rest of the text rtl.
Comment 11 Buovjaga 2015-02-19 16:05:17 UTC
It seems this change request is not in line with the established way of doing things (including MS Office), so the report will have to be closed as INVALID.
Comment 12 Khaled Hosny 2015-02-19 19:39:44 UTC
One way to achieve the desired effect (which is reasonable, since the period here is not a decimal separator) is to insert ”U+200E LEFT-TO-RIGHT MARK” next to the period in the numbering style options. Whether LibreOffice should provide such a style by default (is an option) is a question for others to answer, but IMHO we should.
Comment 13 Yousuf Philips (jay) (retired) 2015-02-20 07:16:27 UTC
My arab friend also stated the same, so setting this to NEW.
Comment 14 Oribasht 2015-02-20 07:57:49 UTC
(In reply to Khaled Hosny from comment #12)
> One way to achieve the desired effect (which is reasonable, since the period
> here is not a decimal separator) is to insert ”U+200E LEFT-TO-RIGHT MARK”
> next to the period in the numbering style options. Whether LibreOffice
> should provide such a style by default (is an option) is a question for
> others to answer, but IMHO we should.

Thank you for your answer. But I can't figure out how where to insert the "LEFT-TO-RIGHT MARK". Could you give more details please?
Comment 15 Khaled Hosny 2015-02-20 20:01:01 UTC
(In reply to Oribasht from comment #14)
> (In reply to Khaled Hosny from comment #12)
> > One way to achieve the desired effect (which is reasonable, since the period
> > here is not a decimal separator) is to insert ”U+200E LEFT-TO-RIGHT MARK”
> > next to the period in the numbering style options. Whether LibreOffice
> > should provide such a style by default (is an option) is a question for
> > others to answer, but IMHO we should.
> 
> Thank you for your answer. But I can't figure out how where to insert the
> "LEFT-TO-RIGHT MARK". Could you give more details please?

Inputting it directly depends on your operating system and input method, but you can use a character map application (e.g. Gucharmap) to look it up and copy it from there.
Comment 16 QA Administrators 2016-02-21 08:35:26 UTC Comment hidden (obsolete)
Comment 17 Yousuf Philips (jay) (retired) 2016-08-05 10:18:17 UTC
*** Bug 98104 has been marked as a duplicate of this bug. ***
Comment 18 meh 2016-08-05 15:13:12 UTC
The bug is still present on

 Version: 5.1.5.1
 Build ID: 1:5.1.5~rc1-1
 OS Version: Linux 4.6 (Debian testing)

In RTL, outline numbering is left to right as @Oribasht have said before.

eg. (Ignore 'ر')
                   ر       ۲- چرخه استخراج
                ر         ۲-۱ باطله برداری
                  ر         ۲-۲ آماده سازی 
                    ر         ۲-۳ آتش باری
st and nd captions:
                ر     نگاره ۲-۱: نمونه اول
                ر     نگاره ۲-۲: نمونه دوم

And in Persian books we often see '-' instead of '.'

I don't know much about unicode characters but i think if you let user change the 'dot' separator between numbers (somewhere like in 'Bullets and Numbering' > Options > Separator > Before and After), there will be no more problem in outline numbering.
Comment 19 Buovjaga 2016-08-05 15:18:17 UTC Comment hidden (off-topic)
Comment 20 meh 2016-08-05 15:21:57 UTC Comment hidden (off-topic)
Comment 21 Buovjaga 2016-08-05 15:42:43 UTC Comment hidden (off-topic)
Comment 22 QA Administrators 2018-03-06 03:43:51 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present with the latest version of LibreOffice from https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the information from Help - About LibreOffice.
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a comment that includes the information from Help - About LibreOffice.

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not 
appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so:
1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3) from http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug
3. Leave a comment with your results.
4a. If the bug was present with 3.3 - set version to 'inherited from OOo';
4b. If the bug was not present in 3.3 - add 'regression' to keyword


Feel free to come ask questions or to say hello in our QA chat: https://kiwiirc.com/nextclient/irc.freenode.net/#libreoffice-qa

Thank you for helping us make LibreOffice even better for everyone!

Warm Regards,
QA Team

MassPing-UntouchedBug