Bug Hunting Session
Bug 88975 - Direct editing capabilities (select, copy, paste, delete, ...) within the rendered formula forgotten to put into LibO 4.5 MASTER
Summary: Direct editing capabilities (select, copy, paste, delete, ...) within the ren...
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-01-31 12:46 UTC by OfficeUser
Modified: 2015-02-01 15:28 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description OfficeUser 2015-01-31 12:46:42 UTC
I just have tried master~2015-01-29_23.44.46_LibreOfficeDev_4.5.0.0.alpha0_Win_x86_en-US_de_ar_ja_ru_qtz.msi


This build is NOT able to select the rendered formula or parts of it for copy and paste. Instead this build has old StarOffice behavior where it is only possible to click elements of the formula to navigate to the corresponding part of the formula description language.

Pleas look at my screen shot of 4.4.0.3. There it is possible to select parts of the rendered formula and there is no Copy item in the context menu.

Screen shot:
https://vm150.documentfoundation.org/attachment.cgi?id=112970


Please note:
There is a bug fix requested on this feature for Libo 4.4 branch: Bug 88744
This fix should also be integrated into LibO 4.5 MASTER as soon as it becomes available.
Comment 1 Buovjaga 2015-01-31 12:57:46 UTC
I get the same behavior with all versions I tried, nothing like in your screenshot.
I only get a dotted line encircling whatever element I click, number or line..

Win 7 Pro 64-bit, LibO Version: 4.4.0.3
Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7

Version: 4.5.0.0.alpha0+
Build ID: 309574394bd4ae3e9e10e5ff0d64bdd7bbbc8b83
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-29_23:44:46

Ubuntu 14.10 64-bit Version: 4.5.0.0.alpha0+
Build ID: 8fd9c25ac66dd238d4c68be3974241a18cb21705
TinderBox: Linux-rpm_deb-x86_64@46-TDF-dbg, Branch:master, Time: 2015-01-27_22:43:15

and

Version: 4.3.3.2
Build ID: 430m0(Build:2)

Ubuntu 14.10 64-bit
LibreOffice 3.3.0 
OOO330m19 (Build:6)
tag libreoffice-3.3.0.4

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 2 V Stuart Foote 2015-01-31 21:41:24 UTC
@norbert,  ref bug 88744#c3
"LibreOffice 4 branch has a new feature where it is possible to select parts of the rendered formula. This feature is missing copy items."

Huh?

The Formula display window has NEVER provided editing actions within the rendered formula. We only provide place holder GUI. Are you thinking of some Extension?


Verified true, and consistent behavior on Windows 7 sp1, 64-bit en-US with

Version 3.6.7.2 (Build ID: e183d5b)

Version 4.0.6.2 (Build ID: 2e2573268451a50806fcd60ae2d9fe01dd0ce24)

Version: 4.2.7.2
Build ID: 933c0aa564ec4f8883ed5732c866db48dca4dac5

Version: 4.3.6.2
Build ID: d50a87b2e514536ed401c18000dad4660b6a169e

Version: 4.4.0.3
Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7
Locale: en_US

Version: 4.5.0.0.alpha0+
Build ID: 802b80fcd378d5788adff1c7c98af526651a30c2
TinderBox: Win-x86@39, Branch:master, Time: 2015-01-25_10:20:28
Locale: en_US


Selected placeholder elements in the rendered formula simply link back to corresponding code in the Math Commands window. ALL copy-paste-insert actions are done into the command window with limited GUI selection of the insertion point in the Formula display.

Within the Formula display window, we can zoom, update, or mouse click to position the Math Command window cursor, and paste with that context menu--nothing more.
Comment 3 OfficeUser 2015-02-01 11:22:32 UTC
I find the advanced formula editor functions (select / CTRL+v / CTRL+v) for the first time in the following final installer (and in it's release candidates):

LibreOffice_4.4.0_Win_x86.msi
+ LibreOffice_4.4.0_Win_x86_helppack_de.msi

I will attach a short video where you can see the feature in action as well as the about dialog and the extension manager:

https://bugs.documentfoundation.org/attachment.cgi?id=113018

==> Set keyword REGRESSION, because actually we will loose this advanced formula editor capabilities with 4.5 MASTER.
Comment 4 OfficeUser 2015-02-01 11:23:15 UTC
Typo, correct is:
(select / CTRL+c / CTRL+v)
Comment 5 Buovjaga 2015-02-01 11:44:49 UTC
Confirmed that clicking next to the element and dragging to it selects in 4.4, but not in 4.5.

Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: 4b9a9ce8a0e5e0716dad9a9ec87d16237e534dc2
TinderBox: Win-x86@39, Branch:master, Time: 2015-01-31_09:49:44
Comment 6 OfficeUser 2015-02-01 12:06:30 UTC
I have adjusted the summary since this a complete feature-set not only select, but also copy, paste, delete, ... directly within the rendered formula.
Comment 7 V Stuart Foote 2015-02-01 15:04:06 UTC
OK, so today I found out an interesting tidbit :-)

The "Visual formula editor" remains an "Experimental" feature. It must be toggled on by enabling experimental features.

Tools -> Options -> Advanced: Optional (unstable) options
  "Enable experimental features" ceckbox

or for the 3.6 builds
Tools -> Options -> General  
  "Enable experimental (unstable) features" checkbox

Check that box on and current builds of master (and all earlier builds I listed) activates the "Visual formula editor"

OK on yesterdays
Version: 4.5.0.0.alpha0+
Build ID: 4b9a9ce8a0e5e0716dad9a9ec87d16237e534dc2
TinderBox: Win-x86@39, Branch:master, Time: 2015-01-31_09:49:44
Locale: en_US