Bug Hunting Session
Bug 89011 - When activating OpenGL rendering, UI elements become black
Summary: When activating OpenGL rendering, UI elements become black
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 95008 95519 (view as bug list)
Depends on:
Blocks: OpenGL
  Show dependency treegraph
 
Reported: 2015-02-01 13:00 UTC by Silviu C.
Modified: 2016-01-15 22:15 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
broken UI scr1 (41.40 KB, image/png)
2015-02-01 13:00 UTC, Silviu C.
Details
broken UI scr2 (59.44 KB, image/png)
2015-02-01 13:01 UTC, Silviu C.
Details
OGL UI rendering still broken (129.04 KB, image/png)
2015-10-15 14:53 UTC, Silviu C.
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Silviu C. 2015-02-01 13:00:53 UTC
Created attachment 113020 [details]
broken UI scr1

When I activate the OpenGL rendering option, after restarting LO, various UI elements become black.
 
See attached screenshots
Comment 1 Silviu C. 2015-02-01 13:01:45 UTC
Created attachment 113021 [details]
broken UI scr2
Comment 2 Silviu C. 2015-02-01 13:05:48 UTC
Output for graphics info:

silviu@trusty:~$ inxi -xx -G
Graphics:  Card: NVIDIA GK106 [GeForce GTX 660] bus-ID: 01:00.0 chip-ID: 10de:11c0 
           X.Org: 1.15.1 driver: nvidia Resolution: 1440x900@59.9hz 
           GLX Renderer: GeForce GTX 660/PCIe/SSE2 GLX Version: 4.5.0 NVIDIA 346.35 Direct Rendering: Yes
Comment 3 Jorendc 2015-02-02 19:43:30 UTC
@Moggi: not sure if intrested.
Comment 4 Robinson Tryon (qubit) 2015-02-08 13:07:16 UTC
(In reply to Silviu C. from comment #0)
> Created attachment 113020 [details]
> broken UI scr1
> 
> When I activate the OpenGL rendering option, after restarting LO, various UI
> elements become black.
>  
> See attached screenshots

CONFIRMED with LO 4.4.0.3 + Ubuntu 14.04
Status -> NEW
Comment 5 Steve Murphy 2015-02-26 15:14:51 UTC
Reproduced Version: 4.4.1.2
Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
Locale: en_GB

Ububntu 14.04

I too have NVidia graphics and get this problem.  

This is especially annoying as once the problem exhibits itself, it also makes LO pretty much unsuable. It also seems impossible to correct it via the UI (none of the tickboxes are visible in settings to disable OpenGL again!).   I had to go in and manually edit my profile to make LO usable again.
Comment 6 Stephen Martin 2015-04-17 20:34:59 UTC
I am just adding that I am experiencing the same problem on arch linux 64bit, LO-fresh 4.4.2.  Disabling opengl corrects the issue.

Like others, I am using nvidia.

Graphics:  Card: NVIDIA GT218M [NVS 3100M] bus-ID: 01:00.0 chip-ID: 10de:0a6c
           Display Server: X.Org 1.17.1 driver: nvidia Resolution: 1440x900@60.06hz, 1600x900@59.98hz
           GLX Renderer: NVS 3100M/PCIe/SSE2 GLX Version: 3.3.0 NVIDIA 340.76 Direct Rendering: Yes

Let me know if you need any other information.
Comment 7 Joel Madero 2015-10-14 03:43:41 UTC
*** Bug 95008 has been marked as a duplicate of this bug. ***
Comment 8 Michael Meeks 2015-10-15 13:35:17 UTC
Can you re-test with a recent -5-0 build that includes Tomaz' patch for bug#94384 - thanks !
Comment 9 Silviu C. 2015-10-15 14:52:14 UTC
Hello Michael,
 
I've tested with the most recent 5.0 build I could find. The problem is still there. 
 
Maybe I did not download the correct build?
 
I've attached a screenshot.
 
file name: LO_build_b16be656efc4bc379f3a4d2c95d188faac596783-GL.png
Comment 10 Silviu C. 2015-10-15 14:53:02 UTC
Created attachment 119643 [details]
OGL UI rendering still broken
Comment 11 Tomaz Vajngerl 2015-10-15 16:08:51 UTC
My patch has an effect on Windows only - the problem here seems to be on Linux with Nvidia cards - which means it is a completely different issue.
Comment 12 Alex Thurgood 2015-11-02 12:24:40 UTC
*** Bug 95519 has been marked as a duplicate of this bug. ***
Comment 13 Roland Baudin 2015-11-19 15:17:28 UTC
I see exactly the same issue on my Ubuntu 15.10 box with nvidia graphics and LibreOffice 5.0.2.2.
Comment 14 Michael Meeks 2016-01-09 18:48:44 UTC
There are so many fixes for LibreOffice 5.1.0 RC2 - that I'll mark this bug as assumed fixed; please - if you find this doesn't work with LibreOffice 5.1.0 RC2 (due out next week) can you re-open, or (more ideally) file a new bug and CC me on it ! =)

Thanks!
Comment 15 Silviu C. 2016-01-09 19:02:59 UTC
Yup, I will test and report when 5.1.0  RC2 is out
Comment 16 Silviu C. 2016-01-15 22:15:11 UTC
I tested and LO now crashes on launch with OGL enabled. Filed this bug report:
 
https://bugs.documentfoundation.org/show_bug.cgi?id=97160