Bug 89019 - Editing. Moving sheet causes label to go undefined
Summary: Editing. Moving sheet causes label to go undefined
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.8.2 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-01 18:08 UTC by dwyoung
Modified: 2015-04-11 13:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
For demonstration of bug by following steps given in description. (12.99 KB, application/vnd.oasis.opendocument.spreadsheet)
2015-02-01 18:08 UTC, dwyoung
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dwyoung 2015-02-01 18:08:55 UTC
Created attachment 113030 [details]
For demonstration of bug by following steps given in description.

Moving a sheet changes the evaluation of references to labels. It should not. This is demonstrated by performing the following steps on attached file LabelRelSheetAddress.ods.
1. "Edit > Sheet > Move/Copy (Copy is preselected) > Insert before Sheet1 > OK"
2. On the new sheet "Sheet1_2", the cell B2 is evaluated to "#NAME?". The reference to 'label1' seems to be the problem even though "Insert > Names > Labels" shows that 'label1' is defined as column label $Sheet1.$A$1.
3. "Edit > Sheet > Move/Copy (Move)  > -move to end position- > OK". Now on "Sheet1_2", cell B2 is evaluated to 303. Moving the sheet shouldn't change the evaluation of references to labels.

Please see related Bug 88963, Bug 88979,
Comment 1 Tim Lloyd 2015-02-01 20:48:07 UTC
I can confirm these findings in Fedora 21

Version: 4.5.0.0.alpha0+
Build ID: d1c9bd13ec7af93f5368dfda6d6d3c955f0b0816
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-01-28_01:15:30
Locale: en_AU
Comment 2 raal 2015-02-03 13:11:03 UTC
(In reply to Tim Lloyd from comment #1)
> I can confirm these findings in Fedora 21
> 
Confirmed -> Setting to NEW. OS = All
Comment 3 Matthew Francis 2015-04-11 13:29:25 UTC
If you enable:
Tools - Options - LibreOffice Calc - Calculate - General Calculations - Automatically find column and row labels

you should find that this works as you would expect.