Bug 89026 - The text in dropdown buttons (like linespacing and kerning) are not editable using the keyboard when selecting a custom value
Summary: The text in dropdown buttons (like linespacing and kerning) are not editable ...
Status: RESOLVED DUPLICATE of bug 76002
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.6.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sidebar-Properties
  Show dependency treegraph
 
Reported: 2015-02-01 21:45 UTC by Francisco
Modified: 2016-10-24 15:45 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Francisco 2015-02-01 21:45:44 UTC
As the title describes, when selecting a "custom" linespacing or kerning value it isn't possible to manually set a specific value. It's only possible to select a value with the arrows of the text box, or the mouse well.

This affects the sidebar buttons from LibO 4.2 and above and also the new linespacing button in the format toolbar in LibO 4.4.

Steps to reproduce:

1) Create a new text document

2) Using the sidebar, change the paragraph linespacing (or a word kerning) into "custom". It could be "proportional", "fixed", etc, for linespacing, or any option that seems to let you fix a value in the textbox. For kerning, any of the 2 options (expanded/condensed) are the same.

3) Try to type a specific value in the textbox


Actual results:

Although the cursor changes into "input text", the textbox isn't clickeable and is not possible to set a specific value.


Expected

It should be possible to set a specific value, as when opening the format dialog window.
Comment 1 Robinson Tryon (qubit) 2015-02-02 14:41:08 UTC
One for ux-advise to triage
Status -> NEW
Comment 2 Francisco 2015-03-21 15:34:36 UTC
I can't reproduce this bug under Windows 7 x86, so I think it's platform-dependent.
Comment 3 Adolfo Jayme Barrientos 2015-04-22 18:30:24 UTC
Sorry, but I think this one is obvious. This doesn’t need any design resolution.
Comment 4 Yousuf Philips (jay) (retired) 2015-04-22 23:04:03 UTC
The sidebar was introduced in 4.1, so it also affects that as well.

I can confirm this behaviour in master that the spin control fields allow you to click the up and down arrows but you cant select the fields text and type in it. I can reproduce this bug also on Windows 7 64-bit.

Version: 5.0.0.0.alpha1+
Build ID: badec7478035008f514e0976a94438fe2e32dc40
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2015-04-22_00:50:58
Comment 5 Yousuf Philips (jay) (retired) 2015-04-22 23:24:38 UTC
As this primarily affects the sidebar, i'm setting it as part of the sidebar meta bug.
Comment 6 Francisco 2015-05-01 21:26:40 UTC
(In reply to Yousuf (Jay) Philips from comment #4)
> The sidebar was introduced in 4.1, so it also affects that as well.
> 
> I can confirm this behaviour in master that the spin control fields allow
> you to click the up and down arrows but you cant select the fields text and
> type in it. I can reproduce this bug also on Windows 7 64-bit.
> 
> Version: 5.0.0.0.alpha1+
> Build ID: badec7478035008f514e0976a94438fe2e32dc40
> TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2015-04-22_00:50:58

Jay, I can't reproduce this bug on Windows 8.1, x64 using LibO 4.3.7. I manage to perfectly click on the textbox to type a custom value for the character spacing.
Comment 7 Maxim Monastirsky 2015-07-07 17:35:06 UTC

*** This bug has been marked as a duplicate of bug 76002 ***