Bug 89095 - Start Center: bigger thumbnails for templates
Summary: Start Center: bigger thumbnails for templates
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: Other All
: medium enhancement
Assignee: Akshay Deep
URL:
Whiteboard: target:5.2.0 target:5.1.3
Keywords: difficultyInteresting, easyHack, skillCpp, topicUI
: 92496 (view as bug list)
Depends on:
Blocks: Start-Center
  Show dependency treegraph
 
Reported: 2015-02-03 19:07 UTC by Amir Adar
Modified: 2017-02-14 08:57 UTC (History)
11 users (show)

See Also:
Crash report or crash signature:


Attachments
thumbnails in start center and template manager (55.53 KB, image/png)
2015-02-10 23:22 UTC, Yousuf Philips (jay) (retired)
Details
recent files preview in startcenter (530.46 KB, image/png)
2016-02-17 18:49 UTC, bordfeldt
Details
templates preview in startcenter (161.62 KB, image/png)
2016-02-17 18:50 UTC, bordfeldt
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Amir Adar 2015-02-03 19:07:40 UTC
The new template selection screen of LibreOffice's start centre is very nice, however I believe it could use bigger thumbnails for the templates. The icon boundaries for each template are rather large, and there is plenty more room the icons can occupy, so I feel it's a shame to waste all that space.
Comment 1 Buovjaga 2015-02-07 09:28:29 UTC
Let's throw this to the design team.
Comment 2 Robinson Tryon (qubit) 2015-02-08 01:50:07 UTC
(In reply to Beluga from comment #1)
> Let's throw this to the design team.
Status -> NEW
Comment 3 Yousuf Philips (jay) (retired) 2015-02-10 23:22:11 UTC
Created attachment 113301 [details]
thumbnails in start center and template manager

The template thumbnails are being pulled from the template manager dialog, so yes the icons there are to small for the start center.
Comment 4 Yousuf Philips (jay) (retired) 2015-07-02 14:17:01 UTC
*** Bug 92496 has been marked as a duplicate of this bug. ***
Comment 5 V Stuart Foote 2015-07-02 14:36:00 UTC
Yes, it looks like the thumbnail of each template needs a 2x - 2.5x scaling to better fit into preview object.

The thumbnails are sized OK while shown within their category, but then navigating into the category, e.g. Bussiness Correspondence, Presentation Backgrounds, etc., the rendered thumbnails need to scaled larger on each selectable Template object.
Comment 6 Jan Holesovsky 2015-11-04 18:49:50 UTC
The size is defined in

include/sfx2/templateabstractview.hxx

see the TEMPLATE_ITEM_MAX_WIDTH and TEMPLATE_ITEM_MAX_HEIGHT

Ideally we should use dynamic size as we do with the recent documents (see sfx2/source/control/recentdocsview.cxx - RecentDocsView constructor), so that in case the screen is small, we get smaller thumbnails, and when the screen is larger, we get larger thumbnails.
Comment 7 Robinson Tryon (qubit) 2015-12-13 11:24:08 UTC Comment hidden (obsolete)
Comment 8 Regina Henschel 2015-12-17 19:19:11 UTC
Yes, please make thumbnails larger. This is needed especially because the preview of the old template manager no longer exists.
Comment 9 bordfeldt 2016-02-17 18:46:53 UTC
LO 5.1.0.3 on Windows 10

For me this should be solved too, because I'm often using templates. I added too screenshots: one of the recent-files-preview in startcenter (which is ok) and one of the templates-preview in startcenter (which is too small). Espacially on high-resolution displays its a real pain.
Comment 10 bordfeldt 2016-02-17 18:49:49 UTC
Created attachment 122740 [details]
recent files preview in startcenter
Comment 11 bordfeldt 2016-02-17 18:50:26 UTC
Created attachment 122741 [details]
templates preview in startcenter
Comment 12 Robinson Tryon (qubit) 2016-02-18 14:51:32 UTC Comment hidden (obsolete)
Comment 13 Commit Notification 2016-04-11 09:27:39 UTC
Akshay Deep committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2e6ed7e0a0f7395d548cbbff71cb72ba32d10309

tdf#89095 Start Center: bigger thumbnails for templates

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Commit Notification 2016-04-12 08:56:12 UTC
Akshay Deep committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8e65e1f91f23ff8ea34617c7fdacd933de0fad18&h=libreoffice-5-1

tdf#89095 Start Center: bigger thumbnails for templates

It will be available in 5.1.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 15 steve -_- 2016-04-12 09:18:24 UTC
verified w Version: 5.2.0.0.alpha0+
Build ID: 0a8abaadf322dca5628c6e62eb18b19394995c40
CPU Threads: 4; OS Version: Mac OS X 10.11.4; UI Render: default; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2016-04-12_05:42:52
Locale: de-DE (de.UTF-8)

Another StartCenter nuisance down - thanks Akshay!