Bug 89152 - Scanner dialog is not localized
Summary: Scanner dialog is not localized
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
4.4.0.0.beta2
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.0.0 target:4.4.4
Keywords: notBibisectable, regression
Depends on:
Blocks:
 
Reported: 2015-02-05 22:33 UTC by Stanislav Horacek
Modified: 2015-12-17 10:58 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
scanner dialog in 4.4 with key IDs (35.74 KB, image/png)
2015-02-05 22:33 UTC, Stanislav Horacek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stanislav Horacek 2015-02-05 22:33:19 UTC
Created attachment 113159 [details]
scanner dialog in 4.4 with key IDs

In Writer, choose Insert - Media (or Image prior to 4.4) - Scan - Select source.

The Scanner dialog appears - it is not localized in 4.4 series (checked in 4.4 beta 2 and 4.4.0), in 4.2.7 it is fully localized (4.3 series not tested).
Comment 1 Adolfo Jayme 2015-02-06 04:31:09 UTC
FTR, I can’t confirm this issue when using the Spanish locale.
Comment 2 Adolfo Jayme 2015-02-06 04:32:37 UTC
Is there any reason you’re reporting a bug about an obsolete build (beta2) when the newer, final RC3 is already available?
Comment 3 Stanislav Horacek 2015-02-06 17:08:00 UTC
Beta 2 is the earliest buggy version (of those I tested), I tried 4.4.0 final too as stated in my report. The Spanish locale gives me the same result.

I should have added that it happens on Ubuntu 14.04, in Windows 7 I get different dialog with a list of sources. I guess it might also depend on available scanners and drivers - I have no one installed.
Comment 4 raal 2015-02-28 19:33:08 UTC
Looks correct with Version: 4.4.1.0.0+
Build ID: 87dc0ee13feb8f1d6031ac77465141b9636c18d6
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:libreoffice-4-4, Time: 2015-02-09_10:17:21
Comment 5 Stanislav Horacek 2015-03-18 16:13:48 UTC
I can't confirm it. In 4.4.2.1, I still see the dialog unstranslated.
Comment 6 Jean-Baptiste Faure 2015-03-29 19:51:02 UTC
Reproducible for me with LibreOffice 4.4.3.0.0+ with French UI built at home under Ubuntu 14.10.

Best regards. JBF
Comment 7 Robinson Tryon (qubit) 2015-03-31 16:13:53 UTC
(In reply to Jean-Baptiste Faure from comment #6)
> Reproducible for me with LibreOffice 4.4.3.0.0+ with French UI built at home
> under Ubuntu 14.10.

Whiteboard -> notBibisectable (lang packs not included in bibisect)
Comment 8 Jean-Baptiste Faure 2015-03-31 19:05:14 UTC
(In reply to Robinson Tryon (qubit) from comment #7)
> (In reply to Jean-Baptiste Faure from comment #6)
> > Reproducible for me with LibreOffice 4.4.3.0.0+ with French UI built at home
> > under Ubuntu 14.10.
> 
> Whiteboard -> notBibisectable (lang packs not included in bibisect)

Not sure if the problem is in the lang packs. Indeed all dialogs available in Pootle have been translated in French and this dialog is not translated. Does that mean that the strings in this dialog are not translatable?

Best regards. JBF
Comment 9 Commit Notification 2015-04-30 21:20:45 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=415c62dc3c3e66f837ec0c89c5bc2d65e17641a7

tdf#89152 add missing .ui localizations to install script

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2015-05-01 01:36:00 UTC
Andras Timar committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=13cbbea83019906201a4a4bb193c2fbfaf1f2b11&h=libreoffice-4-4

tdf#89152 add missing .ui localizations to install script

It will be available in 4.4.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Robinson Tryon (qubit) 2015-12-17 10:58:36 UTC
Migrating Whiteboard tags to Keywords: (notBibisectable)
[NinjaEdit]