Bug 89175 - LibreOffice Viewer for Android does not open password-protected files
Summary: LibreOffice Viewer for Android does not open password-protected files
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Android Viewer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: ARM Android
: medium enhancement
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard: v14/15
Keywords:
: 89892 96776 96777 96779 96781 (view as bug list)
Depends on:
Blocks: mabAndroid
  Show dependency treegraph
 
Reported: 2015-02-06 14:57 UTC by Jan Holesovsky
Modified: 2017-09-01 12:53 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Holesovsky 2015-02-06 14:57:00 UTC
So far we cannot open password protected files - the UI to enter the password is missing so far, unfortunately
Comment 1 Christian Lohmaier 2015-10-03 20:23:48 UTC
*** Bug 89892 has been marked as a duplicate of this bug. ***
Comment 2 Jim Mayer 2015-10-31 15:32:12 UTC
For what it's worth, access to password protected documents is the single feature that would get me to start using this application. I have a small number of documents that I'd like to store in various "cloud" services (Google Drive, Dropbox, etc.). Some are spreadsheets, some regular documents, but all either are, or could be, handled nicely by Libreoffice. I could use a general encryption package like Boxcryptor, but password protecting individual documents would be a lot more convenient for me. Thanks!
Comment 3 QA Administrators 2016-11-08 12:09:21 UTC Comment hidden (obsolete, spam)
Comment 4 Yuri 2017-01-04 04:24:17 UTC
I can confirm that so far (2017-01-04) the LOVA (LibreOffice Viewer for Android) app is still unable to open password-protected files.

I've just installed LOVA's latest version (V8) on my Android smartphone (Motorola RAZR HD, model XT925, ARM CPU, Android OS version 4.4.2, phone's tech specs available at http://www.phonearena.com/phones/Motorola-RAZR-HD_id7486) and attempted to open some password-protected files (ODS and ODT files). In all cases, the same thing happened: after I selected which password-protected file I wanted to open, the LOVA's GUI closed (crashed, apparently), instead of showing me the window/field where I was supposed to provide the unlocking password.
Comment 5 Rexy 2017-02-24 09:15:16 UTC
Hi,
I confirm this bug with exactly the same behaviour as described by YURI.
My system : Moto G+ - Android 6.0.1
Libreoffice Viewer version 5.3.0.0.alpha1+ BuilID 4136757
Comment 6 Christian Lohmaier 2017-09-01 12:47:56 UTC
a fix has been committed to the repository.
https://cgit.freedesktop.org/libreoffice/core/commit/?id=43f5161991cffedabb280a6e4e388c5bcbac4f96

(so will be available with next update)
Comment 7 Christian Lohmaier 2017-09-01 12:53:03 UTC
*** Bug 96776 has been marked as a duplicate of this bug. ***
Comment 8 Christian Lohmaier 2017-09-01 12:53:13 UTC
*** Bug 96777 has been marked as a duplicate of this bug. ***
Comment 9 Christian Lohmaier 2017-09-01 12:53:30 UTC
*** Bug 96779 has been marked as a duplicate of this bug. ***
Comment 10 Christian Lohmaier 2017-09-01 12:53:40 UTC
*** Bug 96781 has been marked as a duplicate of this bug. ***