Bug 89182 - Comment indicator obscures cell contents
Summary: Comment indicator obscures cell contents
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:5.0.0 target:4.4.4
Keywords:
: 91372 (view as bug list)
Depends on: 81032
Blocks: Calc-Comments
  Show dependency treegraph
 
Reported: 2015-02-06 17:56 UTC by rebelxt
Modified: 2017-10-22 19:38 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Red squares obscuring numerals (4.76 KB, image/png)
2015-03-26 14:03 UTC, 7qia0tp02
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rebelxt 2015-02-06 17:56:41 UTC
VIEWING: The size and position of the comment indicator (the red dot) has been changed in LO 4.4.0.3. Presumably this is to make it more visible, which it does. However, it also partially obscures the right-most character if the cell contents are right-aligned. This can make the cell unreadable. For example, lower case b, d, and u are indistinguishable (default font, Windows 8.1).

It is possible to do a work-around with formatting on the cell, but if there are a lot of comments, this becomes a real pain.
Comment 1 A (Andy) 2015-02-06 20:33:34 UTC
Reproducible with LO 4.4.0.3, Win 8.1.
Comment 2 Cor Nouws 2015-02-06 22:18:49 UTC
strange enough, not included in the release notes ..
Comment 3 rebelxt 2015-02-08 15:30:06 UTC
Would it be reasonable to put the comment indicator in the left corner if the cell contents are right-aligned?
Comment 4 7qia0tp02 2015-03-26 14:03:43 UTC
Created attachment 114379 [details]
Red squares obscuring numerals

I like that the new red squares are more visible, but they obscure numbers.

Can they be made partially transparent?
Comment 5 raal 2015-05-19 06:41:03 UTC
*** Bug 91372 has been marked as a duplicate of this bug. ***
Comment 6 Laurent Godard 2015-05-19 07:06:57 UTC
offending commit

draw white border around note marks for fdo#81032

http://cgit.freedesktop.org/libreoffice/core/commit/?id=902b7e9f192fab45cffc35d81cd0df0373a610ed
Comment 7 Commit Notification 2015-05-19 15:50:38 UTC
Laurent Godard committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=2d1abfff0156c17cdaabf27c01e92b5e3f0bbbf4

draw Note mark before text for correct ZOrder tdf#89182

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 helplibreoffice 2015-05-19 19:10:25 UTC
Recommendation: Remove the white border and change the comment indicator from a square to a right triangle.  This will dramatically reduce the obscured area.

Can also add an alpha value to the comment indicator to make it translucent.
Comment 9 Commit Notification 2015-05-20 11:25:52 UTC
Laurent Godard committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ab6ea2f8e73c4a0785bb2a6b256fc521ee120d98&h=libreoffice-4-4

draw Note mark before text for correct ZOrder tdf#89182

It will be available in 4.4.4.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Laurent Godard 2015-05-20 11:29:27 UTC
I put this bug as FIXED as the patch responds to initial report

For other Note marks modifications, please open a new issue as "enhancement request" and ping UX guys
Comment 11 helplibreoffice 2015-05-20 19:01:08 UTC
Thanks Laurent.

I added an enhancement request as Bug #91415.

Do you mind pinging the others?
Comment 12 helplibreoffice 2015-10-23 07:14:02 UTC
LO Calc 5.0.2 (release) still draws the white border around each comment indicator.  Offending code identified by Laurent in comment #6.

My understanding is the patch in comment #9 was supposed to fix this.

Setting status to REOPENED.
Comment 13 tommy27 2015-12-21 18:47:16 UTC
"red squares" are now semi-transparent so they do not hide anymore the cell text a s in the original screenshot

I set status to RESOLVED WORKSFORME

tested under Win8.1 x64 using LibO 5.0.3.1