Bug 89193 - 4.4 Release Loses Footer Background Image
Summary: 4.4 Release Loses Footer Background Image
Status: RESOLVED DUPLICATE of bug 88337
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Michael Stahl
QA Contact:
URL:
Whiteboard: odf target:4.4.3 target:5.0.0
Keywords: bisected
Depends on:
Blocks:
 
Reported: 2015-02-07 04:30 UTC by David Barton
Modified: 2015-04-16 21:10 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description David Barton 2015-02-07 04:30:34 UTC
All my footer background images are lost in the upgrade from 4.3 to 4.4 (when the document is opened).

This is trivial to reproduce:
1. Create a document
2. Add a footer
3. Format the footer background
4. Select a background image either linked or embedded
5. The background image appears
6. If you open up the background settings, the background is lost, but still visible.
7. Save the document and re-open it.  Your background is lost.

Old documents from 4.3 open correctly, but as soon as they are saved the image is lost.

This is a critical bug for me and means I have to revert to 4.3
Comment 1 Jean-Baptiste Faure 2015-02-07 17:54:11 UTC
Reproducible for me with LibreOffice 4.4.1.0.0+ built at home under Ubuntu 14.10 x86-64.
Works as expected with filling color but not with background image.

Best regards. JBF
Comment 2 Cor Nouws 2015-03-02 20:13:32 UTC
Hi David,

Works fine for me in 4.4.1.2 on Ubuntu.
Can you pls check in that version too?

thanks - Cor
Comment 3 Michael Stahl 2015-04-14 15:46:32 UTC
confirmed

regression from commit 7d9bb549d498d6beed2c4050c402d09643febdfa

footer background image loss is due to same problem as page style background image loss

*** This bug has been marked as a duplicate of bug 88337 ***
Comment 4 Commit Notification 2015-04-14 20:05:06 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d2c490fb9f4b2b6b63b82c4ba26df9a3672f9d55&h=libreoffice-4-4

tdf#88337 tdf#89193: sw: add missing SwXPageStyle properties

It will be available in 4.4.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2015-04-16 21:10:08 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=662b368fd204066f2668c27e18f11ef9434d674a

tdf#88337 tdf#89193: sw: add missing SwXPageStyle properties

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.