Download it now!
Bug 89196 - PRINTING: Printing or PDF Export fails to shipout numeric values in tables created with elder versions
Summary: PRINTING: Printing or PDF Export fails to shipout numeric values in tables cr...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:pdf
Depends on:
Blocks: PDF-Export
  Show dependency treegraph
 
Reported: 2015-02-07 10:09 UTC by Jürgen Mähnß
Modified: 2017-10-31 06:50 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
testfiles for printing and corresponding pdf-exports (55.61 KB, application/x-zip-compressed)
2015-02-07 10:09 UTC, Jürgen Mähnß
Details
pdf export with LibreOffice Calc 4.4 (45.85 KB, application/pdf)
2015-02-07 16:14 UTC, Jean-Baptiste Faure
Details
Screenshot (194.08 KB, image/png)
2015-02-07 16:47 UTC, m.a.riosv
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jürgen Mähnß 2015-02-07 10:09:03 UTC
Created attachment 113198 [details]
testfiles for printing and corresponding pdf-exports

In a simple file numeric values are not send to printer or pdf-export. Alphabetic characters are printed.
I tried to find out if this is related to formating but couldn't find any effect. The file worked nicely with LO 4.3.5.2. (print1)

When I create a new spreadsheet with LO 4.4.0.3 the printing works. (print2)
Comment 1 Jean-Baptiste Faure 2015-02-07 16:14:48 UTC
Created attachment 113206 [details]
pdf export with LibreOffice Calc 4.4

Not reproducible for me with LibreOffice 4.4.1.0.0+ built at home under Ubuntu 14.10 x86-64. PDF export attached.

Best regards. JBF
Comment 2 raal 2015-02-07 16:36:27 UTC
I can confirm with LO Version: 4.5.0.0.alpha0+
Build ID: 20deac4903fc0697477e855feeff482b3da234f9
TinderBox: Win-x86@42, Branch:master, Time: 2015-01-29_23:02:41

When I change font to Arial, then I can export correct PDF. Original font is MS Sans Serif
Comment 3 raal 2015-02-07 16:37:31 UTC
Win only issue, I can export PDF in Linux
Comment 4 m.a.riosv 2015-02-07 16:47:42 UTC
Created attachment 113209 [details]
Screenshot

I think the issue it that LibreOffice doesn't recognize properly Ms Sans Serif, the letter in the file, even I have the font installed. Screenshot shows the installed fonts and the LibreOffice list for selecting.

Win7x64
Version: 4.4.0.3 Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7

Changing the font for Microsoft Sans Serif works right for me.
Comment 5 QA Administrators 2016-02-21 08:37:28 UTC Comment hidden (obsolete)
Comment 6 Jürgen Mähnß 2016-02-26 15:25:53 UTC
Problem still exists with Version: 5.1.0.3 (x64)
Build-ID: 5e3e00a007d9b3b6efb6797a8b8e57b51ab1f737
Solution provided in comment #4 works
Comment 7 QA Administrators 2017-10-30 08:31:26 UTC Comment hidden (obsolete)
Comment 8 Jürgen Mähnß 2017-10-30 11:24:02 UTC
The problem stems from an invalid character set (ms sans-serif) which is no longer supportet. Just reset the formatting to standard and it works.