Bug 89199 - CONDITIONAL FORMATTING: Data bars without values
Summary: CONDITIONAL FORMATTING: Data bars without values
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.5.0.0.alpha0+ Master
Hardware: Other All
: medium enhancement
Assignee: Katarina Behrens (CIB)
QA Contact:
URL:
Whiteboard: target:5.0.0
Keywords:
Depends on:
Blocks: Conditional-Formatting
  Show dependency treegraph
 
Reported: 2015-02-07 11:43 UTC by Yousuf Philips (jay)
Modified: 2015-05-21 15:48 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) 2015-02-07 11:43:06 UTC
I had mentioned in bug 87356 comment 2 that it would be useful to have conditional formatting data bars with the hiding of the underlying values from the cells. I had noticed this feature in Excel's dialog (attachment 110901 [details]) as a checkbox called 'Show Bar Only'.

This feature is available in Excel 2010+ and having this feature would also improve MSO compatibility.
Comment 1 A (Andy) 2015-02-07 15:53:31 UTC
For me this sounds reasonable and good, especially if it also increases the compatibility with MSO.
Comment 2 Markus Mohrhard 2015-02-10 20:34:40 UTC
This feature is implemented and just not available in the UI.
Comment 3 Yousuf Philips (jay) 2015-02-10 21:15:04 UTC
Thanks Markus for the info. I just confirmed that importing an xlsx file with data bars without values is imported correctly, and exporting it as an ods also retains the valueless fields, but there is no means of turning the values on after doing so in LO's UI.

So all that is necessary is adding a checkbox to the dialog (attachment 109791 [details]) to add the necessary functionality.
Comment 4 Commit Notification 2015-04-09 08:55:05 UTC
Katarina Behrens committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=1627f39768be588368744f9addc7745092ca4e50

tdf#89199: UI option to show data bar only (no values)

It will be available in 5.0.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Katarina Behrens (CIB) 2015-04-10 20:37:37 UTC
(forgot to assign to myself)
Comment 6 Mike §chinagl 2015-05-21 15:48:57 UTC
This bug fix is mentioned in the release notes of the coming LibreOffice 5.0 (see release notes https://wiki.documentfoundation.org/ReleaseNotes/5.0). Therefore it would be wonderful if this feature really worked well, otherwise it should not be mentioned in the release notes. In the notes it reads:

UI for Data bars without showing their underlying values. (feature without UI has been available since 3.6) tdf#89199 (Katarina Behrens)