Bug 89244 - AutoFilter on merged cells is empty
Summary: AutoFilter on merged cells is empty
Status: RESOLVED DUPLICATE of bug 43958
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.5.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:7.2.0
Keywords:
: 114723 (view as bug list)
Depends on:
Blocks: AutoFilter Calc-Merge-Split
  Show dependency treegraph
 
Reported: 2015-02-09 06:46 UTC by Inno
Modified: 2021-01-27 11:39 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file for testing. Apply autofilter on A1. (7.51 KB, application/vnd.oasis.opendocument.spreadsheet)
2021-01-27 10:11 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Inno 2015-02-09 06:46:13 UTC
1. Open Spreadsheet.

2. Enter something into A1 and A3, leave A2 blank.

3. Select A1-A2 and merge cells.

4. With A1 in focus, from the menu-bar, select Data > Filter > AutoFilter.

5. Use drop down button on A1 to display filter options. [Note the null list! It is supposed to display A3 value]

6. Click "Show only current item" or "Hide only current item" to produce the crash.
Comment 1 raal 2015-02-09 12:14:20 UTC
I can confirm with LO 4.4, win7
Comment 2 Julien Nabet 2015-02-09 21:14:01 UTC
For the record, since it's a Windows marked bug, on pc Debian x86-64 with master sources updated today, I could reproduce the null list but not the crash.
Comment 3 Julien Nabet 2015-12-05 00:19:24 UTC Comment hidden (obsolete)
Comment 4 QA Administrators 2017-01-03 19:42:16 UTC Comment hidden (obsolete)
Comment 5 Xisco Faulí 2017-02-27 12:38:55 UTC
I can no longer reproduce the crash in

Versión: 5.3.0.3
Id. de compilación: 7074905676c47b82bbcfbea1aeefc84afe1c50e1
Subpr. de CPU: 1; Versión de SO: Windows 6.1; Repr. de IU: predet.; Motor de trazado: HarfBuzz; 
Configuración regional: es-ES (es_ES); Calc: group

updating the summary accordantly
Comment 6 Julien Nabet 2017-02-27 12:55:03 UTC Comment hidden (obsolete)
Comment 7 Julien Nabet 2017-02-27 12:56:51 UTC Comment hidden (obsolete)
Comment 8 raal 2017-12-28 11:28:40 UTC
*** Bug 114723 has been marked as a duplicate of this bug. ***
Comment 9 QA Administrators 2018-12-29 03:49:48 UTC Comment hidden (obsolete)
Comment 10 Timur 2018-12-31 16:18:03 UTC
Repro in 6.3+ as described.
Comment 11 NISZ LibreOffice Team 2021-01-27 10:11:56 UTC
Created attachment 169176 [details]
Example file for testing. Apply autofilter on A1.

I can't reproduce the problem in 7.1 since:

https://cgit.freedesktop.org/libreoffice/core/commit/?id=605b4ba57b2daa447af9d43d3759079e15df8148

author	Attila Szűcs <szucs.attila3@nisz.hu>	2020-09-18 12:59:38 +0200
committer	László Németh <nemeth@numbertext.org>	2020-09-30 10:32:30 +0200

tdf#43958 sc: fix fill by selecting merged cell
Comment 12 NISZ LibreOffice Team 2021-01-27 10:12:51 UTC
Thanks Attila for making this one also go away :)

*** This bug has been marked as a duplicate of bug 43958 ***
Comment 13 Commit Notification 2021-01-27 11:39:32 UTC
Xisco Fauli committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/757c4d2d20f5c723be5ab94f26f8faab8a617c74

tdf#89244: sc: Add UItest

It will be available in 7.2.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.