Bug 89251 - UI: Color pickers not working
Summary: UI: Color pickers not working
Status: RESOLVED DUPLICATE of bug 86198
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2015-02-09 11:42 UTC by Walid Moghrabi
Modified: 2015-02-11 04:04 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Walid Moghrabi 2015-02-09 11:42:39 UTC
I recently upgraded to LibreOffice 4.4.0 rc3 on Ubuntu 14.04 running the Gnome3 desktop (not Unity) and I'm having troubled with the color pickers for font face colors or font background colors.
These color pickers (from toolbar or sidebar) are not working, when I press the icon, it looks like "pressed" but the color selection box does not appears.
Clicking on the icon assigns the color that is set by default in the icon but you can't choose another one.

The only workaround I found is to edit the character style and from there, I can change the color.

I disabled hardware acceleration or OpenGL rendering but the problem remains.
I also removed ~/.config/libreoffice and still, the problem remains too.

I didn't had this problem on previous releases.

Sometimes, when I click on these color pickers, Gnome Shell (or X) freezes with high cpu usage for both X and Gnome Shell (Gnome 3.12)
Comment 1 Jean-Baptiste Faure 2015-02-10 18:28:22 UTC
Seems to be the same problem as bug 89006 and bug 89279

Best regards. JBF
Comment 2 Walid Moghrabi 2015-02-10 18:45:05 UTC
Just some more informations, I tried with Zukitwo them and Adwaita too ... same problem.

Tried also with a freshly created profile (new user on the system) and still, problem remains and as I said, there is not only a problem with color pickers themselves (which is already very annoying) but most of the time, it simply makes gnome shell crash (or X ... still can't figure what is really crashing).
Comment 3 Adolfo Jayme Barrientos 2015-02-11 04:03:46 UTC
You have to upgrade to Gnome Shell 3.14 for the color picker to work. It is available in Ubuntu 15.04.
Comment 4 Adolfo Jayme Barrientos 2015-02-11 04:04:04 UTC

*** This bug has been marked as a duplicate of bug 86198 ***