Bug Hunting Session
Bug 89253 - EDITING : Bitmap disappear when editing area parameters after operation (substract, combine...)
Summary: EDITING : Bitmap disappear when editing area parameters after operation (subs...
Status: RESOLVED DUPLICATE of bug 82784
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.4.0.3 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2015-02-09 12:19 UTC by Denis RADWAN
Modified: 2015-12-15 11:03 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
3 steps to show the bug (93.89 KB, application/vnd.oasis.opendocument.graphics)
2015-02-09 12:19 UTC, Denis RADWAN
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Denis RADWAN 2015-02-09 12:19:26 UTC
Created attachment 113252 [details]
3 steps to show the bug

Bonjour,

First, sorry for my english.

With Version: 4.4.0.3
Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7
Windows XP SP3

Steps to reproduce :

- In Impress or Draw, import a bitmap.
- Draw one or more shapes on it
- Select all an do an opération like combine, substract,..
- Edit the area (right-clic or menu Format)
- Don't change anything and click OK

Result :
Bitmap disappear and the object become blank.

page 3 of the attachment, i put shadow on the object.
If you directly use the toolbar for this, bitmap stay visible.


Idem with :
Version: 4.5.0.0.alpha0+
Build ID: 1845b6af3991ca5521eef48aafe1d0489e2ff8f6
… 4.3 and 4.2

work with 4.1, 3.6 and AOO 4.1.1
Comment 1 Buovjaga 2015-02-10 12:19:16 UTC
Reproduced.

Adding bibisect request.
Reporter said 4.1 works ok. I can confirm that 3.5.0 worked.

Win 7 Pro 64-bit, LibO Version: 4.4.0.3
Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7
Locale: fi_FI

Ubuntu 14.10 64-bit 
Version: 4.4.0.3
Build ID: 40m0(Build:3)
Locale: en_US

LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 2 Rostislav 'R.Yu.' Okulov 2015-02-10 13:51:32 UTC
(In reply to Denis RADWAN from comment #0)
> Steps to reproduce :
> 
> - In Impress or Draw, import a bitmap.
> - Draw one or more shapes on it
> - Select all an do an opération like combine, substract,..
> - Edit the area (right-clic or menu Format)
> - Don't change anything and click OK
> 
> Result :
> Bitmap disappear and the object become blank.

Do not understand here.

1. Edit the area (right-clic or menu Format)
What item should I choose after right click - Edit style (?)

2. Don't change anything and click OK

If number one is correct I clicked Ok button but image stayed there.
Comment 3 Buovjaga 2015-02-10 13:56:05 UTC
(In reply to Rostislav 'R.Yu.' Okulov from comment #2)
> 1. Edit the area (right-clic or menu Format)
> What item should I choose after right click - Edit style (?)

Right-click - Area
Comment 4 Rostislav 'R.Yu.' Okulov 2015-02-10 14:21:06 UTC
git bisect start
# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
git bisect bad 423a84c4f7068853974887d98442bc2a2d0cc91b
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect good 65fd30f5cb4cdd37995a33420ed8273c0a29bf00
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect good 65fd30f5cb4cdd37995a33420ed8273c0a29bf00
# good: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect good e02439a3d6297a1f5334fa558ddec5ef4212c574
# good: [4850941efe43ae800be5c76e1102ab80ac2c085d] source-hash-980a6e552502f02f12c15bfb1c9f8e6269499f4b
git bisect good 4850941efe43ae800be5c76e1102ab80ac2c085d
# bad: [a900e72b6357882284c5955bdf939bf14269f5fb] source-hash-dd1050b182260a26a1d0ba6d0ef3a6fecc3f4e07
git bisect bad a900e72b6357882284c5955bdf939bf14269f5fb
# bad: [e1d0365cd2b073a859f59ad0a4584385a66dc611] source-hash-2eea96c702a44ab009743b0d22ef639127f0b57b
git bisect bad e1d0365cd2b073a859f59ad0a4584385a66dc611
# good: [98a55bf95f3ec29298751fd8fba76dd2236dce43] source-hash-58dfc97ca697875c36b7ddf14f5505a93d7b9cf8
git bisect good 98a55bf95f3ec29298751fd8fba76dd2236dce43
# good: [1f32fb58159d7f43a4bcb838765261d5274cbf38] source-hash-4a169e4203c10ec8f76b9bcb33882c82b65c7bab
git bisect good 1f32fb58159d7f43a4bcb838765261d5274cbf38
# good: [e8547c17def5e45d1a9ff2cf5eb28b142b3daca0] source-hash-53ca207a700c9501e76c7770f6b1e3af89edd630
git bisect good e8547c17def5e45d1a9ff2cf5eb28b142b3daca0
# bad: [62e28acf6d832fb1ad030889541aad3f626612ba] source-hash-12e0102f39ee3a0398a4369bbc4af4ea0f51ca14
git bisect bad 62e28acf6d832fb1ad030889541aad3f626612ba
# bad: [ce550d732fd43380870f273e6674894d5bb1cdf2] source-hash-b634aa656a74e1f8ebeaf8a9092829294c49171d
git bisect bad ce550d732fd43380870f273e6674894d5bb1cdf2
# good: [1da81d12775c421b7a04cd3a579fa555442c35f6] source-hash-ac01fd51822dc006abec578d61d66f7a169c19cb
git bisect good 1da81d12775c421b7a04cd3a579fa555442c35f6
# first bad commit: [ce550d732fd43380870f273e6674894d5bb1cdf2] source-hash-b634aa656a74e1f8ebeaf8a9092829294c49171d


ce550d732fd43380870f273e6674894d5bb1cdf2 is the first bad commit
commit ce550d732fd43380870f273e6674894d5bb1cdf2
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Sun May 11 10:33:38 2014 +0000

    source-hash-b634aa656a74e1f8ebeaf8a9092829294c49171d
    
    commit b634aa656a74e1f8ebeaf8a9092829294c49171d
    Author:     Chris Sherlock <chris.sherlock79@gmail.com>
    AuthorDate: Fri Feb 7 22:50:28 2014 +1100
    Commit:     Caolán McNamara <caolanm@redhat.com>
    CommitDate: Fri Feb 7 20:16:23 2014 +0000
    
        Remove commented code in OutputDevice::ReMirror
    
        The following code was reimplemented in a cleaner fashion some time
        ago. However, it was just commented out and never removed. There is
        no need for it now, so removing. It's in the DVCS if it's really
        needed :-)
    
        Change-Id: Ia7d3c480ba70ccbd8dcf2808d9b712499c4cef4f
        Reviewed-on: https://gerrit.libreoffice.org/7913
        Reviewed-by: Caolán McNamara <caolanm@redhat.com>
        Tested-by: Caolán McNamara <caolanm@redhat.com>

:100644 100644 05874cf3764db72071b0d1b5d25bab8c7b5f7fb0 253114e5235f294b17b079bdbbc5aeeaae0e15b2 M      ccache.log
:100644 100644 b6d22eb23af685e0bf6f87ef3f5ef02a999ddc19 e1a110f455c5d638b61505bc8751b78557282e98 M      commitmsg
:100644 100644 a958005a2c4cd7a54b08bd25ec524930b3f5f0d3 bc63e7f72f8898a76d822c221a1fc5d1c2c91cf5 M      make.log
:040000 040000 fb4d7c258fc0eadfaeae60b239d3efd2c55e4e26 e2de3407c4f93021f77aae11d25f83026b900b1f M      opt
Comment 5 Matthew Francis 2015-02-21 15:53:47 UTC

*** This bug has been marked as a duplicate of bug 82784 ***
Comment 6 Robinson Tryon (qubit) 2015-12-15 11:03:25 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]