Bug 89264 - FILEOPEN: performance problem with particular xlsx file
Summary: FILEOPEN: performance problem with particular xlsx file
Status: RESOLVED DUPLICATE of bug 102694
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
3.6.7.2 release
Hardware: Other All
: medium major
Assignee: Not Assigned
QA Contact:
URL:
Whiteboard:
Keywords: haveBacktrace, perf
Depends on:
Blocks: Pivot-Table
  Show dependency treegraph
 
Reported: 2015-02-09 16:01 UTC by Marina Latini
Modified: 2017-06-19 13:16 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Callgrind with 5.2 (6.60 MB, application/x-xz)
2016-05-02 20:07 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marina Latini 2015-02-09 16:01:03 UTC
Content of the file: 
* Sheets: 3 (data, pivot table, cache pivot table - hidden)
* Rows: 388935
* Cells: 14906051

file: https://www.dropbox.com/s/f6rjwirdtr6pct2/Record_Pivot_qryRet_Clean.xlsx?dl=0 (~40MB)
 
MS Office 365 opens this file in ~15 seconds. 
On the same machine LibreOffice opens the file in ~30 minutes.

* Version: 3.6.7.2 
* Build ID: e183d5b
* Locale: it_IT
* OS: Windows 7 Home Premium SP1 x86
* OS: Ubuntu 14.04.2 LTS x86_64

* Version: 4.2.8.2
* Build ID: 48d50dbfc06349262c9d50868e5c1f630a573ebd
* Locale: it_IT
* OS: Windows 7 Home Premium SP1 x86
* OS: Ubuntu 14.04.2 LTS x86_64

* Version: 4.3.6.1
* Build ID: 9629686a67dd1f357477c13325e45a66f3452bb9
* Locale: it_IT
* OS: Ubuntu 14.04.2 LTS x86_64

* Version: 4.4.0.3
* Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7
* locale: it_IT
* OS: Windows 7 Home Premium SP1 x86
* OS: Ubuntu 14.04.2 LTS x86_64

* Version: 4.5.0.0.alpha0+
* Build ID: 1845b6af3991ca5521eef48aafe1d0489e2ff8f6
* TinderBox: Win-x86@42, Branch:master, Time: 2015-02-02_09:30:48
* Locale: it_IT
* OS: Windows 7 Home Premium SP1 x86

* Version: 4.5.0.0.alpha0+
* Build ID: 52d1de87e9a77fc7929309b0365bd786406ce022
* TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2015-02-04_01:50:43
* Locale: it_IT
* OS: Ubuntu 14.04.2 LTS x86_64

Office 365
* Version: 15.0.4675.1003
* Locale: it_IT
* OS: Windows 7 Home Premium SP1 x86

Hardware informations:
* CPU: Intel® Core™ i3-3227U CPU @ 1.90GHz × 4
* RAM: 4GB
Comment 1 Buovjaga 2015-02-10 11:41:07 UTC
Reproduced.

Ubuntu 14.10 64-bit
Version: 4.4.0.3
Build ID: 40m0(Build:3)
Locale: en_US
Comment 2 QA Administrators 2016-02-21 08:35:02 UTC Comment hidden (obsolete)
Comment 3 Timur 2016-04-21 18:17:51 UTC
No file. Please attach minimized. And check Bug 94792.
Comment 4 Marina Latini 2016-05-02 15:36:17 UTC
(In reply to Timur from comment #3)
> No file. Please attach minimized. And check Bug 94792.

Sorry, 
moved item :(

The new link is: https://www.dropbox.com/s/kj4hxw4a4aov687/Record_Pivot_qryRet_Clean.xlsx?dl=0
Comment 5 Buovjaga 2016-05-02 15:53:55 UTC
Still takes a couple of minutes, but on a very fast machine (Intel 6700k).
I'll do a callgrind tonight.

Arch Linux 64-bit, KDE Plasma 5
Version: 5.2.0.0.alpha1+
Build ID: 540fee2dc7553152914f7f1d8a41921e765087ef
CPU Threads: 8; OS Version: Linux 4.5; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Built on April 30th 2016
Comment 6 Buovjaga 2016-05-02 20:07:28 UTC
Created attachment 124798 [details]
Callgrind with 5.2

Arch Linux 64-bit, KDE Plasma 5
Version: 5.2.0.0.alpha1+
Build ID: 540fee2dc7553152914f7f1d8a41921e765087ef
CPU Threads: 8; OS Version: Linux 4.5; UI Render: default; 
Locale: fi-FI (fi_FI.UTF-8)
Built on April 30th 2016
Comment 7 Yousuf Philips (jay) 2016-10-21 10:51:22 UTC
Hi Marina,

File is gone again. I think the issue maybe fixed with bug 102694.
Comment 8 Marina Latini 2017-06-19 13:07:23 UTC
(In reply to Yousuf Philips (jay) from comment #7)
> Hi Marina,
> 
> File is gone again. I think the issue maybe fixed with bug 102694.

Hi Jay,
the file is here: https://www.dropbox.com/s/wl00ezo589v50nm/Record_Pivot_qryRet_Clean.xlsx?dl=0

and seems to be quite usable with LibreOffice. ;)

Tested on:

Version: 6.0.0.0.alpha0+
Build ID: c50ae538a6656889c68c43bd9fe0347c61c82aa5
CPU threads: 4; OS: Windows 6.1; UI render: default; 
TinderBox: Win-x86@42, Branch:master, Time: 2017-06-18_23:58:50
Locale: it-IT (it_IT); Calc: group
Comment 9 Buovjaga 2017-06-19 13:16:09 UTC
Ok, let's do a speculative duping.

*** This bug has been marked as a duplicate of bug 102694 ***